fonction MOIS()

Le
Greg
Bonjour,

J'utilise dans un tableau la fonction MOIS() à partir d'une date dans une
autre cellule.

Comme vous le savez, cette fonction renvoie le numéro du mois. Je voudrais
que ce soit le nom du mois qui s'affiche.

ex simplifié :

MOIS(12/05/2009) = 5 mais je voudrais MAI

quand j'utilise le format de cellule "mmm" il considère le 5 comme
05/01/1900 donc le format donne JANV

Y a t'il une autre solution?

Merci

(j'espère avoir été clair)

Greg
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Patrednef
Le #20705281
Bonjour Greg,

Pour convertir une date qui est en A1 en nom de mois (comme mai dans
ton exemple) il suffit de saisir en B1:

=TEXTE(A1;"mmmm")
Tu peux agrémenter cela de diverses fonctions comme Ucase si tu
souhaite "MAI" ........

Bon dimanche

Pat Rednef
Jacky
Le #20705271
Bonjour,

Y a t'il une autre solution?


La date en A1 dans l'exemple

Dans une cellule
¡
Cellule au format personnalisée mmmm
ou
=MAJUSCULE(TEXTE(A1;"mmmm"))
ou
=NOM(TEXTE(A1;"mm"))
--
Salutations
J'


"Greg" %
Bonjour,

J'utilise dans un tableau la fonction MOIS() à partir d'une date dans une
autre cellule.

Comme vous le savez, cette fonction renvoie le numéro du mois. Je voudrais
que ce soit le nom du mois qui s'affiche.

ex simplifié :

MOIS(12/05/2009) = 5 mais je voudrais MAI

quand j'utilise le format de cellule "mmm" il considère le 5 comme
05/01/1900 donc le format donne JANV

Y a t'il une autre solution?

Merci

(j'espère avoir été clair)

Greg



FS
Le #20705261
Bonjour,

Par exemple, avec 12/5/2009 en A1 :

=MAJUSCULE(TEXTE(A1;"mmmm"))

FS
--
Frédéric SIGONNEAU
Modules et modèles pour Excel :
http://frederic.sigonneau.free.fr/

Greg a écrit :
Bonjour,

J'utilise dans un tableau la fonction MOIS() à partir d'une date dans
une autre cellule.

Comme vous le savez, cette fonction renvoie le numéro du mois. Je
voudrais que ce soit le nom du mois qui s'affiche.

ex simplifié :

MOIS(12/05/2009) = 5 mais je voudrais MAI

quand j'utilise le format de cellule "mmm" il considère le 5 comme
05/01/1900 donc le format donne JANV

Y a t'il une autre solution?

Merci

(j'espère avoir été clair)

Greg



Jacky
Le #20705251
Tien.... il a supprimer "propre" ;o))

=NOMPROPRE(TEXTE(A1;"mmmm"))
et non pas
=NOM(TEXTE(A1;"mm"))
--
Salutations
JJ


"Jacky" %
Bonjour,

Y a t'il une autre solution?


La date en A1 dans l'exemple

Dans une cellule
¡
Cellule au format personnalisée mmmm
ou
=MAJUSCULE(TEXTE(A1;"mmmm"))
ou
=NOM(TEXTE(A1;"mm"))
--
Salutations
J'


"Greg" %
Bonjour,

J'utilise dans un tableau la fonction MOIS() à partir d'une date dans
une autre cellule.

Comme vous le savez, cette fonction renvoie le numéro du mois. Je
voudrais que ce soit le nom du mois qui s'affiche.

ex simplifié :

MOIS(12/05/2009) = 5 mais je voudrais MAI

quand j'utilise le format de cellule "mmm" il considère le 5 comme
05/01/1900 donc le format donne JANV

Y a t'il une autre solution?

Merci

(j'espère avoir été clair)

Greg







mugrec75
Le #20705421
bonjour Greg,

date en A2
formule en B2 =TEXTE(DATE(ANNEE(A2);MOIS(A2);1);"mmm")

amicalement

"Greg" wrote:

Bonjour,

J'utilise dans un tableau la fonction MOIS() à partir d'une date dans une
autre cellule.

Comme vous le savez, cette fonction renvoie le numéro du mois. Je voudrais
que ce soit le nom du mois qui s'affiche.

ex simplifié :

MOIS(12/05/2009) = 5 mais je voudrais MAI

quand j'utilise le format de cellule "mmm" il considère le 5 comme
05/01/1900 donc le format donne JANV

Y a t'il une autre solution?

Merci

(j'espère avoir été clair)

Greg

.



Greg
Le #20705411
Merci à tous ça marche nickel
bon dimanche

"Greg" news:%
Bonjour,

J'utilise dans un tableau la fonction MOIS() à partir d'une date dans une
autre cellule.

Comme vous le savez, cette fonction renvoie le numéro du mois. Je voudrais
que ce soit le nom du mois qui s'affiche.

ex simplifié :

MOIS(12/05/2009) = 5 mais je voudrais MAI

quand j'utilise le format de cellule "mmm" il considère le 5 comme
05/01/1900 donc le format donne JANV

Y a t'il une autre solution?

Merci

(j'espère avoir été clair)

Greg



Publicité
Poster une réponse
Anonyme