Fonction NB.SI avec des étoiles dans le texte

Le
Fredazailes
Bonjour,

je cherche des doublons sur une liste de références d'articles contenant
des "*" ou pas.

Dans le mini tableau suivant j'ai utilise la formule =NB.SI(A:A;A1)

> REF NB.SI
> E-SA-200*320 2 =NB.SI(A:A;A1)
> E-SA-200320 1 =NB.SI(A:A;A2)


Je trouve le résultat étonnant. C'est un bug ou dois je ajouter quelque
chose à ma formule pour éviter cette petite plaisanterie d'Excel

Merci d'avance,
Fred
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jac
Le #5460841
Bonjour,

habituellement, * est un joker qui signifie 0, 1 ou plusieurs
caractères. Donc "ça" calcule dans tous les cas de figures 1 s'il n'y a
pas d' * et 1 de + s'il y a une *.
L'autre joker est le ? qui signifie un seul caractère.

Exemple dans un filtre automatique, dans personnalisé.

Jac

Bonjour,

je cherche des doublons sur une liste de références d'articles contenant des
"*" ou pas....

Dans le mini tableau suivant j'ai utilise la formule =NB.SI(A:A;A1)

REF NB.SI
E-SA-200*320 2 =NB.SI(A:A;A1)
E-SA-200320 1 =NB.SI(A:A;A2)



Je trouve le résultat étonnant. C'est un bug ou dois je ajouter quelque chose
à ma formule pour éviter cette petite plaisanterie d'Excel

Merci d'avance,
Fred



JB
Le #5460831
Bonjour,

=NB.SI(B1:B7;"*~**")

JB

On 17 avr, 22:42, Fredazailes
internet.fr> wrote:
Bonjour,

je cherche des doublons sur une liste de références d'articles contena nt
des "*" ou pas....

Dans le mini tableau suivant j'ai utilise la formule =NB.SI(A:A;A1)

REF               NB.SI
E-SA-200*320       2    =NB.SI(A:A;A1)
E-SA-200320        1    =NB.SI(A:A;A2)


Je trouve le résultat étonnant. C'est un bug ou dois je ajouter quelqu e
chose à ma formule pour éviter cette petite plaisanterie d'Excel

Merci d'avance,
Fred



Fredazailes
Le #5460561
Bonjour,
merci à tous, je contourne le pb.
Fred

Bonjour,

=NB.SI(B1:B7;"*~**")

JB

On 17 avr, 22:42, Fredazailes
internet.fr> wrote:
Bonjour,

je cherche des doublons sur une liste de références d'articles contenant
des "*" ou pas....

Dans le mini tableau suivant j'ai utilise la formule =NB.SI(A:A;A1)

REF NB.SI
E-SA-200*320 2 =NB.SI(A:A;A1)
E-SA-200320 1 =NB.SI(A:A;A2)
Je trouve le résultat étonnant. C'est un bug ou dois je ajouter quelque

chose à ma formule pour éviter cette petite plaisanterie d'Excel

Merci d'avance,
Fred






Publicité
Poster une réponse
Anonyme