Fonction NB.SI

Le
JPMonnier
Bonsoir,
Est -il possible d'utiliser NB.SI combiné avec la fonction ET
Ex : Compter le nombre de valeurs comprise entre 1et 6, entre 7 et 12, etc

Ou existe t"il une fonction qui pourrait me sortir ce résultat
Je sèche !!
Merci d'avance
--
Cordialement
jpmonnier-no-spam@neuf.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
LSteph
Le #7081531
Bonsoir,

>comprise entre 1et 6, entre 7 et 12
cela revient à entre 1 et 12

>etc ...
cela revient à ..

Sois plus précis.

> Est -il possible d'utiliser NB.SI combiné avec la fonction ET

oui!

=nb.si(a1:a12;[ceci])+nb.si(a1:a12;[cela])


@+

--
lSteph
(celui qui comprend jamais rien du premier coup)



JPMonnier a écrit :
Bonsoir,
Est -il possible d'utiliser NB.SI combiné avec la fonction ET
Ex : Compter le nombre de valeurs comprise entre 1et 6, entre 7 et 12,
etc ...
Ou existe t"il une fonction qui pourrait me sortir ce résultat
Je sèche !!
Merci d'avance


Jacky
Le #7081511
Bonsoir,
Pas sur d'avoir compris

Compte le nombre de valeur d'une plage(A1:A100) si >1 et <6
=SOMMEPROD((A1:A100>1)*(A1:A100<6))
Compte le nombre de valeur d'une plage si >1 et <6 ET >7 et<12
=SOMMEPROD((A1:A100>1)*(A1:A100<6)+(A1:A100>7)*(A1:A100<12))
--
Salutations
JJ


"JPMonnier" %23coA$
Bonsoir,
Est -il possible d'utiliser NB.SI combiné avec la fonction ET
Ex : Compter le nombre de valeurs comprise entre 1et 6, entre 7 et 12, etc
...
Ou existe t"il une fonction qui pourrait me sortir ce résultat
Je sèche !!
Merci d'avance
--
Cordialement



JPMonnier
Le #7081491
merci LStephsteph
Pour être plus précis, compter le nb de val (comprises entre 1 et 6, = tant
de valeurs), et (comprises entre 7 et 12 = tant de valeurs)etc, dans une
matrice contenant 144 lignes avec des chiffres distribués entre 1 et 144
soit : nb chiffres entre 1 et 6, nb chiffres entre 7 et 12, nb chiffres
entre 14 et 20 etc ...
--
Cordialement

"LSteph" news:
Bonsoir,

>comprise entre 1et 6, entre 7 et 12
cela revient à entre 1 et 12

>etc ...
cela revient à ..

Sois plus précis.

> Est -il possible d'utiliser NB.SI combiné avec la fonction ET

oui!

=nb.si(a1:a12;[ceci])+nb.si(a1:a12;[cela])


@+

--
lSteph
(celui qui comprend jamais rien du premier coup)



JPMonnier a écrit :
Bonsoir,
Est -il possible d'utiliser NB.SI combiné avec la fonction ET
Ex : Compter le nombre de valeurs comprise entre 1et 6, entre 7 et 12,
etc ...
Ou existe t"il une fonction qui pourrait me sortir ce résultat
Je sèche !!
Merci d'avance




Tatanka
Le #7081481
Bonsoir,

Pour trouver le nombre de nombres compris entre 1 et 6 (bornes incluses),
dans la plage A1:A20, tu pourrais utiliser ceci :
=NB.SI(A1:A20;"<=6")-NB.SI(A1:A20;"<1")
Cependant cette formule qui donne le même résultat me semble plus intéressante :
=SOMMEPROD((A1:A20>=1)*(A1:A20<=6))

Serge



"JPMonnier"
Bonsoir,
Est -il possible d'utiliser NB.SI combiné avec la fonction ET
Ex : Compter le nombre de valeurs comprise entre 1et 6, entre 7 et 12, etc ...
Ou existe t"il une fonction qui pourrait me sortir ce résultat
Je sèche !!
Merci d'avance
--
Cordialement



LSteph
Le #7081641
Soit, merci pour ce retour, mais tu n'es guère plus précis,

tu veux :
un résultat ou plusieurs ou l'addition des résultats
???

Exemple
si j'ai une matrice avec des nombres consécutifs sompris entre 1 et 144
et que je veux

=nb.si(a1:a144;" j'obtiens 144

sinon je mets dans deux cellules différentes pour obtenir tantôt dans l'une
=nb.si(a1:a144;"<77")
j'obtiens 76

et dans l'autre
=nb.si(a1:a144;">76")
j'obtiens 78

Ou je récupère un texte contenant les deux résultats:
=nb.si(a1:a144;" j'obtiens "76 et 78"

...

JPMonnier a écrit :
merci LStephsteph
Pour être plus précis, compter le nb de val (comprises entre 1 et 6, =
tant de valeurs), et (comprises entre 7 et 12 = tant de valeurs)etc,
dans une matrice contenant 144 lignes avec des chiffres distribués entre
1 et 144
soit : nb chiffres entre 1 et 6, nb chiffres entre 7 et 12, nb chiffres
entre 14 et 20 etc ...


JPMonnier
Le #7081631
Merci à tous
Le SOMMEPROD me convient tout à fait
Merci mille fois
--
Cordialement


"JPMonnier" news:%23coA$
Bonsoir,
Est -il possible d'utiliser NB.SI combiné avec la fonction ET
Ex : Compter le nombre de valeurs comprise entre 1et 6, entre 7 et 12, etc
...
Ou existe t"il une fonction qui pourrait me sortir ce résultat
Je sèche !!
Merci d'avance
--
Cordialement



JPMonnier
Le #7081711
Merci LSTEPH,
avec SOMMPROD, j'ai 24 lignes avec cette formule
ces 24 lignes représentent 24 groupes de 6
Excuse moi pour mon imprécision sur ma demande
--
Cordialement


"LSteph" news:

Soit, merci pour ce retour, mais tu n'es guère plus précis,

tu veux :
un résultat ou plusieurs ou l'addition des résultats
???

Exemple
si j'ai une matrice avec des nombres consécutifs sompris entre 1 et 144
et que je veux

=nb.si(a1:a144;" j'obtiens 144

sinon je mets dans deux cellules différentes pour obtenir tantôt dans
l'une
=nb.si(a1:a144;"<77")
j'obtiens 76

et dans l'autre
=nb.si(a1:a144;">76")
j'obtiens 78

Ou je récupère un texte contenant les deux résultats:
=nb.si(a1:a144;" j'obtiens "76 et 78"

...

JPMonnier a écrit :
merci LStephsteph
Pour être plus précis, compter le nb de val (comprises entre 1 et 6, =
tant de valeurs), et (comprises entre 7 et 12 = tant de valeurs)etc, dans
une matrice contenant 144 lignes avec des chiffres distribués entre 1 et
144
soit : nb chiffres entre 1 et 6, nb chiffres entre 7 et 12, nb chiffres
entre 14 et 20 etc ...




LSteph
Le #7081921
Nonon c'est moi, je vais aller dormir!

JPMonnier a écrit :
Merci LSTEPH,
avec SOMMPROD, j'ai 24 lignes avec cette formule
ces 24 lignes représentent 24 groupes de 6
Excuse moi pour mon imprécision sur ma demande


Publicité
Poster une réponse
Anonyme