Fonction "nombre le plus proche d'une valeur"

Le
MS
Bonjour,

Sur excel 2003 SP3, je cherche la fonction excel qui permet de chercher dans
une table la valeur la plus proche d'une autre valeur (en occurence, la
moyenne de cette même table).
Merci !
--
MS
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #17262321
Bonjour.
Faute de mieux et ta table est classée en ordre croissant :
=SI(ESTNA(RECHERCHEV(C1;B1:B10;1;0));SI(C1-RECHERCHEV(C1;B1:B10;1;1)<INDEX(B1:B10;EQUIV(C1;B1:B10;1)+1)-C1;RECHERCHEV(C1;B1:B10;1;1);INDEX(B1:B10;EQUIV(C1;B1:B10;1)+1));RECHERCHEV(C1;B1:B10;1;0))
Cordialement.
Daniel
"MS"
Bonjour,

Sur excel 2003 SP3, je cherche la fonction excel qui permet de chercher
dans
une table la valeur la plus proche d'une autre valeur (en occurence, la
moyenne de cette même table).
Merci !
--
MS


Corto
Le #17262511
Bonjour MS,
par formule matricielle (valider par Shift+Ctrl+Enter) :
{=INDEX(B2:B179;EQUIV(MIN(ABS($J$2-$F$2:$F$179));ABS($J$2-$F$2:$F$179); 0))}
B2:B179 = Valeurs à renvoyer
F2:F179 = Liste des valeurs
J2 = Moyenne de F2:F179

Corto

MS a écrit :
Bonjour,

Sur excel 2003 SP3, je cherche la fonction excel qui permet de chercher dans
une table la valeur la plus proche d'une autre valeur (en occurence, la
moyenne de cette même table).
Merci !



Publicité
Poster une réponse
Anonyme