Fonction qui compte le nombre d'occurence d'une chaine de caractère?

Le
YannDeo
Salut

J'ai un fichier excel qui contient plusieurs lignes.

Mon problème :

J'ai plusieurs lots : A, ABC, AC, AB, etc

A chacun de ces lots correspond une quantité.

Par exemple :

Lot Quantité dans Lot
ABCEF 1291
ABEF 1254
ACEF 4119
ADEF 3
AEF 6454
BCEF 9
BDEF 1893
BEF 9519
BEFG 1665
CEF 2646
DEF 8332
DEFG 2
E 4535
EF 57830
EFG 3448

J'aimerai calculer la quantité totale pour chacune des lettres, par exemple,
pour A, 1291 + 1254 + 4119 + 3 + 6454 = 13121

Je pense donc à la formule "=SI(ESTNUM(CHERCHE(C$1;$A2));$B2;0)" mais y a t
il mieux ?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
DanielCo
Le #23047761
Bonjour.
Formule matricielle (valider avec Ctrl+Maj+Entrée) :
=SOMME(SI(ESTNUM(CHERCHE("A";A1:A15));1;0)*B1:B15)
Cordialement.
Daniel


Salut

J'ai un fichier excel qui contient plusieurs lignes.

Mon problème :

J'ai plusieurs lots : A, ABC, AC, AB, etc...

A chacun de ces lots correspond une quantité.

Par exemple :

Lot Quantité dans Lot
ABCEF 1291
ABEF 1254
ACEF 4119
ADEF 3
AEF 6454
BCEF 9
BDEF 1893
BEF 9519
BEFG 1665
CEF 2646
DEF 8332
DEFG 2
E 4535
EF 57830
EFG 3448

J'aimerai calculer la quantité totale pour chacune des lettres, par exemple,
pour A, 1291 + 1254 + 4119 + 3 + 6454 = 13121

Je pense donc à la formule "=SI(ESTNUM(CHERCHE(C$1;$A2));$B2;0)" mais y a t
il mieux ?
Tatanka
Le #23048031
Bonjour,

Une autre façon de faire en supposant ton tableau en A1:B15.
1) Entre A, B, C, D, E, F, G en D1:D7
2) Entre la formule suivante en E1 :
=SOMMEPROD((ESTNUM(CHERCHE(D1;$A$1:$A$15))*$B$1:$B$15))
( à valider par Entrée )
3) Recopie la formule vers le bas.

Serge


"YannDeo"
Salut

J'ai un fichier excel qui contient plusieurs lignes.

Mon problème :

J'ai plusieurs lots : A, ABC, AC, AB, etc...

A chacun de ces lots correspond une quantité.

Par exemple :

Lot Quantité dans Lot
ABCEF 1291
ABEF 1254
ACEF 4119
ADEF 3
AEF 6454
BCEF 9
BDEF 1893
BEF 9519
BEFG 1665
CEF 2646
DEF 8332
DEFG 2
E 4535
EF 57830
EFG 3448

J'aimerai calculer la quantité totale pour chacune des lettres, par exemple, pour A, 1291 + 1254 + 4119 + 3 + 6454 = 13121

Je pense donc à la formule "=SI(ESTNUM(CHERCHE(C$1;$A2));$B2;0)" mais y a t il mieux ?

YannDeo
Le #23048161
Merci beaucoup!

"YannDeo" a écrit dans le message de groupe de discussion :
4d3d381f$0$811$

Salut

J'ai un fichier excel qui contient plusieurs lignes.

Mon problème :

J'ai plusieurs lots : A, ABC, AC, AB, etc...

A chacun de ces lots correspond une quantité.

Par exemple :

Lot Quantité dans Lot
ABCEF 1291
ABEF 1254
ACEF 4119
ADEF 3
AEF 6454
BCEF 9
BDEF 1893
BEF 9519
BEFG 1665
CEF 2646
DEF 8332
DEFG 2
E 4535
EF 57830
EFG 3448

J'aimerai calculer la quantité totale pour chacune des lettres, par exemple,
pour A, 1291 + 1254 + 4119 + 3 + 6454 = 13121

Je pense donc à la formule "=SI(ESTNUM(CHERCHE(C$1;$A2));$B2;0)" mais y a t
il mieux ?
Publicité
Poster une réponse
Anonyme