Fonction SI imbriquée (Excel 2003)

Le
Tartempion
Bonjour à tous,

en A1, il y a une fonction DIFDATE qui affiche un calcul d'années.
en B1, je souhaiterais satisfaire l'ensemble de conditions suivantes :
SI A1>E alors B16 h 00
SI A1>P alors B14 h 00
Si A1>U alors B12 h 00
Sinon B18 h 00

J'ai noté en B1 les fonctions imbriquées suivantes :
=SI(G28>E;"36 h 00";SI(G28>P;"34 h00";SI(G28>U;"32 h 00";"38 h 00")))

Malheureusement le résultat obtenu ne correspond pas aux calculs souhaités

Qui peut me corriger ? Et me donner quelqu'explications SVP ?

Merci d'avance
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Tartempion
Le #19353611
Bon,

J'ai corrigé le message... Y avait une erreur dans la copie de mes notes :-/



"Tartempion" discussion :
Bonjour à tous,

en A1, il y a une fonction DIFDATE qui affiche un calcul d'années.
en B1, je souhaiterais satisfaire l'ensemble de conditions suivantes :
SI A1>E alors B16 h 00
SI A1>P alors B14 h 00
Si A1>U alors B12 h 00
Sinon B18 h 00

J'ai noté en B1 les fonctions imbriquées suivantes :
=SI(A1>E;"36 h 00";SI(A1>P;"34 h00";SI(A1>U;"32 h 00";"38 h 00")))

Malheureusement le résultat obtenu ne correspond pas aux calculs souhaités

Qui peut me corriger ? Et me donner quelqu'explications SVP ?

Merci d'avance


isabelle
Le #19353601
bonjour Tartempion,,

comme tu l'avais écris, si en A1 la valeur est de 56, la première
condition est vrai A1>E

=SI(ET(A1>E;A1<50);"36 h 00";SI(ET(A1>P;A1<55);"34
h00";SI(A1>U;"32 h 00";"38 h 00")))

isabelle

Tartempion a écrit :
Bon,

J'ai corrigé le message... Y avait une erreur dans la copie de mes
notes :-/



"Tartempion" discussion :
Bonjour à tous,

en A1, il y a une fonction DIFDATE qui affiche un calcul d'années.
en B1, je souhaiterais satisfaire l'ensemble de conditions suivantes :
SI A1>E alors B16 h 00
SI A1>P alors B14 h 00
Si A1>U alors B12 h 00
Sinon B18 h 00

J'ai noté en B1 les fonctions imbriquées suivantes :
=SI(A1>E;"36 h 00";SI(A1>P;"34 h00";SI(A1>U;"32 h 00";"38 h 00")))

Malheureusement le résultat obtenu ne correspond pas aux calculs
souhaités

Qui peut me corriger ? Et me donner quelqu'explications SVP ?

Merci d'avance





Caetera
Le #19353731
> en A1, il y a une fonction DIFDATE qui affiche un calcul d'années.
en B1, je souhaiterais satisfaire l'ensemble de conditions suivantes :
SI A1>E alors B16 h 00
SI A1>P alors B14 h 00
Si A1>U alors B12 h 00
Sinon B18 h 00



En mettant la cellule B1 au format 0" h ""00"
=INDEX({38;36;34;32};EQUIV(A1;{0;45;50;55};1))

Etc
Tartempion
Le #19353721
Un tout grand merci à toi Isabelle !
Et bon dimanche :-)



"isabelle" a écrit dans le message de groupe de discussion :
#
bonjour Tartempion,,

comme tu l'avais écris, si en A1 la valeur est de 56, la première
condition est vrai A1>E

=SI(ET(A1>E;A1<50);"36 h 00";SI(ET(A1>P;A1<55);"34 h00";SI(A1>U;"32
h 00";"38 h 00")))

isabelle

Tartempion a écrit :
Bon,

J'ai corrigé le message... Y avait une erreur dans la copie de mes notes
:-/



"Tartempion" discussion :
Bonjour à tous,

en A1, il y a une fonction DIFDATE qui affiche un calcul d'années.
en B1, je souhaiterais satisfaire l'ensemble de conditions suivantes :
SI A1>E alors B16 h 00
SI A1>P alors B14 h 00
Si A1>U alors B12 h 00
Sinon B18 h 00

J'ai noté en B1 les fonctions imbriquées suivantes :
=SI(A1>E;"36 h 00";SI(A1>P;"34 h00";SI(A1>U;"32 h 00";"38 h 00")))

Malheureusement le résultat obtenu ne correspond pas aux calculs
souhaités

Qui peut me corriger ? Et me donner quelqu'explications SVP ?

Merci d'avance







Tartempion
Le #19353821
Waouw ! Mieux encore... mais j'ai du prendre mes notes pour m'y retrouver !
Un papy qui s'exerce à Excel et qui découvre ô combien les internautes sont
des gars sympas et serviables.
Merci à toi, Etienne... et bon dimanche aussi :-)



"Caetera" discussion :
en A1, il y a une fonction DIFDATE qui affiche un calcul d'années.
en B1, je souhaiterais satisfaire l'ensemble de conditions suivantes :
SI A1>E alors B16 h 00
SI A1>P alors B14 h 00
Si A1>U alors B12 h 00
Sinon B18 h 00



En mettant la cellule B1 au format 0" h ""00"
=INDEX({38;36;34;32};EQUIV(A1;{0;45;50;55};1))

Etc




MichDenis
Le #19353761
Bonjour Tartempion,

| =SI(A1>E;"36 h 00";SI(A1>P;"34 h00";SI(A1>U;"32 h 00";"38 h 00")))

Tu n'as qu'à renverser les conditions :
=SI(A1>U;"32 h 00";A1>P;"34 h00";SI(A1>E;"36 h 00";"38 h 00")))
Une explication simple à retenir :
Lorsque tu as des "si" imbriqués, tu pars de la gauche vers la droite.
Dès qu'une condition est réalisée, le résultat prévu et attaché
à cette condition est réalisé et toutes les autres conditions
situées après celle-ci sont "ignorées".



"Tartempion"
Bonjour à tous,

en A1, il y a une fonction DIFDATE qui affiche un calcul d'années.
en B1, je souhaiterais satisfaire l'ensemble de conditions suivantes :
SI A1>E alors B16 h 00
SI A1>P alors B14 h 00
Si A1>U alors B12 h 00
Sinon B18 h 00

J'ai noté en B1 les fonctions imbriquées suivantes :
=SI(G28>E;"36 h 00";SI(G28>P;"34 h00";SI(G28>U;"32 h 00";"38 h 00")))

Malheureusement le résultat obtenu ne correspond pas aux calculs souhaités

Qui peut me corriger ? Et me donner quelqu'explications SVP ?

Merci d'avance
Tartempion
Le #19353811
Génial !
Un tout grand merci pour ton explication !
J'y vois un peu plus clair... Je vais tester tout ce que vous m'avez dit
pour que ça rentre dans ma caboche !
C super ! Merci pour votre gentillesse :-)



"MichDenis" discussion :
Bonjour Tartempion,

| =SI(A1>E;"36 h 00";SI(A1>P;"34 h00";SI(A1>U;"32 h 00";"38 h 00")))

Tu n'as qu'à renverser les conditions :
=SI(A1>U;"32 h 00";A1>P;"34 h00";SI(A1>E;"36 h 00";"38 h 00")))
Une explication simple à retenir :
Lorsque tu as des "si" imbriqués, tu pars de la gauche vers la droite.
Dès qu'une condition est réalisée, le résultat prévu et attaché
à cette condition est réalisé et toutes les autres conditions
situées après celle-ci sont "ignorées".



"Tartempion" discussion :

Bonjour à tous,

en A1, il y a une fonction DIFDATE qui affiche un calcul d'années.
en B1, je souhaiterais satisfaire l'ensemble de conditions suivantes :
SI A1>E alors B16 h 00
SI A1>P alors B14 h 00
Si A1>U alors B12 h 00
Sinon B18 h 00

J'ai noté en B1 les fonctions imbriquées suivantes :
=SI(G28>E;"36 h 00";SI(G28>P;"34 h00";SI(G28>U;"32 h 00";"38 h
00")))

Malheureusement le résultat obtenu ne correspond pas aux calculs souhaités

Qui peut me corriger ? Et me donner quelqu'explications SVP ?

Merci d'avance



Publicité
Poster une réponse
Anonyme