Fonction SI OU intégrant la fonction CHERCHE

Le
Martinellaella
J'ai une base de données listant des ingrédients associés à des
codes.

Je souhaite renvoyer OUI ou NON dans une cellule si l'ingrédient
affiche l'un des codes suivants :
Carc. 1A, Carc. 1B, Carc. 2, Muta. 1A
Les codes sont contenus dans une très longue chaîne de caractères

Exemple
Ingrédient 1 en cellule A1
Index No : 610-214-00-2Hazard Class and Category Code :
<PX:Popup,Carc. 2>Carc. 2<EL><PX:Popup,Acute Tox. 4 *>Acute Tox. 4
*<EL><PX:Popup,<PX:Popup, Carc. 1B >Carc. 1B<EL><PX etc
Réponse attendue OUI

Ingrédient 2 en cellule A2
Index No : 619-145-00-2Hazard Class and Category Code :
<PX:Popup,Repr. 2>Repr. 2<EL><PX:Popup,Eye Irrit. 2>Eye Irrit etc
Réponse attendue NON

J'ai essayé la formule suivante :
=SI(OU(CHERCHE("Carc. 1A";A1);CHERCHE("Carc. 1B";A1);CHERCHE("Carc.
2";A1);CHERCHE("Muta. 1A"));"oui";"non"))

La formule affiche #VALEUR! dès que l'un des codes contenu dans la
formule de calcul n'est pas présent dans la cellule au lieu d'afficher
OUI.Je pensais qu'avec SI OU il suffisait qu'au moins une valeur soit
vérifiée pour que la condition soit satisfaite.

Merci pour votre aide et pour vos suggestions

Martinellaella
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
DanielCo
Le #24275101
Bonjour,
Essaie la formule matricielle (valider avec Ctrl+Maj+Entrée) :
=SI(MIN(NBCAR(SUBSTITUE(A1;{"Carc. 1A";"Carc. 1B";"Carc. 2";"Muta.
1A"};"")))<NBCAR(A1);"Oui";"Non")
Le texte étaant en A1.
Cordialement.
Daniel


J'ai une base de données listant des ingrédients associés à des
codes.

Je souhaite renvoyer OUI ou NON dans une cellule si l'ingrédient
affiche l'un des codes suivants :
Carc. 1A, Carc. 1B, Carc. 2, Muta. 1A.........
Les codes sont contenus dans une très longue chaîne de caractères

Exemple
Ingrédient 1 en cellule A1
Index No : 610-214-00-2Hazard Class and Category Code :
* Réponse attendue OUI

Ingrédient 2 en cellule A2
Index No : 619-145-00-2Hazard Class and Category Code :
Réponse attendue NON

J'ai essayé la formule suivante :
=SI(OU(CHERCHE("Carc. 1A";A1);CHERCHE("Carc. 1B";A1);CHERCHE("Carc.
2";A1);CHERCHE("Muta. 1A"));"oui";"non"))

La formule affiche #VALEUR! dès que l'un des codes contenu dans la
formule de calcul n'est pas présent dans la cellule au lieu d'afficher
OUI.Je pensais qu'avec SI OU il suffisait qu'au moins une valeur soit
vérifiée pour que la condition soit satisfaite.

Merci pour votre aide et pour vos suggestions

Martinellaella
Martinellaella
Le #24275431
On 23 fév, 16:37, DanielCo
Bonjour,
Essaie la formule matricielle (valider avec Ctrl+Maj+Entrée) :
=SI(MIN(NBCAR(SUBSTITUE(A1;{"Carc. 1A";"Carc. 1B";"Carc. 2";"Muta.
1A"};"")))<NBCAR(A1);"Oui";"Non")
Le texte étaant en A1.
Cordialement.
Daniel







> J'ai une base de données  listant des ingrédients associés à des
> codes.

> Je souhaite renvoyer OUI ou NON dans une cellule si  l'ingrédient
> affiche l'un des codes suivants :
> Carc. 1A, Carc. 1B, Carc. 2, Muta. 1A.........
> Les codes sont contenus dans une très longue chaîne de caractères

> Exemple
> Ingrédient 1  en cellule A1
> Index No : 610-214-00-2Hazard Class and Category Code :
> > * > Réponse attendue OUI

> Ingrédient 2 en cellule A2
> Index No : 619-145-00-2Hazard Class and Category Code :
> > Réponse attendue NON

> J'ai essayé la  formule suivante :
> =SI(OU(CHERCHE("Carc. 1A";A1);CHERCHE("Carc. 1B";A1);CHERCHE("Carc.
> 2";A1);CHERCHE("Muta. 1A"));"oui";"non"))

> La formule affiche #VALEUR! dès que l'un des codes contenu dans la
> formule de calcul n'est pas présent dans la cellule au lieu d'affiche r
> OUI.Je pensais qu'avec SI OU il suffisait qu'au moins une valeur soit
> vérifiée pour que la condition soit satisfaite.

> Merci pour votre aide et pour vos suggestions

> Martinellaella




Bonjour,
Merci Daniel pour la formule qui marche.
Si tu as un peu de temps pourrais-tu m'expliquer pourquoi min et nbcar
avec substitue

Martinellaella
DanielCo
Le #24275811
La fonction SUBSTITUE cherche à remplacer les chaines par rien ("").Si
l'une des chaines est remplacée, un des résultats comporte des
caractères en moins. Par exemple si A1 contient : "toto Carc. 1B toto",
la fonction SUBSTITUE renvoie les valeurs suivantes :
{"toto Carc. 1B toto";"toto toto";"toto Carc. 1B toto";"toto Carc. 1B
toto"}
et le nomre de caractères renvoyé par NBCAR est :
{18;10;18;18}
La plus petite valeur renvoyée par MIN (10) est inférieure à celle
renvoyée par NBCAR(A1) (18) parce qu'il y a eu substitution. C'est la
magie des formules matricielles. Tu peux retrouver les valeurs
ci-dessus en surlignant une partie de la formule générale et en
appuyant sur F9.
Daniel


On 23 fév, 16:37, DanielCo
Bonjour,
Essaie la formule matricielle (valider avec Ctrl+Maj+Entrée) :
=SI(MIN(NBCAR(SUBSTITUE(A1;{"Carc. 1A";"Carc. 1B";"Carc. 2";"Muta.
1A"};"")))<NBCAR(A1);"Oui";"Non")
Le texte étaant en A1.
Cordialement.
Daniel







J'ai une base de données  listant des ingrédients associés à des
codes.



Je souhaite renvoyer OUI ou NON dans une cellule si  l'ingrédient
affiche l'un des codes suivants :
Carc. 1A, Carc. 1B, Carc. 2, Muta. 1A.........
Les codes sont contenus dans une très longue chaîne de caractères
Exemple
Ingrédient 1  en cellule A1
Index No : 610-214-00-2Hazard Class and Category Code :
* Réponse attendue OUI



Ingrédient 2 en cellule A2
Index No : 619-145-00-2Hazard Class and Category Code :
Réponse attendue NON



J'ai essayé la  formule suivante :
=SI(OU(CHERCHE("Carc. 1A";A1);CHERCHE("Carc. 1B";A1);CHERCHE("Carc.
2";A1);CHERCHE("Muta. 1A"));"oui";"non"))
La formule affiche #VALEUR! dès que l'un des codes contenu dans la
formule de calcul n'est pas présent dans la cellule au lieu d'afficher
OUI.Je pensais qu'avec SI OU il suffisait qu'au moins une valeur soit
vérifiée pour que la condition soit satisfaite.
Merci pour votre aide et pour vos suggestions
Martinellaella






Bonjour,
Merci Daniel pour la formule qui marche.
Si tu as un peu de temps pourrais-tu m'expliquer pourquoi min et nbcar
avec substitue

Martinellaella
Martinellaella
Le #24277301
On 23 fév, 21:42, DanielCo
La fonction SUBSTITUE cherche à remplacer les chaines par rien ("").Si
l'une des chaines est remplacée, un des résultats comporte des
caractères en moins. Par exemple si A1 contient : "toto Carc. 1B toto",
la fonction SUBSTITUE renvoie les valeurs suivantes :
{"toto Carc. 1B toto";"toto  toto";"toto Carc. 1B toto";"toto Carc. 1B
toto"}
et le nomre de caractères renvoyé par NBCAR est :
{18;10;18;18}
La plus petite valeur renvoyée par MIN (10) est inférieure à celle
renvoyée par NBCAR(A1) (18) parce qu'il y a eu substitution. C'est la
magie des formules matricielles. Tu peux retrouver les valeurs
ci-dessus en surlignant une partie de la formule générale et en
appuyant sur F9.
Daniel







> On 23 fév, 16:37, DanielCo >> Bonjour,
>> Essaie la formule matricielle (valider avec Ctrl+Maj+Entrée) :
>> =SI(MIN(NBCAR(SUBSTITUE(A1;{"Carc. 1A";"Carc. 1B";"Carc. 2";"Muta.
>> 1A"};"")))<NBCAR(A1);"Oui";"Non")
>> Le texte étaant en A1.
>> Cordialement.
>> Daniel

>>> J'ai une base de données  listant des ingrédients associés à des
>>> codes.

>>> Je souhaite renvoyer OUI ou NON dans une cellule si  l'ingrédient
>>> affiche l'un des codes suivants :
>>> Carc. 1A, Carc. 1B, Carc. 2, Muta. 1A.........
>>> Les codes sont contenus dans une très longue chaîne de caractèr es
>>> Exemple
>>> Ingrédient 1  en cellule A1
>>> Index No : 610-214-00-2Hazard Class and Category Code :
>>> >>> * >>> Réponse attendue OUI

>>> Ingrédient 2 en cellule A2
>>> Index No : 619-145-00-2Hazard Class and Category Code :
>>> >>> Réponse attendue NON

>>> J'ai essayé la  formule suivante :
>>> =SI(OU(CHERCHE("Carc. 1A";A1);CHERCHE("Carc. 1B";A1);CHERCHE("Carc.
>>> 2";A1);CHERCHE("Muta. 1A"));"oui";"non"))
>>> La formule affiche #VALEUR! dès que l'un des codes contenu dans la
>>> formule de calcul n'est pas présent dans la cellule au lieu d'affic her
>>> OUI.Je pensais qu'avec SI OU il suffisait qu'au moins une valeur soit
>>> vérifiée pour que la condition soit satisfaite.
>>> Merci pour votre aide et pour vos suggestions
>>> Martinellaella

> Bonjour,
> Merci Daniel pour la formule qui marche.
> Si tu as un peu de temps pourrais-tu m'expliquer pourquoi min et nbcar
> avec substitue

> Martinellaella



Bonjour
Merci pour les explications
Martinellaella
Publicité
Poster une réponse
Anonyme