FONCTION SI ET REPONSE CELLULE VIDE

Le
yapi
Bonjour,

Je travaille actuellement sur une fonction si et cherche à obtenir une
cellule vide en réponse

Exemple : A1=0 et A2=si(A1=0;"OK";je voudrais une cellule vide). Si je mets
des guillements, j'ai effectivement une cellule videen apparence seulement
puisqu'elle est comptabilisée dans une fonction NBVAL par exemple!

Y-a-t-il une solution?
Merci,
--
yapi
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #17946501
Bonjour,

=NB.SI(B2:B9;">0")

JB
http://boisgontierjacques.free.fr

On 24 nov, 16:12, yapi
Bonjour,

Je travaille actuellement sur une fonction si et cherche à obtenir une
cellule vide en réponse...

Exemple : A1=0 et A2=si(A1=0;"OK";je voudrais une cellule vide). Si je mets
des guillements, j'ai effectivement une cellule vide...en apparence seule ment
puisqu'elle est comptabilisée dans une fonction NBVAL par exemple!

Y-a-t-il une solution?
Merci,
--
yapi


Modeste
Le #17946601
Bonsour® yapi avec ferveur ;o))) vous nous disiez :
Je travaille actuellement sur une fonction si et cherche à obtenir une
cellule vide en réponse...

Exemple : A1=0 et A2=si(A1=0;"OK";je voudrais une cellule vide). Si
je mets des guillements, j'ai effectivement une cellule vide...en
apparence seulement puisqu'elle est comptabilisée dans une fonction
NBVAL par exemple!



s'il y a une formule , la cellule n'est pas vide !!!!
ce qui est sommes toutes logique...

quoique .....
la fonction NB.VIDE(plage) semble contredire
Les cellules contenant des formules qui renvoient " " (texte vide) sont également comptées, ce qui n'est pas le cas des cellules contenant la valeur zéro.
?????
;o))))


--
--
@+
;o)))
Philippe.R
Le #17946701
Bonjour,
Les cellules contenant des formules ne sont effectivement pas vides, même
avec un résultat de type "" ; on pourra se tourner vers ce contournement par
exemple, avec en A2 et autres, la formule que tu souhaitais :
=SI(A1=0;"OK";"")
et ailleurs, pour compter les non vides
=NBVAL(A2:J2)-NB.SI(A2:J2;"")
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"yapi" news:
Bonjour,

Je travaille actuellement sur une fonction si et cherche à obtenir une
cellule vide en réponse...

Exemple : A1=0 et A2=si(A1=0;"OK";je voudrais une cellule vide). Si je
mets
des guillements, j'ai effectivement une cellule vide...en apparence
seulement
puisqu'elle est comptabilisée dans une fonction NBVAL par exemple!

Y-a-t-il une solution?
Merci,
--
yapi


yapi
Le #17947251
Merci à tous,

J'ai appris de chacun de vos commentaires!!!
--
yapi


"yapi" a écrit :

Bonjour,

Je travaille actuellement sur une fonction si et cherche à obtenir une
cellule vide en réponse...

Exemple : A1=0 et A2=si(A1=0;"OK";je voudrais une cellule vide). Si je mets
des guillements, j'ai effectivement une cellule vide...en apparence seulement
puisqu'elle est comptabilisée dans une fonction NBVAL par exemple!

Y-a-t-il une solution?
Merci,
--
yapi


Publicité
Poster une réponse
Anonyme