Fonction : somme.si

Le
Nomade
Bonjour,

Comment fait on pour faire une somme.SI sur plusieurs critères, ex sur une
base de donnée :
- femmes
- habitant Nancy
- Emploi Comptable

Je ne vois pas comment faire ?
--
Merci d'avance de votre aide,

Nomade
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #18872921
bonjour Nomade,

=SOMMEPROD(($A$1:$A$10="femme")*($B$1:$B$10="Nancy")*($C$1:$C$10="comptable")*($D$1:$D$10))

isabelle

Nomade a écrit :
Bonjour,

Comment fait on pour faire une somme.SI sur plusieurs critères, ex sur une
base de donnée :
- femmes
- habitant Nancy
- Emploi Comptable

Je ne vois pas comment faire ?



Abigael
Le #18874681
Bonjour,

il est possible aussi d'utiliser la fonction SOMME.SI.ENS qui permet
plusieurs critères

Abigael

"Nomade" a écrit :

Bonjour,

Comment fait on pour faire une somme.SI sur plusieurs critères, ex sur une
base de donnée :
- femmes
- habitant Nancy
- Emploi Comptable

Je ne vois pas comment faire ?
--
Merci d'avance de votre aide,

Nomade





Daniel.C
Le #18874771
Bonjour.
Seulement avec XL2007.
Cordialement.
Daniel

Bonjour,

il est possible aussi d'utiliser la fonction SOMME.SI.ENS qui permet
plusieurs critères

Abigael

"Nomade" a écrit :

Bonjour,

Comment fait on pour faire une somme.SI sur plusieurs critères, ex sur une
base de donnée :
- femmes
- habitant Nancy
- Emploi Comptable

Je ne vois pas comment faire ?
--
Merci d'avance de votre aide,

Nomade







Jac
Le #18875351
Bonjour Nomade,

autre approche : tu mets en place un filtre automatique et tes critères
de sélection se font par le filtre (Sexe= femme, Ville= Nancy, Emploi=
comptable) et pour le résultat, tu utilises la fonction sous.total
Voir dans l'aide le paramétrage de cette fonction.

Si la colonne A contient le nom des personnes, la formule pourrait
ressembler à : =sous.total(3;A2:A65536)

L'idéal serait de rajouter 2 lignes au dessus du tableau.
En A1 :

="Nombre de personnes sélectionnées : " & sous.total(3;A4:A65536)

La ligne 2, il faut la masquer (sélection de la ligne puis clic droit /
Masquer)pour séparer la ligne de résultat (1) et le tableau (3:65536).

Intérêt de cette façon de faire : tu peux imprimer le résultat et les
lignes concernées.

On en reparle quand tu veux.

Jac

Nomade a exprimé avec précision :
Bonjour,

Comment fait on pour faire une somme.SI sur plusieurs critères, ex sur une
base de donnée :
- femmes
- habitant Nancy
- Emploi Comptable

Je ne vois pas comment faire ?


gmlsteph
Le #18875471
Bonjour,

L'utilisation de sommeprod est à privilégier plutôt que somme.si (qui
plante) c'est déjà répondu voir le post d Isabelle
sinon pour une base de données tu peux aussi utiliser les fonctions
qui commencent BD dans la liste
seulement il te faudra définir une zone de critères et placer les
valeurs ou jokers dedans Cf l'aide d Excel sur les fonctions de base
de données.

--
lSteph
"Sommeprod c'est TOP"

On 11 mar, 00:05, " Nomade"
Bonjour,

Comment fait on pour faire une somme.SI sur plusieurs critères, ex sur une
base de donnée :
- femmes
- habitant Nancy
- Emploi Comptable

Je ne vois pas comment faire ?
--
Merci d'avance de votre aide,

Nomade


Publicité
Poster une réponse
Anonyme