fonction spéciale

Le
milloche
Rebonjour,
Je me suis sans doute mal exprimé, alors, je reprends la file.
J'ai une colonne G, des formules ou le résultat des premières ligne est
toujours 0, puis les cellules deviennent positives.
J'ai une colonne H, aussi des formules dont les valeurs sont diverses.
J'aimerais avoir une "Function" qui me renvoie la valeur dans la cellule de
la colonne H dès que la cellule de la colonne G est supérieure à 0.
Pour l'instant, j'ai le résultat avec une boucle dans une macro, mais
j'aimerai que cela se fasse en temps réel, donc une fonction que je ne
parviens pas à élaborer.
Je pense que c'est plus clair.
D'avance, merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
milloche
Le #16632561
J'ai oublié de préciser que les 2 premières lignes sont des titres, qu'il ne
faut pas inclure et que G et H sont des exemples.
"milloche"
Rebonjour,
Je me suis sans doute mal exprimé, alors, je reprends la file.
J'ai une colonne G, des formules ou le résultat des premières ligne est
toujours 0, puis les cellules deviennent positives.
J'ai une colonne H, aussi des formules dont les valeurs sont diverses.
J'aimerais avoir une "Function" qui me renvoie la valeur dans la cellule
de la colonne H dès que la cellule de la colonne G est supérieure à 0.
Pour l'instant, j'ai le résultat avec une boucle dans une macro, mais
j'aimerai que cela se fasse en temps réel, donc une fonction que je ne
parviens pas à élaborer.
Je pense que c'est plus clair.
D'avance, merci



Francois L
Le #16632541
milloche a écrit :

Bonjour,

Tu pourrais mettre un exemple sur Cjoint qu'on essaie de comprendre ce
que tu veux ?

--
François L


J'ai oublié de préciser que les 2 premières lignes sont des titres, qu'il ne
faut pas inclure et que G et H sont des exemples.
"milloche"
Rebonjour,
Je me suis sans doute mal exprimé, alors, je reprends la file.
J'ai une colonne G, des formules ou le résultat des premières ligne est
toujours 0, puis les cellules deviennent positives.
J'ai une colonne H, aussi des formules dont les valeurs sont diverses.
J'aimerais avoir une "Function" qui me renvoie la valeur dans la cellule
de la colonne H dès que la cellule de la colonne G est supérieure à 0.
Pour l'instant, j'ai le résultat avec une boucle dans une macro, mais
j'aimerai que cela se fasse en temps réel, donc une fonction que je ne
parviens pas à élaborer.
Je pense que c'est plus clair.
D'avance, merci







milloche
Le #16633371
Voilà

col V col W
0,00 15000
0,00 12000
0,00 13500
8.00 12288
14,5 10284
18.25 9184
Je voudrais une fonction à placer ou je veux qui me renvoie en temps réel,
le résultat 13500 dans le cas présent.
C'est à dire juste avant que la col V devienne positive. Sachant que ces
données sont le résultat de formules donc peuvent changer à chaque instant
mais que la colonne V commence toujours par une série de zéros.
Est-ce mieux ?
J'ai tenté une capture mais c'est illisible. Peut-être je ne sais pas faire.
Mais ne te casse pas trop la tête, je pensais que c'était simple.
Ca marche avec une macro ou je parcoure la colonne V:V avec
activecell.offset(1,0) et if activecell>0 then macellule=
activecell.offset(0,1)
Mais il faut lancer la macro à chaque changement.



"Francois L" de news:
milloche a écrit :

Bonjour,

Tu pourrais mettre un exemple sur Cjoint qu'on essaie de comprendre ce que
tu veux ?

--
François L


J'ai oublié de préciser que les 2 premières lignes sont des titres, qu'il
ne faut pas inclure et que G et H sont des exemples.
"milloche"
Rebonjour,
Je me suis sans doute mal exprimé, alors, je reprends la file.
J'ai une colonne G, des formules ou le résultat des premières ligne est
toujours 0, puis les cellules deviennent positives.
J'ai une colonne H, aussi des formules dont les valeurs sont diverses.
J'aimerais avoir une "Function" qui me renvoie la valeur dans la cellule
de la colonne H dès que la cellule de la colonne G est supérieure à 0.
Pour l'instant, j'ai le résultat avec une boucle dans une macro, mais
j'aimerai que cela se fasse en temps réel, donc une fonction que je ne
parviens pas à élaborer.
Je pense que c'est plus clair.
D'avance, merci








Jacky
Le #16633351
Bonsoir,

Essaie
=RECHERCHEV(0;V1:W1000;2)

--
Salutations
JJ


"milloche"
Rebonjour,
Je me suis sans doute mal exprimé, alors, je reprends la file.
J'ai une colonne G, des formules ou le résultat des premières ligne est
toujours 0, puis les cellules deviennent positives.
J'ai une colonne H, aussi des formules dont les valeurs sont diverses.
J'aimerais avoir une "Function" qui me renvoie la valeur dans la cellule
de la colonne H dès que la cellule de la colonne G est supérieure à 0.
Pour l'instant, j'ai le résultat avec une boucle dans une macro, mais
j'aimerai que cela se fasse en temps réel, donc une fonction que je ne
parviens pas à élaborer.
Je pense que c'est plus clair.
D'avance, merci



milloche
Le #16633531
Et ça marche
Grand merci et bon courage
"Jacky"
Bonsoir,

Essaie
=RECHERCHEV(0;V1:W1000;2)

--
Salutations
JJ


"milloche"
Rebonjour,
Je me suis sans doute mal exprimé, alors, je reprends la file.
J'ai une colonne G, des formules ou le résultat des premières ligne est
toujours 0, puis les cellules deviennent positives.
J'ai une colonne H, aussi des formules dont les valeurs sont diverses.
J'aimerais avoir une "Function" qui me renvoie la valeur dans la cellule
de la colonne H dès que la cellule de la colonne G est supérieure à 0.
Pour l'instant, j'ai le résultat avec une boucle dans une macro, mais
j'aimerai que cela se fasse en temps réel, donc une fonction que je ne
parviens pas à élaborer.
Je pense que c'est plus clair.
D'avance, merci







Sam
Le #16634041
Bonjour,
avec =RECHERCHEV(0;V1:W1000;2)
j'obtiens la valeur face au dernier 0 mais pas la valeur face au premier
nombre positif
Nota je n'ai pas de solution à proposer pour l'instant.

Cordialement
Michel dit "Sam"

"milloche"
Et ça marche
Grand merci et bon courage
"Jacky"
Bonsoir,

Essaie
=RECHERCHEV(0;V1:W1000;2)

--
Salutations
JJ


"milloche"
Rebonjour,
Je me suis sans doute mal exprimé, alors, je reprends la file.
J'ai une colonne G, des formules ou le résultat des premières ligne est
toujours 0, puis les cellules deviennent positives.
J'ai une colonne H, aussi des formules dont les valeurs sont diverses.
J'aimerais avoir une "Function" qui me renvoie la valeur dans la cellule
de la colonne H dès que la cellule de la colonne G est supérieure à 0.
Pour l'instant, j'ai le résultat avec une boucle dans une macro, mais
j'aimerai que cela se fasse en temps réel, donc une fonction que je ne
parviens pas à élaborer.
Je pense que c'est plus clair.
D'avance, merci











Sam
Le #16634191
Bonjour, ça semble être mieux
=INDEX(V1:W6;EQUIV(0;V1:V6;1)+1;2)
Cordialement
Michel dit "Sam"

"Sam" 48b45881$0$922$
Bonjour,
avec =RECHERCHEV(0;V1:W1000;2)
j'obtiens la valeur face au dernier 0 mais pas la valeur face au premier
nombre positif
Nota je n'ai pas de solution à proposer pour l'instant.

Cordialement
Michel dit "Sam"

"milloche"
Et ça marche
Grand merci et bon courage
"Jacky"
Bonsoir,

Essaie
=RECHERCHEV(0;V1:W1000;2)

--
Salutations
JJ


"milloche"
Rebonjour,
Je me suis sans doute mal exprimé, alors, je reprends la file.
J'ai une colonne G, des formules ou le résultat des premières ligne est
toujours 0, puis les cellules deviennent positives.
J'ai une colonne H, aussi des formules dont les valeurs sont diverses.
J'aimerais avoir une "Function" qui me renvoie la valeur dans la
cellule de la colonne H dès que la cellule de la colonne G est
supérieure à 0.
Pour l'instant, j'ai le résultat avec une boucle dans une macro, mais
j'aimerai que cela se fasse en temps réel, donc une fonction que je ne
parviens pas à élaborer.
Je pense que c'est plus clair.
D'avance, merci















Jacky
Le #16634741
Heuu....
La demande est:

col V col W
0,00 15000
0,00 12000
0,00 13500
8.00 12288
14,5 10284
18.25 9184
Je voudrais une fonction à placer ou je veux qui me renvoie en temps réel,
le résultat 13500 dans le cas présent.
C'est à dire juste avant que la col V devienne positive



Donc, nous disions JUSTE AVANT que la col V devienne positive
;o)))
--
Salutations
JJ


"Sam" 48b45881$0$922$
Bonjour,
avec =RECHERCHEV(0;V1:W1000;2)
j'obtiens la valeur face au dernier 0 mais pas la valeur face au premier
nombre positif
Nota je n'ai pas de solution à proposer pour l'instant.

Cordialement
Michel dit "Sam"

"milloche"
Et ça marche
Grand merci et bon courage
"Jacky"
Bonsoir,

Essaie
=RECHERCHEV(0;V1:W1000;2)

--
Salutations
JJ


"milloche"
Rebonjour,
Je me suis sans doute mal exprimé, alors, je reprends la file.
J'ai une colonne G, des formules ou le résultat des premières ligne est
toujours 0, puis les cellules deviennent positives.
J'ai une colonne H, aussi des formules dont les valeurs sont diverses.
J'aimerais avoir une "Function" qui me renvoie la valeur dans la
cellule de la colonne H dès que la cellule de la colonne G est
supérieure à 0.
Pour l'instant, j'ai le résultat avec une boucle dans une macro, mais
j'aimerai que cela se fasse en temps réel, donc une fonction que je ne
parviens pas à élaborer.
Je pense que c'est plus clair.
D'avance, merci















Sam
Le #16642521
Oups , je n'avais pas vu la 2eme version !
j'en étais resté au mail du 26/8 :
"J'aimerais avoir une "Function" qui me renvoie la valeur dans la cellule de
la colonne H dès que la cellule de la colonne G est supérieure à 0."

Cordialement
Michel dit "Sam"

"Jacky"
Heuu....
La demande est:

col V col W
0,00 15000
0,00 12000
0,00 13500
8.00 12288
14,5 10284
18.25 9184
Je voudrais une fonction à placer ou je veux qui me renvoie en temps réel,
le résultat 13500 dans le cas présent.
C'est à dire juste avant que la col V devienne positive



Donc, nous disions JUSTE AVANT que la col V devienne positive
;o)))
--
Salutations
JJ


"Sam" 48b45881$0$922$
Bonjour,
avec =RECHERCHEV(0;V1:W1000;2)
j'obtiens la valeur face au dernier 0 mais pas la valeur face au premier
nombre positif
Nota je n'ai pas de solution à proposer pour l'instant.

Cordialement
Michel dit "Sam"

"milloche"
Et ça marche
Grand merci et bon courage
"Jacky"
Bonsoir,

Essaie
=RECHERCHEV(0;V1:W1000;2)

--
Salutations
JJ


"milloche"
Rebonjour,
Je me suis sans doute mal exprimé, alors, je reprends la file.
J'ai une colonne G, des formules ou le résultat des premières ligne
est toujours 0, puis les cellules deviennent positives.
J'ai une colonne H, aussi des formules dont les valeurs sont diverses.
J'aimerais avoir une "Function" qui me renvoie la valeur dans la
cellule de la colonne H dès que la cellule de la colonne G est
supérieure à 0.
Pour l'instant, j'ai le résultat avec une boucle dans une macro, mais
j'aimerai que cela se fasse en temps réel, donc une fonction que je ne
parviens pas à élaborer.
Je pense que c'est plus clair.
D'avance, merci



















Publicité
Poster une réponse
Anonyme