Fonction VraixFaux

Le
John
Bonjour,

Dans Excel j'ai les conditions suivantes :=SI(I2<100;I2;100)
SI(I2>500;400;(I2-K2))
SI(I2<500;0;(I2-K2-L2))

Je voudrai les retrouver dans Access avec VraiFaux comment les écrires ?
Pour I2 dans Excel le champ Access = "Calcul"
Pour K2 = "Tranche1"
Pour L2 = "Tranche2"

Si calcul est <100 on écrit la valeur du champ "calcul"
Si calcul est > 500 on écrit 400 sinon on fait "calcul - Tranche1"
etc.

Merci d'avance.


--
John.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
P. BENNOIT
Le #6382601
Bonjour,

Dans Excel j'ai les conditions suivantes :=SI(I2<100;I2;100)
SI(I2>500;400;(I2-K2))
SI(I2<500;0;(I2-K2-L2))

Je voudrai les retrouver dans Access avec VraiFaux comment les écrires ?
Pour I2 dans Excel le champ Access = "Calcul"
Pour K2 = "Tranche1"
Pour L2 = "Tranche2"

Si calcul est <100 on écrit la valeur du champ "calcul"
Si calcul est > 500 on écrit 400 sinon on fait "calcul - Tranche1"
etc....

Merci d'avance.


Bonjour,


il me semble :
vraifaux([calcul]<100;[calcul];100)
vraifaux([calcul]>500;400;[calcul]-[tranche1])
vraifaux([calcul]<500;0;[calcul]-[tranche1]-[tranche2])


Cordialement.
Pascal

John
Le #6332801
Merci,

La ligne 2 n'est pas bonne, vraifaux([calcul]>500;400;[calcul]-[tranche1])
il doit y avoir 0 alors que j'ai -152.

Access:
Calcul = 84
Tranche 1 = 236
Tranche 2 = -152
Tranche 3 = 0

Dans Excel c'est bon, j'ai :
Calcul = 84
Tranche 1 = 84
Tranche 2 = 0
Tranche 3 = 0

Encore merci pour votre aide.
--
John.



Bonjour,

Dans Excel j'ai les conditions suivantes :=SI(I2<100;I2;100)
SI(I2>500;400;(I2-K2))
SI(I2<500;0;(I2-K2-L2))

Je voudrai les retrouver dans Access avec VraiFaux comment les écrires ?
Pour I2 dans Excel le champ Access = "Calcul"
Pour K2 = "Tranche1"
Pour L2 = "Tranche2"

Si calcul est <100 on écrit la valeur du champ "calcul"
Si calcul est > 500 on écrit 400 sinon on fait "calcul - Tranche1"
etc....

Merci d'avance.


Bonjour,


il me semble :
vraifaux([calcul]<100;[calcul];100)
vraifaux([calcul]>500;400;[calcul]-[tranche1])
vraifaux([calcul]<500;0;[calcul]-[tranche1]-[tranche2])


Cordialement.
Pascal




John
Le #6332781
Excuses

Je me suis trompé de nom dans le champ de la tranche 1, maintenant c'est bon.
@+
--
John.



Bonjour,

Dans Excel j'ai les conditions suivantes :=SI(I2<100;I2;100)
SI(I2>500;400;(I2-K2))
SI(I2<500;0;(I2-K2-L2))

Je voudrai les retrouver dans Access avec VraiFaux comment les écrires ?
Pour I2 dans Excel le champ Access = "Calcul"
Pour K2 = "Tranche1"
Pour L2 = "Tranche2"

Si calcul est <100 on écrit la valeur du champ "calcul"
Si calcul est > 500 on écrit 400 sinon on fait "calcul - Tranche1"
etc....

Merci d'avance.


Bonjour,


il me semble :
vraifaux([calcul]<100;[calcul];100)
vraifaux([calcul]>500;400;[calcul]-[tranche1])
vraifaux([calcul]<500;0;[calcul]-[tranche1]-[tranche2])


Cordialement.
Pascal




Publicité
Poster une réponse
Anonyme