Fonctions GAUCHE ou Droite combinées

Le
Bruno
Bonjour,

J'ai une chaine de caractère composée de la façon suivante :
20080210192635 dans laquelle les 4 premiers caractère correspondent à
l'année, le deux suivants au mois et les deux suivants au jour et les
caractère suivants au n° d'ordre en fonction de la date.
Comment puis-je en une seule manip extraire la date avec précision ? Je sais
le faire en décomposant : L'année , le moi et le jour, mais je ne sais pas le
faire en recomposant la date au format jj/mm/aaaa avec une seule manip^.
Merci de votre aide,
Bruno
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JPMonnier
Le #17648681
Bonjour,
en A1
ÚTEVAL(STXT(A1;7;2)&"/"&STXT(A1;5;2)&"/"&GAUCHE(A1;4))
format de cellule en date
--
Cordialement

"Bruno" news:
Bonjour,

J'ai une chaine de caractère composée de la façon suivante :
20080210192635 dans laquelle les 4 premiers caractère correspondent à
l'année, le deux suivants au mois et les deux suivants au jour et les
caractère suivants au n° d'ordre en fonction de la date.
Comment puis-je en une seule manip extraire la date avec précision ? Je
sais
le faire en décomposant : L'année , le moi et le jour, mais je ne sais pas
le
faire en recomposant la date au format jj/mm/aaaa avec une seule manip^.
Merci de votre aide,
Bruno


Daniel.C
Le #17648671
Bonjour.
A la "Modeste" :
=TEXTE(GAUCHE(A15;8);"0000/00/00")*1
Format de cellule : date courte.
Daniel

Bonjour,

J'ai une chaine de caractère composée de la façon suivante :
20080210192635 dans laquelle les 4 premiers caractère correspondent à
l'année, le deux suivants au mois et les deux suivants au jour et les
caractère suivants au n° d'ordre en fonction de la date.
Comment puis-je en une seule manip extraire la date avec précision ? Je sais
le faire en décomposant : L'année , le moi et le jour, mais je ne sais pas le
faire en recomposant la date au format jj/mm/aaaa avec une seule manip^.
Merci de votre aide,
Bruno


isabelle
Le #17648761
bonjour Bruno,

ÚTE(GAUCHE(A1;4);STXT(A1;5;2);STXT(A1;7;2))

à mettre au format de ton choix,

isabelle

Bruno a écrit :
Bonjour,

J'ai une chaine de caractère composée de la façon suivante :
20080210192635 dans laquelle les 4 premiers caractère correspondent à
l'année, le deux suivants au mois et les deux suivants au jour et les
caractère suivants au n° d'ordre en fonction de la date.
Comment puis-je en une seule manip extraire la date avec précision ? Je sais
le faire en décomposant : L'année , le moi et le jour, mais je ne sais pas le
faire en recomposant la date au format jj/mm/aaaa avec une seule manip^.
Merci de votre aide,
Bruno


laurent.daures
Le #17648661
Bonjour
la date
=DROITE(GAUCHE(A1;8);2)&"/"&DROITE(GAUCHE(A1;6);2)&"/"&GAUCHE(A1;4)
et pour le numéro d'ordre
=DROITE(A1;NBCAR(A1)-8)
Amicalement
Siesting Hoax
"Bruno"
Bonjour,

J'ai une chaine de caractère composée de la façon suivante :
20080210192635 dans laquelle les 4 premiers caractère correspondent à
l'année, le deux suivants au mois et les deux suivants au jour et les
caractère suivants au n° d'ordre en fonction de la date.
Comment puis-je en une seule manip extraire la date avec précision ? Je
sais
le faire en décomposant : L'année , le moi et le jour, mais je ne sais pas
le
faire en recomposant la date au format jj/mm/aaaa avec une seule manip^.
Merci de votre aide,
Bruno


Modeste
Le #17649061
Bonsour® Daniel.C avec ferveur ;o))) vous nous disiez :

A la "Modeste" :
=TEXTE(GAUCHE(A15;8);"0000/00/00")*1
Format de cellule : date courte.



;o)))
bientôt je ne pourrais plus en placer une ...
;o)))
Daniel.C
Le #17649171
Bonjour.
;-)))
Disciplus Simplex

Bonsour® Daniel.C avec ferveur ;o))) vous nous disiez :

A la "Modeste" :
=TEXTE(GAUCHE(A15;8);"0000/00/00")*1
Format de cellule : date courte.



;o)))
bientôt je ne pourrais plus en placer une ...
;o)))


Jacquouille
Le #17649621
Avec vos cochoncetés de slach, on dirait des V majuscules.
Heureux que mon neurone soit bien réveillé.
On devrait interdire cela ...-)

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Modeste"
Bonsour® Daniel.C avec ferveur ;o))) vous nous disiez :

A la "Modeste" :
=TEXTE(GAUCHE(A15;8);"0000/00/00")*1
Format de cellule : date courte.



;o)))
bientôt je ne pourrais plus en placer une ...
;o)))
Sam
Le #17649711
Bonjour,
j'ai eu le même tour, je ne comprenais pas ce / !
c'est comme ça qu'on apprend !
Cordialement
Michel dit "Sam"

"Jacquouille" news:
Avec vos cochoncetés de slach, on dirait des V majuscules.
Heureux que mon neurone soit bien réveillé.
On devrait interdire cela ...-)

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Modeste"
Bonsour® Daniel.C avec ferveur ;o))) vous nous disiez :

A la "Modeste" :
=TEXTE(GAUCHE(A15;8);"0000/00/00")*1
Format de cellule : date courte.



;o)))
bientôt je ne pourrais plus en placer une ...
;o)))





Publicité
Poster une réponse
Anonyme