fonctions si...mais

Le
marc
Bonjour à vous tous
Voici mon problème
Dans une feuille Database j'ai trois colonnes
A = Numéro de début
B = Numéro de fin
C = Noms
J'ai plus de 300 lignes.
Dans la colonne A et B, ce sont des numéros de dossiers, donc, pas de format
numérique

Voici un exemple
A B
C
10500-000-00000 11999-999-00000 test
12000-000-00000 12500-000-00000 jeudi

et ainsi de suite

Sur l'autre feuille, je veux que si j'inscrit dans la colonne A un numéro de
dossier dans la fourchette (entre le chiffre de la colonne A et B) qui
m'écrivent le texte qui est dans la colonne C

Exemple
A B
10900-005-36525 test


Je suis à la recherche d'une formule, si possible, pas d'une macro.
En espérant avoir été assez explicite

Voici un fichier d'exemple
http://cjoint.com/?cow4EGvNhc

Merci de votre aide

Marc
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #5276361
Bonsoir.
En B2, formule matricielle (valider avec CTTRL+MAJ+Entrée) :
=INDEX(Database!C2:C15;EQUIV(1;(Database!A2:A15<¢)*(Database!B2:B15>=Liste!A2);0))
MAIS, il y a des trous : entre B3 et A4, par exemple:
12500-400-00000
La formule renvoie #NA!
Cordialement.
Daniel
"marc" %
Bonjour à vous tous
Voici mon problème
Dans une feuille Database j'ai trois colonnes
A = Numéro de début
B = Numéro de fin
C = Noms
J'ai plus de 300 lignes.
Dans la colonne A et B, ce sont des numéros de dossiers, donc, pas de
format numérique

Voici un exemple
A B C
10500-000-00000 11999-999-00000 test
12000-000-00000 12500-000-00000 jeudi

et ainsi de suite

Sur l'autre feuille, je veux que si j'inscrit dans la colonne A un numéro
de dossier dans la fourchette (entre le chiffre de la colonne A et B) qui
m'écrivent le texte qui est dans la colonne C

Exemple
A B
10900-005-36525 test


Je suis à la recherche d'une formule, si possible, pas d'une macro.
En espérant avoir été assez explicite

Voici un fichier d'exemple
http://cjoint.com/?cow4EGvNhc

Merci de votre aide

Marc



Ellimac
Le #5276161
Bonjour,
Avec 10900-005-36525 en A1 de laf euille2 :
=RECHERCHEV(A1;Feuil1!A1:C300;3)

Camille

"marc" %
Bonjour à vous tous
Voici mon problème
Dans une feuille Database j'ai trois colonnes
A = Numéro de début
B = Numéro de fin
C = Noms
J'ai plus de 300 lignes.
Dans la colonne A et B, ce sont des numéros de dossiers, donc, pas de
format numérique

Voici un exemple
A B C
10500-000-00000 11999-999-00000 test
12000-000-00000 12500-000-00000 jeudi

et ainsi de suite

Sur l'autre feuille, je veux que si j'inscrit dans la colonne A un numéro
de dossier dans la fourchette (entre le chiffre de la colonne A et B) qui
m'écrivent le texte qui est dans la colonne C

Exemple
A B
10900-005-36525 test


Je suis à la recherche d'une formule, si possible, pas d'une macro.
En espérant avoir été assez explicite

Voici un fichier d'exemple
http://cjoint.com/?cow4EGvNhc

Merci de votre aide

Marc




marc
Le #5275861
Bonjour Camille et Daniel.

Merci de votre aide
Marc

"Ellimac"
Bonjour,
Avec 10900-005-36525 en A1 de laf euille2 :
=RECHERCHEV(A1;Feuil1!A1:C300;3)

Camille

"marc" %
Bonjour à vous tous
Voici mon problème
Dans une feuille Database j'ai trois colonnes
A = Numéro de début
B = Numéro de fin
C = Noms
J'ai plus de 300 lignes.
Dans la colonne A et B, ce sont des numéros de dossiers, donc, pas de
format numérique

Voici un exemple
A B C
10500-000-00000 11999-999-00000 test
12000-000-00000 12500-000-00000 jeudi

et ainsi de suite

Sur l'autre feuille, je veux que si j'inscrit dans la colonne A un numéro
de dossier dans la fourchette (entre le chiffre de la colonne A et B) qui
m'écrivent le texte qui est dans la colonne C

Exemple
A B
10900-005-36525 test


Je suis à la recherche d'une formule, si possible, pas d'une macro.
En espérant avoir été assez explicite

Voici un fichier d'exemple
http://cjoint.com/?cow4EGvNhc

Merci de votre aide

Marc








Publicité
Poster une réponse
Anonyme