Format champ de fusion

Le
Fab
Bonjour,

Je n'arrive pas à résoudre ce problème de format de champ de fusion extrait
d'un fichier Excel.
Il me semble pourtant que j'ai bien mis le format correctement, mais cela ne
fonctionne pas du tout

Voilà ce que j'ai :
NET IMPOSABLE = { MERGEFIELD "IMPOT" # "## ### ?" }

j'ai essayé aussi :

NET IMPOSABLE = { MERGEFIELD IMPOT # "## ### ?" }

mais Word s'obstine à afficher après un "alt F9"

NET IMPOSABLE = 11130,130000000001

d'autant plus que le chiffre réel est 11130,13 (et non 11130,130000etc .)

Qu'est ce qui cloche ?? où ai-je fais une erreur ??

Je bosse avec :
windows XP sp1
word 2003
excel 2003

Merci d'avance pour votre aide

--
Fabienne
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Circé
Le #6174921
Bonjour Fab,


Encore un coup du protocole OLE ! :(

Tes champs sont OK, les guillemets pour les noms de champs sont
facultatifs pour les noms simples sans espaces. Idem pour les
commutateurs.

L'utilisation du protocole DDE devrait régler ton problème. La solution
est ici :
http://faqword.free.fr/articles.php?lng=fr&pgW2

Circé
http://faqword.free.fr

Fab avait écrit le 22/04/2008 :
Bonjour,

Je n'arrive pas à résoudre ce problème de format de champ de fusion extrait
d'un fichier Excel.
Il me semble pourtant que j'ai bien mis le format correctement, mais cela ne
fonctionne pas du tout

Voilà ce que j'ai :
NET IMPOSABLE = { MERGEFIELD "IMPOT" # "## ### ?" }

j'ai essayé aussi :

NET IMPOSABLE = { MERGEFIELD IMPOT # "## ### ?" }

mais Word s'obstine à afficher après un "alt F9"

NET IMPOSABLE = 11130,130000000001

d'autant plus que le chiffre réel est 11130,13 (et non 11130,130000etc .)

Qu'est ce qui cloche ?? où ai-je fais une erreur ??

Je bosse avec :
windows XP sp1
word 2003
excel 2003

Merci d'avance pour votre aide


JièL
Le #6174901
Bonjoir(c) Circé

Le 22/04/2008 18:44 vous avez écrit ceci :
Bonjour Fab,


Encore un coup du protocole OLE ! :(


le " ?" (qui doit être " ¤" je suppose) ne serait pas en cause ?

--
JièL / Jean-Louis GOUBERT
La FAQ Outlook a déménagé : http://faq.outlook.fr/

Boycott des questions venant de CDO
http://faq.outlook.fr/viewpage.php?page_id=2

Circé
Le #6174881
Hello JièL,

JièL a pensé très fort :
Bonjoir(c) Circé

Le 22/04/2008 18:44 vous avez écrit ceci :
Bonjour Fab,


Encore un coup du protocole OLE ! :(


le " ?" (qui doit être " ¤" je suppose) ne serait pas en cause ?


Je suppose effectivement que le ? est le ¤. Cela dit Word n'est pas
regardant là dessus, on peut lui mettre n'importe quoi !!! ;)

Circé
http://faqword.free.fr


Fab
Le #6330811
bjr,

Oui en effet le "?" est bien un "¤" .... j'ma gourré ... le copier-coller à
merdoyer !!!

Fab

--
Fabienne
"Circé"
Hello JièL,

JièL a pensé très fort :
Bonjoir(c) Circé

Le 22/04/2008 18:44 vous avez écrit ceci :
Bonjour Fab,


Encore un coup du protocole OLE ! :(


le " ?" (qui doit être " ¤" je suppose) ne serait pas en cause ?


Je suppose effectivement que le ? est le ¤. Cela dit Word n'est pas
regardant là dessus, on peut lui mettre n'importe quoi !!! ;)

Circé
http://faqword.free.fr






Fab
Le #6330801
Bjr,

yesssssssssssssssssssss youpi tra la la tchao OLE bonjour DDE !!

Et merci pour cette aide précieuse

--
Fabienne


"Circé"
Bonjour Fab,


Encore un coup du protocole OLE ! :(

Tes champs sont OK, les guillemets pour les noms de champs sont
facultatifs pour les noms simples sans espaces. Idem pour les
commutateurs.

L'utilisation du protocole DDE devrait régler ton problème. La solution
est ici :
http://faqword.free.fr/articles.php?lng=fr&pgW2

Circé
http://faqword.free.fr

Fab avait écrit le 22/04/2008 :
Bonjour,

Je n'arrive pas à résoudre ce problème de format de champ de fusion
extrait


d'un fichier Excel.
Il me semble pourtant que j'ai bien mis le format correctement, mais
cela ne


fonctionne pas du tout

Voilà ce que j'ai :
NET IMPOSABLE = { MERGEFIELD "IMPOT" # "## ### ?" }

j'ai essayé aussi :

NET IMPOSABLE = { MERGEFIELD IMPOT # "## ### ?" }

mais Word s'obstine à afficher après un "alt F9"

NET IMPOSABLE = 11130,130000000001

d'autant plus que le chiffre réel est 11130,13 (et non 11130,130000etc
.)



Qu'est ce qui cloche ?? où ai-je fais une erreur ??

Je bosse avec :
windows XP sp1
word 2003
excel 2003

Merci d'avance pour votre aide






Publicité
Poster une réponse
Anonyme