Format personnalisé - Comment supprimé le signe décimal

Le
Corona
Bonjour,
J'ai appliqué un format personnalisé de telle manière que lorsque l'on
encode le chiffre 1 apparaisse "1 an" et lorsque le nombre est supérieur
à 1 apparaisse "2, 3 etc .. soit "x ans".
Tout cela fonctionne parfaitement.
Je voudrais maintenant que lorsque l'on tape 0,10 ou 0,02 la cellule
affiche "10 mois" ou "2 mois"
Malheureusement cela fonctionne partiellement. J'obtiens ",10 mois"
",02 mois".

Le format personnalisé appliqué est '[<1],#0" mois";[>=2]0" ans";0" an"'
Quelqu'un a t'il une idée ?
Merci pour vos lumières
Philippe Tulliez
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #20399601
Bonjour,

A défaut de mieux
[<1].#0" mois";[=1]0" an";0" ans"

Sans être tout à fait ce que tu souhaites.
;o)
--
Salutations
JJ


"Corona"
Bonjour,
J'ai appliqué un format personnalisé de telle manière que lorsque l'on
encode le chiffre 1 apparaisse "1 an" et lorsque le nombre est supérieur à
1 apparaisse "2, 3 etc .. soit "x ans".
Tout cela fonctionne parfaitement.
Je voudrais maintenant que lorsque l'on tape 0,10 ou 0,02 la cellule
affiche "10 mois" ou "2 mois"
Malheureusement cela fonctionne partiellement. J'obtiens ",10 mois" ",02
mois".

Le format personnalisé appliqué est '[<1],#0" mois";[>=2]0" ans";0" an"'
Quelqu'un a t'il une idée ?
Merci pour vos lumières
Philippe Tulliez


Jacky
Le #20399891
Pffff !!!!
Oublie vite ma réponse.

--
Salutations
JJ


"Jacky" %
Bonjour,

A défaut de mieux
[<1].#0" mois";[=1]0" an";0" ans"

Sans être tout à fait ce que tu souhaites.
;o)
--
Salutations
JJ


"Corona"
Bonjour,
J'ai appliqué un format personnalisé de telle manière que lorsque l'on
encode le chiffre 1 apparaisse "1 an" et lorsque le nombre est supérieur
à 1 apparaisse "2, 3 etc .. soit "x ans".
Tout cela fonctionne parfaitement.
Je voudrais maintenant que lorsque l'on tape 0,10 ou 0,02 la cellule
affiche "10 mois" ou "2 mois"
Malheureusement cela fonctionne partiellement. J'obtiens ",10 mois" ",02
mois".

Le format personnalisé appliqué est '[<1],#0" mois";[>=2]0" ans";0" an"'
Quelqu'un a t'il une idée ?
Merci pour vos lumières
Philippe Tulliez






Publicité
Poster une réponse
Anonyme