Format téléphone

Le
zebulator
Bonjour,

J'ai récupéré un fichier que je dois traiter avec, entre autre, des numéros
de téléphones présentés comme suit :
0 825 827 829
825827829
08/25/82/78/29
08.25.82.78.29
08-25-82-78-29

un coup en texte, en numerique, avec des "/", des "." ou des "-" !

je voulais, en une seule formule, déformater ces contenus et tous les passer
en numérique et affichage spécial (numéros de téléphones francais).

j'ai testé chaque éléments séparément et cela fontionne :
0 825 827 829 = CNUM(A1)
825827829 rien à faire
08/25/82/78/29 = SI(TROUVE("/";A1);CNUM(SUBSTITUE(A1;"/";"";1)))
08.25.82.78.29 = SI(TROUVE(".";A1);CNUM(SUBSTITUE(A1;".";"";1)))
08-25-82-78-29 = SI(TROUVE("-";A1);CNUM(SUBSTITUE(A1;"-";"";1)))

mais si je met tout en une seule fonction, j'ai l'erreur "#VALEUR!"

la fonction qui déconne :
=SI(TROUVE("/";A1);CNUM(SUBSTITUE(A1;"/";"";1));SI(TROUVE(".";A1);CNUM(SUBSTITUE(A1;".";"";1));SI(TROUVE("-";A1);CNUM(SUBSTITUE(A1;"-";"";1)))))

si un gourou d'Excel avait une solution ou un début de piste

Merci

Zeb
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Caetera
Le #22180421
"zebulator"
J'ai récupéré un fichier que je dois traiter avec, entre autre, des numéros de
téléphones présentés comme suit :
0 825 827 829
825827829
08/25/82/78/29
08.25.82.78.29
08-25-82-78-29



************
La cellule au format "téléphone" :

=1*SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(A1;" ";"");"-";"");"/";"");".";"")

Etc
zebulator
Le #22180411
Arf, c'était si simple....

J'ai cherché à compliquer en fait avec mes SI imbriqués.

Merci pour la solution en tout cas

Bien cordialement

Zeb

"Caetera" news:%23t4d6rj$
"zebulator" news:
J'ai récupéré un fichier que je dois traiter avec, entre autre, des
numéros de téléphones présentés comme suit :
0 825 827 829
825827829
08/25/82/78/29
08.25.82.78.29
08-25-82-78-29



************
La cellule au format "téléphone" :

=1*SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(A1;"
";"");"-";"");"/";"");".";"")

Etc

Publicité
Poster une réponse
Anonyme