formulaire et sous formulaire (liaison)

Le
BRUNOKILIAN15
Bonjour à tous,

J'ai un petit soucis dans ma petite application.

J'ai une table famille et une table enfants. J'ai fais une requete pour
qu'il y ait un lien entre la famille de rattachement et les enfants.

Dans un formulaire "saisie des donnée", j'ai tous les champs de la table
famille. J'ai ajouté un sous formulaire "enfants" pour qu'il puisse
m'enregistrer plusieurs enfants pour une famille. Cela ne fonctionne pas.

Si j'arrive à inclure le sous formulaire dans le formulaire lors de
l'exécution il affiche bien les données que je saisis mais elles ne sont pas
prises en compte dans la table enfants.

Merci à qui veut m'aider
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Gilbert
Le #6326631
Bonjour,
Qu'entends-tu par "elles ne sont pas prises en compte dans la table
enfants"?
Rien n'est enregistré dans la table Enfants?
Ou les données y sont mais ne sont pas liées à la table Parents?

As-tu créé une relation entre les 2 tables?
Y-a-t'il un champ dans ta table Enfants qui permet d'établir cette relation?

--
Cordialement,

Gilbert


"BRUNOKILIAN15" message de news:
Bonjour à tous,

J'ai un petit soucis dans ma petite application.

J'ai une table famille et une table enfants. J'ai fais une requete pour
qu'il y ait un lien entre la famille de rattachement et les enfants.

Dans un formulaire "saisie des donnée", j'ai tous les champs de la table
famille. J'ai ajouté un sous formulaire "enfants" pour qu'il puisse
m'enregistrer plusieurs enfants pour une famille. Cela ne fonctionne pas.

Si j'arrive à inclure le sous formulaire dans le formulaire lors de
l'exécution il affiche bien les données que je saisis mais elles ne sont
pas
prises en compte dans la table enfants.

Merci à qui veut m'aider



BRUNOKILIAN15
Le #6386831
Merci de ton tuyau.
Je suis débutant et je construis pas à pas

Si tu veux voir ce que j'ai fais et pourquoi cela ne fonctionne pas c'est
parfois plus simple


Bonjour,
Qu'entends-tu par "elles ne sont pas prises en compte dans la table
enfants"?
Rien n'est enregistré dans la table Enfants?
Ou les données y sont mais ne sont pas liées à la table Parents?

As-tu créé une relation entre les 2 tables?
Y-a-t'il un champ dans ta table Enfants qui permet d'établir cette relation?

--
Cordialement,

Gilbert


"BRUNOKILIAN15" message de news:
Bonjour à tous,

J'ai un petit soucis dans ma petite application.

J'ai une table famille et une table enfants. J'ai fais une requete pour
qu'il y ait un lien entre la famille de rattachement et les enfants.

Dans un formulaire "saisie des donnée", j'ai tous les champs de la table
famille. J'ai ajouté un sous formulaire "enfants" pour qu'il puisse
m'enregistrer plusieurs enfants pour une famille. Cela ne fonctionne pas.

Si j'arrive à inclure le sous formulaire dans le formulaire lors de
l'exécution il affiche bien les données que je saisis mais elles ne sont
pas
prises en compte dans la table enfants.

Merci à qui veut m'aider








BRUNOKILIAN15
Le #6386811
http://cjoint.com/?kxj7prDYMr


Merci de ton tuyau.
Je suis débutant et je construis pas à pas

Si tu veux voir ce que j'ai fais et pourquoi cela ne fonctionne pas c'est
parfois plus simple


Bonjour,
Qu'entends-tu par "elles ne sont pas prises en compte dans la table
enfants"?
Rien n'est enregistré dans la table Enfants?
Ou les données y sont mais ne sont pas liées à la table Parents?

As-tu créé une relation entre les 2 tables?
Y-a-t'il un champ dans ta table Enfants qui permet d'établir cette relation?

--
Cordialement,

Gilbert


"BRUNOKILIAN15" message de news:
Bonjour à tous,

J'ai un petit soucis dans ma petite application.

J'ai une table famille et une table enfants. J'ai fais une requete pour
qu'il y ait un lien entre la famille de rattachement et les enfants.

Dans un formulaire "saisie des donnée", j'ai tous les champs de la table
famille. J'ai ajouté un sous formulaire "enfants" pour qu'il puisse
m'enregistrer plusieurs enfants pour une famille. Cela ne fonctionne pas.

Si j'arrive à inclure le sous formulaire dans le formulaire lors de
l'exécution il affiche bien les données que je saisis mais elles ne sont
pas
prises en compte dans la table enfants.

Merci à qui veut m'aider










Thierry (ze Titi)
Le #6386791
Bonjour Bruno !

As-tu jeté un oeil au champ de liaison entre le formulaire principal et
le sous-formulaire ? Tu as établi ta liaison sur la date de
naissance... Pas étonnant que ça ne fonctionne pas. Ton champ de
liaison entre les deux tables semble être refListe, c'est donc lui
qu'il faut utiliser !

Dans ton message du mardi 23/10/2007 jour de Saint Jean de Capistran., tu as pris
l'initiative de nous narrer les faits suivants:
http://cjoint.com/?kxj7prDYMr


Merci de ton tuyau.
Je suis débutant et je construis pas à pas

Si tu veux voir ce que j'ai fais et pourquoi cela ne fonctionne pas c'est
parfois plus simple


Bonjour,
Qu'entends-tu par "elles ne sont pas prises en compte dans la table
enfants"?
Rien n'est enregistré dans la table Enfants?
Ou les données y sont mais ne sont pas liées à la table Parents?

As-tu créé une relation entre les 2 tables?
Y-a-t'il un champ dans ta table Enfants qui permet d'établir cette
relation?

--
Cordialement,

Gilbert


"BRUNOKILIAN15" message de news:
Bonjour à tous,

J'ai un petit soucis dans ma petite application.

J'ai une table famille et une table enfants. J'ai fais une requete pour
qu'il y ait un lien entre la famille de rattachement et les enfants.

Dans un formulaire "saisie des donnée", j'ai tous les champs de la table
famille. J'ai ajouté un sous formulaire "enfants" pour qu'il puisse
m'enregistrer plusieurs enfants pour une famille. Cela ne fonctionne pas.

Si j'arrive à inclure le sous formulaire dans le formulaire lors de
l'exécution il affiche bien les données que je saisis mais elles ne sont
pas
prises en compte dans la table enfants.

Merci à qui veut m'aider









--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info




BRUNOKILIAN15
Le #6386611
Merci d'avoir jeté un coup d'oeil
J'ai modifié et ca fonctionne

Merci encore


Bonjour Bruno !

As-tu jeté un oeil au champ de liaison entre le formulaire principal et
le sous-formulaire ? Tu as établi ta liaison sur la date de
naissance... Pas étonnant que ça ne fonctionne pas. Ton champ de
liaison entre les deux tables semble être refListe, c'est donc lui
qu'il faut utiliser !

Dans ton message du mardi 23/10/2007 jour de Saint Jean de Capistran., tu as pris
l'initiative de nous narrer les faits suivants:
http://cjoint.com/?kxj7prDYMr


Merci de ton tuyau.
Je suis débutant et je construis pas à pas

Si tu veux voir ce que j'ai fais et pourquoi cela ne fonctionne pas c'est
parfois plus simple


Bonjour,
Qu'entends-tu par "elles ne sont pas prises en compte dans la table
enfants"?
Rien n'est enregistré dans la table Enfants?
Ou les données y sont mais ne sont pas liées à la table Parents?

As-tu créé une relation entre les 2 tables?
Y-a-t'il un champ dans ta table Enfants qui permet d'établir cette
relation?

--
Cordialement,

Gilbert


"BRUNOKILIAN15" message de news:
Bonjour à tous,

J'ai un petit soucis dans ma petite application.

J'ai une table famille et une table enfants. J'ai fais une requete pour
qu'il y ait un lien entre la famille de rattachement et les enfants.

Dans un formulaire "saisie des donnée", j'ai tous les champs de la table
famille. J'ai ajouté un sous formulaire "enfants" pour qu'il puisse
m'enregistrer plusieurs enfants pour une famille. Cela ne fonctionne pas.

Si j'arrive à inclure le sous formulaire dans le formulaire lors de
l'exécution il affiche bien les données que je saisis mais elles ne sont
pas
prises en compte dans la table enfants.

Merci à qui veut m'aider









--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info









3stone
Le #6386601
Bonjour Thierry,

"Thierry (ze Titi)"
| As-tu jeté un oeil au champ de liaison...


Comme c'est lié à la (même) question juste au dessus,
je te laisse faire... car y a du boulot ;-)

Tables et relations à voir ou revoir...
Il a voulu avancer trop vite, le copain Bruno.

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
Thierry (ze Titi)
Le #6386591
Bonjour Thierry,
Bonjour Pierre


Tables et relations à voir ou revoir...
J'avais souligné ce point sur un post précédent lié à la même

application. Mais il y a travaillé, crois-moi !
Et puis, il faut être pris pour apprendre, tu dois en savoir quelque
chose pour en être arrivé au niveau où tu es aujourd'hui. Et le forum
est là pour l'aider le Bruno !

@+

--
Cordialement,
Thierry

Tout pour réussir avec Access :
http://www.mpfa.info

3stone
Le #6386501
re Thierry,

"Thierry (ze Titi)"
| > Tables et relations à voir ou revoir...
| J'avais souligné ce point sur un post précédent lié à la même
| application. Mais il y a travaillé, crois-moi !

Je te crois... je ne lis plus qu'en diagonale c'est temps ci ;-(


| Et puis, il faut être pris pour apprendre, tu dois en savoir quelque
| chose pour en être arrivé au niveau où tu es aujourd'hui.

Et comment ;-)
Et j'ai même appris que cela fait moins mal lorsque l'on rate une marche
au début de l'escalier que lorsque l'on est déjà bien engagé :o))


| Et le forum est là pour l'aider le Bruno !

Tu prêches un converti ;-)

Bonne continuation.

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
Publicité
Poster une réponse
Anonyme