formule avec si

Le
AnB
Bonsoir
cette formule fait une erreur "valeur" car il y a une condition qui donne
"faux"
je n'arrive pas à trouver la bonne formultation
si vous avez une solution
merci par avance
SI(NBCAR(B2)=1;"T000000"&B2);SI(NBCAR(B2)=2;"T00000"&B2)
Anb
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
garnote
Le #19850341
Ave AnB,

Essaie comme ceci :

=SI(NBCAR(B2)=1;"T000000"&B2;SI(NBCAR(B2)=2;"T00000"&B2;""))

Cela te convient-il ?

Serge

"AnB" OP$dg%
Bonsoir
cette formule fait une erreur "valeur" car il y a une condition qui donne
"faux"
je n'arrive pas à trouver la bonne formultation
si vous avez une solution
merci par avance
SI(NBCAR(B2)=1;"T000000"&B2);SI(NBCAR(B2)=2;"T00000"&B2)
Anb



AnB
Le #19850521
ok

Merci

"garnote"
Ave AnB,

Essaie comme ceci :

=SI(NBCAR(B2)=1;"T000000"&B2;SI(NBCAR(B2)=2;"T00000"&B2;""))

Cela te convient-il ?

Serge

"AnB" OP$dg%
Bonsoir
cette formule fait une erreur "valeur" car il y a une condition qui donne
"faux"
je n'arrive pas à trouver la bonne formultation
si vous avez une solution
merci par avance
SI(NBCAR(B2)=1;"T000000"&B2);SI(NBCAR(B2)=2;"T00000"&B2)
Anb







Philippe.R
Le #19850721
Bonsoir,
Si j'ai bien compris, on pourrait aussi utiliser :

="T00000"&REPT("0";2-NBCAR(B2))&B2
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"AnB" news:OP$dg%
Bonsoir
cette formule fait une erreur "valeur" car il y a une condition qui donne
"faux"
je n'arrive pas à trouver la bonne formultation
si vous avez une solution
merci par avance
SI(NBCAR(B2)=1;"T000000"&B2);SI(NBCAR(B2)=2;"T00000"&B2)
Anb



garnote
Le #19850711
Salut Philippe,

J'avais essayé quelque chose de similaire mais
quand le nombre de caractères est différent
de 1 ou 2, on obteint des folies :-)

Serge


"Philippe.R"
Bonsoir,
Si j'ai bien compris, on pourrait aussi utiliser :

="T00000"&REPT("0";2-NBCAR(B2))&B2
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"AnB" news:OP$dg%
Bonsoir
cette formule fait une erreur "valeur" car il y a une condition qui donne
"faux"
je n'arrive pas à trouver la bonne formultation
si vous avez une solution
merci par avance
SI(NBCAR(B2)=1;"T000000"&B2);SI(NBCAR(B2)=2;"T00000"&B2)
Anb






Philippe.R
Le #19851781
Salut Serge,
On pourrait quand même aller jusqu'à :
="T"&REPT("0";7-NBCAR(B2))&B2
avec éventuellement une limitation de la saisie en B2 à 7 caractères via
Données / validation
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"garnote" news:%
Salut Philippe,

J'avais essayé quelque chose de similaire mais
quand le nombre de caractères est différent
de 1 ou 2, on obteint des folies :-)

Serge


"Philippe.R"
Bonsoir,
Si j'ai bien compris, on pourrait aussi utiliser :

="T00000"&REPT("0";2-NBCAR(B2))&B2
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"AnB" news:OP$dg%
Bonsoir
cette formule fait une erreur "valeur" car il y a une condition qui
donne "faux"
je n'arrive pas à trouver la bonne formultation
si vous avez une solution
merci par avance
SI(NBCAR(B2)=1;"T000000"&B2);SI(NBCAR(B2)=2;"T00000"&B2)
Anb










garnote
Le #19851811
Ave Philippe,

À un poil près, c'est la fonction que j'avais essayée.:
"T"&REPT(0;7-NBCAR(B2))&B2
On pourrait aussi se compliquer la vie ainsi :
=SI(OU(NBCAR(B2)=1;NBCAR(B2)=2);"T"&REPT(0;7-NBCAR(B2))&B2;"")
(simplifiable?)
ou avec une fonction personnalisée ::
Function rep(x)
Select Case Len(x)
Case 1 To 2: rep = "T" & Application.Rept(0, 7 - Len(x)) & x
Case Else: rep = ""
End Select
End Function

Bonsoir, Bonne nuit
Serge


"Philippe.R" %
Salut Serge,
On pourrait quand même aller jusqu'à :
="T"&REPT("0";7-NBCAR(B2))&B2
avec éventuellement une limitation de la saisie en B2 à 7 caractères via
Données / validation
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"garnote" news:%
Salut Philippe,

J'avais essayé quelque chose de similaire mais
quand le nombre de caractères est différent
de 1 ou 2, on obteint des folies :-)

Serge


"Philippe.R" news:
Bonsoir,
Si j'ai bien compris, on pourrait aussi utiliser :

="T00000"&REPT("0";2-NBCAR(B2))&B2
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"AnB" news:OP$dg%
Bonsoir
cette formule fait une erreur "valeur" car il y a une condition qui
donne "faux"
je n'arrive pas à trouver la bonne formultation
si vous avez une solution
merci par avance
SI(NBCAR(B2)=1;"T000000"&B2);SI(NBCAR(B2)=2;"T00000"&B2)
Anb













Philippe.R
Le #19856101
Salve,
=SI(OU(NBCAR(B2)=1;NBCAR(B2)=2);"T"&REPT(0;7-NBCAR(B2))&B2;"")
(simplifiable?)
=SI(NBCAR(B2)<3;"T"&REPT(0;7-NBCAR(B2))&B2;"")
peut être
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"garnote" news:u$
Ave Philippe,

À un poil près, c'est la fonction que j'avais essayée.:
"T"&REPT(0;7-NBCAR(B2))&B2
On pourrait aussi se compliquer la vie ainsi :
=SI(OU(NBCAR(B2)=1;NBCAR(B2)=2);"T"&REPT(0;7-NBCAR(B2))&B2;"")
(simplifiable?)
ou avec une fonction personnalisée ::
Function rep(x)
Select Case Len(x)
Case 1 To 2: rep = "T" & Application.Rept(0, 7 - Len(x)) & x
Case Else: rep = ""
End Select
End Function

Bonsoir, Bonne nuit
Serge


"Philippe.R" %
Salut Serge,
On pourrait quand même aller jusqu'à :
="T"&REPT("0";7-NBCAR(B2))&B2
avec éventuellement une limitation de la saisie en B2 à 7 caractères via
Données / validation
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"garnote" news:%
Salut Philippe,

J'avais essayé quelque chose de similaire mais
quand le nombre de caractères est différent
de 1 ou 2, on obteint des folies :-)

Serge


"Philippe.R" news:
Bonsoir,
Si j'ai bien compris, on pourrait aussi utiliser :

="T00000"&REPT("0";2-NBCAR(B2))&B2
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"AnB" news:OP$dg%
Bonsoir
cette formule fait une erreur "valeur" car il y a une condition qui
donne "faux"
je n'arrive pas à trouver la bonne formultation
si vous avez une solution
merci par avance
SI(NBCAR(B2)=1;"T000000"&B2);SI(NBCAR(B2)=2;"T00000"&B2)
Anb

















Publicité
Poster une réponse
Anonyme