Formule avec sous total

Le
ats.ccs
Bonjour,

Sous Excel 2000,

Est il possible au moyen d'une formule de calculer un sous total seulement
pour les valeurs de la colonne qui ne se terminent pas par un V ?
=Sous.total(3;A4:A896)
789
526
125V
327
doit me donner 3

Merci pour votre aide.
BH
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ellimac
Le #5276091
Bonjour,

=SOMME(N(DROITE(A4:A29;1)<>"v"))
Formule matricielle à valider avec CTRL Shift Entrée

Camille

"" dans le message de news:

Bonjour,

Sous Excel 2000,

Est il possible au moyen d'une formule de calculer un sous total seulement
pour les valeurs de la colonne qui ne se terminent pas par un V ?
=Sous.total(3;A4:A896)
789
526
125V
327
doit me donner 3

Merci pour votre aide.
BH



JB
Le #5276071
Bonjour,


=Somme(A4:A29) doit suffire (seules les cellules num sont prises en
compte)

JB

On 15 fév, 10:39, "Ellimac"
Bonjour,

=SOMME(N(DROITE(A4:A29;1)<>"v"))
Formule matricielle à valider avec CTRL Shift Entrée

Camille

"" dans le message de news:




Bonjour,

Sous Excel 2000,

Est il possible au moyen d'une formule de calculer un sous total seuleme nt
pour les valeurs de la colonne qui ne se terminent pas par un V ?
=Sous.total(3;A4:A896)
789
526
125V
327
doit me donner 3

Merci pour votre aide.
BH- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



Ellimac
Le #5276011
Bonjour,

Oui mais s'il n'y a pas que des nombres dans les valeurs ne se terminant pas
par un V ?

Camille

"JB"
Bonjour,


=Somme(A4:A29) doit suffire (seules les cellules num sont prises en
compte)

JB

On 15 fév, 10:39, "Ellimac"
Bonjour,

=SOMME(N(DROITE(A4:A29;1)<>"v"))
Formule matricielle à valider avec CTRL Shift Entrée

Camille

"" dans le message de news:




Bonjour,

Sous Excel 2000,

Est il possible au moyen d'une formule de calculer un sous total
seulement
pour les valeurs de la colonne qui ne se terminent pas par un V ?
=Sous.total(3;A4:A896)
789
526
125V
327
doit me donner 3

Merci pour votre aide.
BH- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



JB
Le #5275881
J'avais mal lu la question:

=NB.SI(A2:A20;"<>*v")

JB

On 15 fév, 11:32, "Ellimac"
Bonjour,

Oui mais s'il n'y a pas que des nombres dans les valeurs ne se terminant p as
par un V ?

Camille

"JB"
Bonjour,

=Somme(A4:A29) doit suffire (seules les cellules num sont prises en
compte)

JB

On 15 fév, 10:39, "Ellimac"


Bonjour,

=SOMME(N(DROITE(A4:A29;1)<>"v"))
Formule matricielle à valider avec CTRL Shift Entrée

Camille

"" dans le message de news:


Bonjour,

Sous Excel 2000,

Est il possible au moyen d'une formule de calculer un sous total
seulement
pour les valeurs de la colonne qui ne se terminent pas par un V ?
=Sous.total(3;A4:A896)
789
526
125V
327
doit me donner 3

Merci pour votre aide.
BH- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -




ats.ccs
Le #5275851
Je vous remercie pour vos réponses.

Cela ne convient pas car je recherche le nombre de valeur après un filtre.

Peux t'on améliorer la formule ?

Merci.

BH
MichDenis
Le #5166061
LaPlage est une plage nommé de la colonne que tu dois additionner (de l'étiquette de la colonne
jusqu'à la dernière valeur de la colonne
Dans ce cas : A1:A11
B1:B11 -> plage ou s'applique le critère
Le critère n'est pas sensible à la casse : V ou v cela n'a pas d'importance

Suggestion : Tu peux donner aussi un nom à la plage de critère !

=SOMMEPROD((SOUS.TOTAL(3;DECALER(LaPlage;LIGNE(LaPlage)-MIN(LIGNE(LaPlage));;1)))*(STXT(B1:B11;NBCAR(B1:B11);1)="V");LaPlage)



""
Bonjour,

Sous Excel 2000,

Est il possible au moyen d'une formule de calculer un sous total seulement
pour les valeurs de la colonne qui ne se terminent pas par un V ?
=Sous.total(3;A4:A896)
789
526
125V
327
doit me donner 3

Merci pour votre aide.
BH
Ellimac
Le #5166021
Une solution en rajouter une colonne avec un test
=si(droite(A4:A896;1)="v";"";1)
Puis faire =Sous.Total(2;B4:B896)
Attention au paramètre 2 et non 3 pour la fonction Sous.Total

Camille

"" dans le message de news:

Je vous remercie pour vos réponses.

Cela ne convient pas car je recherche le nombre de valeur après un filtre.

Peux t'on améliorer la formule ?

Merci.

BH





ats.ccs
Le #5165871
Bonsoir,

Merci pour vos réponses.

Pour Camille : je voulais éviter l'ajout de colonne car j'ai un certain
nombre de liaisons à modifier.

Pour MichDenis : après quelques soucis de compréhension, j'ai résussi mais
le résultat obtenu reste désespérement égal à zéro.

BH.

"MichDenis" wrote:

LaPlage est une plage nommé de la colonne que tu dois additionner (de l'étiquette de la colonne
jusqu'à la dernière valeur de la colonne
Dans ce cas : A1:A11
B1:B11 -> plage ou s'applique le critère
Le critère n'est pas sensible à la casse : V ou v cela n'a pas d'importance

Suggestion : Tu peux donner aussi un nom à la plage de critère !

=SOMMEPROD((SOUS.TOTAL(3;DECALER(LaPlage;LIGNE(LaPlage)-MIN(LIGNE(LaPlage));;1)))*(STXT(B1:B11;NBCAR(B1:B11);1)="V");LaPlage)



""
Bonjour,

Sous Excel 2000,

Est il possible au moyen d'une formule de calculer un sous total seulement
pour les valeurs de la colonne qui ne se terminent pas par un V ?
=Sous.total(3;A4:A896)
789
526
125V
327
doit me donner 3

Merci pour votre aide.
BH




MichDenis
Le #5165831
Un petit exemple là : http://cjoint.com/?cpvpEDzkQL



""
Bonsoir,

Merci pour vos réponses.

Pour Camille : je voulais éviter l'ajout de colonne car j'ai un certain
nombre de liaisons à modifier.

Pour MichDenis : après quelques soucis de compréhension, j'ai résussi mais
le résultat obtenu reste désespérement égal à zéro.

BH.

"MichDenis" wrote:

LaPlage est une plage nommé de la colonne que tu dois additionner (de l'étiquette de la colonne
jusqu'à la dernière valeur de la colonne
Dans ce cas : A1:A11
B1:B11 -> plage ou s'applique le critère
Le critère n'est pas sensible à la casse : V ou v cela n'a pas d'importance

Suggestion : Tu peux donner aussi un nom à la plage de critère !

=SOMMEPROD((SOUS.TOTAL(3;DECALER(LaPlage;LIGNE(LaPlage)-MIN(LIGNE(LaPlage));;1)))*(STXT(B1:B11;NBCAR(B1:B11);1)="V");LaPlage)



""
Bonjour,

Sous Excel 2000,

Est il possible au moyen d'une formule de calculer un sous total seulement
pour les valeurs de la colonne qui ne se terminent pas par un V ?
=Sous.total(3;A4:A896)
789
526
125V
327
doit me donner 3

Merci pour votre aide.
BH




ats.ccs
Le #5165791
Merci MichDenis,

Rien ne vaut un exemple concret pour des personnes limites comme moi.
Ton exemple va réellement me servir mais pour un autre cas que mon souhait
initial.
J'ai compris pourquoi je n'y arrivais pas, je n'attendais pas ce résultat.
Dans l'exemple, si je filtre 10 sur data, je veux obtenir 1 (taleur10), il y
a une valeur qui ne se termine pas par V à l'issue du filtre.
Si je filtre sur 1, le résultat attendu est zéro.
Est ce réalisable ?

BH

"MichDenis" wrote:

Un petit exemple là : http://cjoint.com/?cpvpEDzkQL



""
Bonsoir,

Merci pour vos réponses.

Pour Camille : je voulais éviter l'ajout de colonne car j'ai un certain
nombre de liaisons à modifier.

Pour MichDenis : après quelques soucis de compréhension, j'ai résussi mais
le résultat obtenu reste désespérement égal à zéro.

BH.

"MichDenis" wrote:

LaPlage est une plage nommé de la colonne que tu dois additionner (de l'étiquette de la colonne
jusqu'à la dernière valeur de la colonne
Dans ce cas : A1:A11
B1:B11 -> plage ou s'applique le critère
Le critère n'est pas sensible à la casse : V ou v cela n'a pas d'importance

Suggestion : Tu peux donner aussi un nom à la plage de critère !

=SOMMEPROD((SOUS.TOTAL(3;DECALER(LaPlage;LIGNE(LaPlage)-MIN(LIGNE(LaPlage));;1)))*(STXT(B1:B11;NBCAR(B1:B11);1)="V");LaPlage)



""
Bonjour,

Sous Excel 2000,

Est il possible au moyen d'une formule de calculer un sous total seulement
pour les valeurs de la colonne qui ne se terminent pas par un V ?
=Sous.total(3;A4:A896)
789
526
125V
327
doit me donner 3

Merci pour votre aide.
BH









Publicité
Poster une réponse
Anonyme