Formule de condition de valeur - Suppresion résultats vides

Le
freya
Bonjour à tous
J'ai une feuille 1 excel avec des données
je veux que sur ma feuille 2 soit reprise des infos de la feuilles 1

j'ai pris cette formule pour la colonne ou j'ai ma données qui m'intéresse :
=SI('Feuil1'!$B7="Tomate";'Feuil1 08'!B7;"")

et pour les colonnes suivantes bien entendu
=SI('Feuil1'!$B7="Tomates";'Feuil1'!C7;"")
D7
E7
etc.

le soucis est que je ne veux pas les lignes blanches, lignes vides

je ne veux que les résultats avec les lignes qui correspondent à Tomates


comment faire ?

sans faire le copier /coller spécial suppresion ligne vide

je veux que ce soit automatique

Merci bcp par avance
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #6564001
Bonjour.
Pour simplifier, j'ai tout mis sur la même feuille. En ligne 1 (formule
matricielle, à valider avec CTRL+MAJ+Entrée) :
=SI(ESTERR(PETITE.VALEUR(SI($B$7:$B$16="tomates";LIGNE($B$7:$B$16);"");LIGNE()));"";PETITE.VALEUR(SI($B$7:$B$16="tomates";LIGNE($B$7:$B$16);"");LIGNE())*$C$7:$C$16)
à tirer vers le bas. Si ta première formule n'est pas en ligne 1, modifie
"ligne()" pour que le résultat soit "1". Par exemple, si la première formule
est en ligne 2, tu mets "ligne()-1"
Cordialement.
Daniel
"freya"
Bonjour à tous
J'ai une feuille 1 excel avec des données
je veux que sur ma feuille 2 soit reprise des infos de la feuilles 1

j'ai pris cette formule pour la colonne ou j'ai ma données qui m'intéresse
:
=SI('Feuil1'!$B7="Tomate";'Feuil1 08'!B7;"")

et pour les colonnes suivantes bien entendu
=SI('Feuil1'!$B7="Tomates";'Feuil1'!C7;"")
...................................................D7
...................................................E7
etc.......

le soucis est que je ne veux pas les lignes blanches, lignes vides

je ne veux que les résultats avec les lignes qui correspondent à Tomates


comment faire ?

sans faire le copier /coller spécial suppresion ligne vide

je veux que ce soit automatique

Merci bcp par avance


Jacques ALARDET
Le #6564411
Bonjour Freya

C'est comme si tu voulais filtrer ta feuil1 et avoir le résultat dans la
Feuil2

Je te proposerais volontiers un "flitre élaboré avec Copier vers" qui
réalise cette fonction, mais il faut regénérer le résultat chaque que la
liste de base évolue


--
J a c q u e s

"freya" news:
Bonjour à tous
J'ai une feuille 1 excel avec des données
je veux que sur ma feuille 2 soit reprise des infos de la feuilles 1

j'ai pris cette formule pour la colonne ou j'ai ma données qui m'intéresse
:
=SI('Feuil1'!$B7="Tomate";'Feuil1 08'!B7;"")

et pour les colonnes suivantes bien entendu
=SI('Feuil1'!$B7="Tomates";'Feuil1'!C7;"")
...................................................D7
...................................................E7
etc.......

le soucis est que je ne veux pas les lignes blanches, lignes vides

je ne veux que les résultats avec les lignes qui correspondent à Tomates


comment faire ?

sans faire le copier /coller spécial suppresion ligne vide

je veux que ce soit automatique

Merci bcp par avance



Jacques ALARDET
Le #6565351
Bonjour

La formule de Daniel est trapue, mais je ne suis pas arrivé à la faire
tourner
Je ne dis pas qu'elle ne marche pas, mais c'est juste *$C$7:$C$16) que je
n'ai pas compris

Par contre j'ai pu faire tourner la formule suivante :
=SI(ESTERREUR(PETITE.VALEUR(SI(Feuil1!$A$7:$A$16="tomates";LIGNE(Feuil1!$A$7:$A$16);"");LIGNE()-1));"";DECALER(Feuil1!A$1;PETITE.VALEUR(SI(Feuil1!$A$7:$A$16="tomates";LIGNE(Feuil1!$A$7:$A$16);"");LIGNE()-1)-1;0;1;1))

bref, c'est plus complexe !

J a c q u e s

"Jacques ALARDET" news:O$
Bonjour Freya

C'est comme si tu voulais filtrer ta feuil1 et avoir le résultat dans la
Feuil2

Je te proposerais volontiers un "flitre élaboré avec Copier vers" qui
réalise cette fonction, mais il faut regénérer le résultat chaque que la
liste de base évolue


--
J a c q u e s

"freya" news:
Bonjour à tous
J'ai une feuille 1 excel avec des données
je veux que sur ma feuille 2 soit reprise des infos de la feuilles 1

j'ai pris cette formule pour la colonne ou j'ai ma données qui
m'intéresse
:
=SI('Feuil1'!$B7="Tomate";'Feuil1 08'!B7;"")

et pour les colonnes suivantes bien entendu
=SI('Feuil1'!$B7="Tomates";'Feuil1'!C7;"")
...................................................D7
...................................................E7
etc.......

le soucis est que je ne veux pas les lignes blanches, lignes vides

je ne veux que les résultats avec les lignes qui correspondent à Tomates


comment faire ?

sans faire le copier /coller spécial suppresion ligne vide

je veux que ce soit automatique

Merci bcp par avance







Daniel.C
Le #6565741
Très juste, la formule est fausse, la voici corrigée :
=SI(ESTERR(PETITE.VALEUR(SI($B$7:$B$16="tomates";LIGNE($B$7:$B$16);"");LIGNE()));"";INDEX($C$1:$C$16;PETITE.VALEUR(SI($B$7:$B$16="tomates";LIGNE($B$7:$B$16);"");LIGNE())))
Daniel
"Jacques ALARDET"
Bonjour

La formule de Daniel est trapue, mais je ne suis pas arrivé à la faire
tourner
Je ne dis pas qu'elle ne marche pas, mais c'est juste *$C$7:$C$16) que je
n'ai pas compris

Par contre j'ai pu faire tourner la formule suivante :
=SI(ESTERREUR(PETITE.VALEUR(SI(Feuil1!$A$7:$A$16="tomates";LIGNE(Feuil1!$A$7:$A$16);"");LIGNE()-1));"";DECALER(Feuil1!A$1;PETITE.VALEUR(SI(Feuil1!$A$7:$A$16="tomates";LIGNE(Feuil1!$A$7:$A$16);"");LIGNE()-1)-1;0;1;1))

bref, c'est plus complexe !

J a c q u e s

"Jacques ALARDET" news:O$
Bonjour Freya

C'est comme si tu voulais filtrer ta feuil1 et avoir le résultat dans la
Feuil2

Je te proposerais volontiers un "flitre élaboré avec Copier vers" qui
réalise cette fonction, mais il faut regénérer le résultat chaque que la
liste de base évolue


--
J a c q u e s

"freya" news:
Bonjour à tous
J'ai une feuille 1 excel avec des données
je veux que sur ma feuille 2 soit reprise des infos de la feuilles 1

j'ai pris cette formule pour la colonne ou j'ai ma données qui
m'intéresse
:
=SI('Feuil1'!$B7="Tomate";'Feuil1 08'!B7;"")

et pour les colonnes suivantes bien entendu
=SI('Feuil1'!$B7="Tomates";'Feuil1'!C7;"")
...................................................D7
...................................................E7
etc.......

le soucis est que je ne veux pas les lignes blanches, lignes vides

je ne veux que les résultats avec les lignes qui correspondent à Tomates


comment faire ?

sans faire le copier /coller spécial suppresion ligne vide

je veux que ce soit automatique

Merci bcp par avance










Jacques ALARDET
Le #6565731
Hello Daniel

Je te fais confiance et bon courage à Freya


--
J a c q u e s

"Daniel.C" news:%
Très juste, la formule est fausse, la voici corrigée :
=SI(ESTERR(PETITE.VALEUR(SI($B$7:$B$16="tomates";LIGNE($B$7:$B$16);"");LIGNE()));"";INDEX($C$1:$C$16;PETITE.VALEUR(SI($B$7:$B$16="tomates";LIGNE($B$7:$B$16);"");LIGNE())))
Daniel
"Jacques ALARDET" news:
Bonjour

La formule de Daniel est trapue, mais je ne suis pas arrivé à la faire
tourner
Je ne dis pas qu'elle ne marche pas, mais c'est juste *$C$7:$C$16) que je
n'ai pas compris

Par contre j'ai pu faire tourner la formule suivante :
=SI(ESTERREUR(PETITE.VALEUR(SI(Feuil1!$A$7:$A$16="tomates";LIGNE(Feuil1!$A$7:$A$16);"");LIGNE()-1));"";DECALER(Feuil1!A$1;PETITE.VALEUR(SI(Feuil1!$A$7:$A$16="tomates";LIGNE(Feuil1!$A$7:$A$16);"");LIGNE()-1)-1;0;1;1))

bref, c'est plus complexe !

J a c q u e s

"Jacques ALARDET" news:O$
Bonjour Freya

C'est comme si tu voulais filtrer ta feuil1 et avoir le résultat dans la
Feuil2

Je te proposerais volontiers un "flitre élaboré avec Copier vers" qui
réalise cette fonction, mais il faut regénérer le résultat chaque que la
liste de base évolue


--
J a c q u e s

"freya" news:
Bonjour à tous
J'ai une feuille 1 excel avec des données
je veux que sur ma feuille 2 soit reprise des infos de la feuilles 1

j'ai pris cette formule pour la colonne ou j'ai ma données qui
m'intéresse
:
=SI('Feuil1'!$B7="Tomate";'Feuil1 08'!B7;"")

et pour les colonnes suivantes bien entendu
=SI('Feuil1'!$B7="Tomates";'Feuil1'!C7;"")
...................................................D7
...................................................E7
etc.......

le soucis est que je ne veux pas les lignes blanches, lignes vides

je ne veux que les résultats avec les lignes qui correspondent à
Tomates


comment faire ?

sans faire le copier /coller spécial suppresion ligne vide

je veux que ce soit automatique

Merci bcp par avance














freya
Le #6624781
Merci à tous.... mais je ni suis pas arrivé

j'ai essayé aussi avec recherchev, mais erreur
freya
Le #6624761
merci à tous, mais je ni suis pas parvenu
..... oups...

j'ai essayé aussi avec rechercev, mais ça ne fonctionne pas

vous avez une idée ?

Merci
Publicité
Poster une réponse
Anonyme