FORMULE CONDITIONNEL

Le
julien_poisson
bonjour a tous et bonne année
je cherche un moyen d'inserer une formule, par exemple somme en
fonction d'un critere
un petit exemple

A B C(formule a inserer)
1 alex 10 10
2 robert 15 35
3 robert 20
4 bob 25 25
5 alain 30 105
6 alain 35
7 alain 40
8 nobert 45 45

dans mon exemple je voudrais qu'en C1 j'ai la somme pour alex soit 10
C2 et uniquement
en C2 j'ai la somme pour robert soit 35 et ainsi de suite

Merci de votre aide
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #5290561
=SI(NB.SI($A$1:A1;A1)>1;"";SOMME.SI($A$1:$A$8;A1;$B$1:$B$8))
Daniel

bonjour a tous et bonne année
je cherche un moyen d'inserer une formule, par exemple somme en
fonction d'un critere
un petit exemple

A B C(formule a inserer)
1 alex 10 10
2 robert 15 35
3 robert 20
4 bob 25 25
5 alain 30 105
6 alain 35
7 alain 40
8 nobert 45 45

dans mon exemple je voudrais qu'en C1 j'ai la somme pour alex soit 10
C2 et uniquement
en C2 j'ai la somme pour robert soit 35 et ainsi de suite

Merci de votre aide
Daniel.C
Le #5290551
Euh, la formule est à mettre en ligne 1, et à recopier vers le bas.
Cela va sans dire ;-))
Daniel
"Daniel.C" %
=SI(NB.SI($A$1:A1;A1)>1;"";SOMME.SI($A$1:$A$8;A1;$B$1:$B$8))
Daniel

bonjour a tous et bonne année
je cherche un moyen d'inserer une formule, par exemple somme en
fonction d'un critere
un petit exemple

A B C(formule a inserer)
1 alex 10 10
2 robert 15 35
3 robert 20
4 bob 25 25
5 alain 30 105
6 alain 35
7 alain 40
8 nobert 45 45

dans mon exemple je voudrais qu'en C1 j'ai la somme pour alex soit 10
C2 et uniquement
en C2 j'ai la somme pour robert soit 35 et ainsi de suite

Merci de votre aide



JB
Le #5290541
Bonsoir,

=SI(A1<>A2;SOMME.SI($A$2:$A$100;A2;$B$2:$B$100);"")

http://cjoint.com/?bvtnLNgn2Q

JB

On 21 jan, 18:55, wrote:
bonjour a tous et bonne année
je cherche un moyen d'inserer une formule, par exemple somme en
fonction d'un critere
un petit exemple

    A         B         C(formule a inserer)
1  alex      10        10
2  robert    15        35
3  robert    20
4  bob       25        25
5  alain      30       105
6  alain      35
7  alain      40
8  nobert    45       45

dans mon exemple je voudrais qu'en C1 j'ai la somme pour alex soit 10
                                                     C2 et uniquement
en C2 j'ai la somme pour robert soit 35 et ainsi de suite

Merci de votre aide


Jacquouille
Le #5290531
Bonsoir

Cas d'école pour Sommeprod
=Sommeprod((a1:a50="alex")*b1:b50)

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.


bonjour a tous et bonne année
je cherche un moyen d'inserer une formule, par exemple somme en
fonction d'un critere
un petit exemple

A B C(formule a inserer)
1 alex 10 10
2 robert 15 35
3 robert 20
4 bob 25 25
5 alain 30 105
6 alain 35
7 alain 40
8 nobert 45 45

dans mon exemple je voudrais qu'en C1 j'ai la somme pour alex soit 10
C2 et uniquement
en C2 j'ai la somme pour robert soit 35 et ainsi de suite

Merci de votre aide
Modeste
Le #5290511
Bonsour® avec ferveur ;o))) vous nous disiez :

bonjour a tous et bonne année
je cherche un moyen d'inserer une formule, par exemple somme en
fonction d'un critere
un petit exemple

A B C(formule a inserer)
1 alex 10 10
2 robert 15 35
3 robert 20
4 bob 25 25
5 alain 30 105
6 alain 35
7 alain 40
8 nobert 45 45

dans mon exemple je voudrais qu'en C1 j'ai la somme pour alex soit 10
C2 et uniquement
en C2 j'ai la somme pour robert soit 35 et ainsi de suite


sous réserve que la colonne A soit triée
=== >>>ET !!!!!!!
que la premiere ligne ne contient pas de données :

en C2
=SI(A1¢;"";SOMMEPROD((A$2:A$22¢)*B$2:B$22))
puis recopier vers le bas autant que necessaire

inspirée de la réponse de Nicolas B.
20 Jan 2008 21:26:29 +0100

--
--
@+
;o)))

Publicité
Poster une réponse
Anonyme