Formule dynamique

Le
Mario Limoges
Bonjour-bonsoir
Excel 2003

Je cherche le moyen (sans VBA) de passer au une formule, qui receuille des
valeurs dans une plage nommée une valeur texte pour identifier cette plage.

Dand une feuille j'ai une liste (donnée/validation) une liste de mois au
changement de cette liste je créer une chaine de caractère en [R6]
identifiant la plage de donnée corespondant
'Stat_2008_1','Stat_2008_2' etc pour les 12 mois de l'année.

dans une cellule j'ai une formule qui ressemble a :
=SOMME((Stat_2008_1)*(App_2008¹)) (entre accolades par ctl Shift enter)

L'objectif visé est de pouvoir passer a cette formule la valeur texte
contenue en [R6]
afin que ma formule sois dynamique.

Espérant avoir été limpide dans mes explications

Merci à l'avance
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
LSteph
Le #5277941
Bonsoir,
(Validation normale)

=SOMMEPROD(INDIRECT(R6)*(App_2008=$B$9))

--
lSteph

Bonjour-bonsoir
Excel 2003

Je cherche le moyen (sans VBA) de passer au une formule, qui receuille des
valeurs dans une plage nommée une valeur texte pour identifier cette plage.

Dand une feuille j'ai une liste (donnée/validation) une liste de mois au
changement de cette liste je créer une chaine de caractère en [R6]
identifiant la plage de donnée corespondant
'Stat_2008_1','Stat_2008_2' etc pour les 12 mois de l'année.

dans une cellule j'ai une formule qui ressemble a :
=SOMME((Stat_2008_1)*(App_2008¹)) (entre accolades par ctl Shift enter)

L'objectif visé est de pouvoir passer a cette formule la valeur texte
contenue en [R6]
afin que ma formule sois dynamique.

Espérant avoir été limpide dans mes explications

Merci à l'avance




mario.limoges
Le #5277131
On Feb 12, 2:46 pm, LSteph
Bonsoir,
(Validation normale)

=SOMMEPROD(INDIRECT(R6)*(App_2008=$B$9))

--
lSteph




Bonjour-bonsoir
Excel 2003

Je cherche le moyen (sans VBA) de passer au uneformule, qui receuille de s
valeurs dans une plage nommée une valeur texte pour identifier cette p lage.

Dand une feuille j'ai une liste (donnée/validation) une liste de mois au
changement de cette liste je créer une chaine de caractère en [R6]
identifiant la plage de donnée corespondant
'Stat_2008_1','Stat_2008_2' etc pour les 12 mois de l'année.

dans une cellule j'ai uneformulequi ressemble a :
=SOMME((Stat_2008_1)*(App_2008¹)) (entre accolades par ctl Shift e nter)

L'objectif visé est de pouvoir passer a cetteformulela valeur texte
contenue en [R6]
afin que maformulesoisdynamique.

Espérant avoir été limpide dans mes explications

Merci à l'avance- Hide quoted text -


- Show quoted text -


Merci beaucoup, c est impec !


Publicité
Poster une réponse
Anonyme