FORMULE EXCELL (FONCTION RECHERCHE ET SI)

Le
Claude
Bonjour,

Voici mon problème:
Feuille 1

A B C D E
1 NO QTE MONTANT QTE MONTANT
2 REEL REEL ACHETÉ ACHETÉ
3 15-25-541 1 10.00 5 50.00
4 15-32-547
5 22587 0 0 0 0
6 3L4587
7 3-45-587
8 7978745
9 456456458




Feuille 2

A B C
1 NO QTE MONTANT
2 REEL REEL
3 15-25-541 1 10.00
4 15-32-547
5
6 3L4587
7 3-45-587
8 7978745
9 456456458









Je voudrais que dans feuille 1 B3
- Va voir dans feuille 2 si tu trouves a3 mets b3 sinon 0
- Si tu trouve pas le numéro mets 0


=SI(RECHERCHE(A3;Feuil2!A3:A9;Feuil2!B3:B9);0)

Merci de votre aide
Claude M
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #18687261
bonjour Claude,

=SI(ESTERREUR(RECHERCHE(A3;Feuil2!A3:A9;Feuil2!B3:B9));0;RECHERCHE(A3;Feuil2!A3:A9;Feuil2!B3:B9))

isabelle

Claude a écrit :
Bonjour,

Voici mon problème:
Feuille 1

A B C D E
1 NO QTE MONTANT QTE MONTANT
2 REEL REEL ACHETÉ ACHETÉ
3 15-25-541 1 10.00 5 50.00
4 15-32-547
5 22587 0 0 0 0
6 3L4587
7 3-45-587
8 7978745
9 456456458




Feuille 2

A B C
1 NO QTE MONTANT
2 REEL REEL
3 15-25-541 1 10.00
4 15-32-547
5
6 3L4587
7 3-45-587
8 7978745
9 456456458









Je voudrais que dans feuille 1 B3
- Va voir dans feuille 2 si tu trouves a3 mets b3 sinon 0
- Si tu trouve pas le numéro mets 0


=SI(RECHERCHE(A3;Feuil2!A3:A9;Feuil2!B3:B9);0)

Merci de votre aide
Claude M





Fredo P.
Le #18688561
Bonjour Isabelle
Est ce qu'il y a une raison qui oriente ton choix sur "RECHERCHE" plus que
"INDEX" Isabelle?
Pour moi, ce que j'ai retenu, à moins que cela ai changé, RECHERCHE oblige
un tri du tableau. Non?

"isabelle" a écrit dans le message de
news:%2314m%
bonjour Claude,




=SI(ESTERREUR(RECHERCHE(A3;Feuil2!A3:A9;Feuil2!B3:B9));0;RECHERCHE(A3;Feuil2
!A3:A9;Feuil2!B3:B9))

isabelle



SI(ESTERREUR(INDEX(Feuil2!A3:B9;EQUIV(A3;Feuil2!A3:A9;0);2));0;INDEX(Feuil2!
A3:B9;EQUIV(A3;Feuil2!A3:A9;0);2))
Claude a écrit :
> Bonjour,
>
> Voici mon problème:
> Feuille 1
>
> A B C D E
> 1 NO QTE MONTANT QTE MONTANT
> 2 REEL REEL ACHETÉ ACHETÉ
> 3 15-25-541 1 10.00 5 50.00
> 4 15-32-547
> 5 22587 0 0 0 0
> 6 3L4587
> 7 3-45-587
> 8 7978745
> 9 456456458
>
>
>
>
> Feuille 2
>
> A B C
> 1 NO QTE MONTANT
> 2 REEL REEL
> 3 15-25-541 1 10.00
> 4 15-32-547
> 5
> 6 3L4587
> 7 3-45-587
> 8 7978745
> 9 456456458
>
>
>
>
>
>
>
>
>
> Je voudrais que dans feuille 1 B3
> - Va voir dans feuille 2 si tu trouves a3 mets b3 sinon 0
> - Si tu trouve pas le numéro mets 0
>
>
> =SI(RECHERCHE(A3;Feuil2!A3:A9;Feuil2!B3:B9);0)
>
> Merci de votre aide
> Claude M
>
>
>


isabelle
Le #18690961
bonjour Fredo,

non, c'est seulement parce que le demandeur a mit cette fonction dans sa
demande ,
si non :

=SI(ESTERREUR(EQUIV(A3;Feuil2!A3:A9;0));0;INDEX(Feuil2!B3:B9;EQUIV(A3;Feuil2!A3:A9;0))

ferait l'affaire,

isabelle


Fredo P. a écrit :
Bonjour Isabelle
Est ce qu'il y a une raison qui oriente ton choix sur "RECHERCHE" plus que
"INDEX" Isabelle?
Pour moi, ce que j'ai retenu, à moins que cela ai changé, RECHERCHE oblige
un tri du tableau. Non?

"isabelle" a écrit dans le message de
news:%2314m%

bonjour Claude,





=SI(ESTERREUR(RECHERCHE(A3;Feuil2!A3:A9;Feuil2!B3:B9));0;RECHERCHE(A3;Feuil2
!A3:A9;Feuil2!B3:B9))

isabelle




> SI(ESTERREUR(INDEX(Feuil2!A3:B9;EQUIV(A3;Feuil2!A3:A9;0);2));0;INDEX(Feuil2!
A3:B9;EQUIV(A3;Feuil2!A3:A9;0);2))

Claude a écrit :

Bonjour,

Voici mon problème:
Feuille 1

A B C D E
1 NO QTE MONTANT QTE MONTANT
2 REEL REEL ACHETÉ ACHETÉ
3 15-25-541 1 10.00 5 50.00
4 15-32-547
5 22587 0 0 0 0
6 3L4587
7 3-45-587
8 7978745
9 456456458




Feuille 2

A B C
1 NO QTE MONTANT
2 REEL REEL
3 15-25-541 1 10.00
4 15-32-547
5
6 3L4587
7 3-45-587
8 7978745
9 456456458









Je voudrais que dans feuille 1 B3
- Va voir dans feuille 2 si tu trouves a3 mets b3 sinon 0
- Si tu trouve pas le numéro mets 0


=SI(RECHERCHE(A3;Feuil2!A3:A9;Feuil2!B3:B9);0)

Merci de votre aide
Claude M













Publicité
Poster une réponse
Anonyme