Formule matricielle

Le
jero
Bonjour à tous,
J'ai 3 colonnes : A contient un texte ("A","B",etc. par ex.) et B et C des
nombres ; x lignes
Je cherche à écrire une formule matricielle (une seule formule) qui me
ferait la somme des nombres en B et C si la colonne A contient "A" par ex.
J'ai essayé {=SOMME(SI(A1:A33="A";SOMME(B1:C1);0))} et autres mais le
résultat n'est pas bon
Ce que je ne trouve pas, c'est comment modifier SOMME(B1:C1) pour qu'Excel
"fasse la rotation" des lignes.
Merci d'avance si vous avez une idée.
jpg
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #20587371
bonjour jpg,

=SOMMEPROD((A1:A10="a")*((B1:B10)+(C1:C10)))

isabelle

jero a écrit :
Bonjour à tous,
J'ai 3 colonnes : A contient un texte ("A","B",etc. par ex.) et B et C des
nombres ; x lignes
Je cherche à écrire une formule matricielle (une seule formule) qui me
ferait la somme des nombres en B et C si la colonne A contient "A" par ex.
J'ai essayé {=SOMME(SI(A1:A33="A";SOMME(B1:C1);0))} et autres... mais le
résultat n'est pas bon...
Ce que je ne trouve pas, c'est comment modifier SOMME(B1:C1) pour qu'Excel
"fasse la rotation" des lignes.
Merci d'avance si vous avez une idée.
jpg






Daniel.C
Le #20587361
Bonjour.
=SOMMEPROD(($A$1:$A$33="A")*$B$1:$C$33)
Cordialement.
Daniel

Bonjour à tous,
J'ai 3 colonnes : A contient un texte ("A","B",etc. par ex.) et B et C des
nombres ; x lignes
Je cherche à écrire une formule matricielle (une seule formule) qui me
ferait la somme des nombres en B et C si la colonne A contient "A" par ex.
J'ai essayé {=SOMME(SI(A1:A33="A";SOMME(B1:C1);0))} et autres... mais le
résultat n'est pas bon...
Ce que je ne trouve pas, c'est comment modifier SOMME(B1:C1) pour qu'Excel
"fasse la rotation" des lignes.
Merci d'avance si vous avez une idée.
jpg


michdenis
Le #20587511
Bonjour Jéro,

Un exemple :

Validation matricielle : Maj + ctrl + Enter

=SOMME(SI(A1:A5="toto";B1:C5))



"jero"
Bonjour à tous,
J'ai 3 colonnes : A contient un texte ("A","B",etc. par ex.) et B et C des
nombres ; x lignes
Je cherche à écrire une formule matricielle (une seule formule) qui me
ferait la somme des nombres en B et C si la colonne A contient "A" par ex.
J'ai essayé {=SOMME(SI(A1:A33="A";SOMME(B1:C1);0))} et autres... mais le
résultat n'est pas bon...
Ce que je ne trouve pas, c'est comment modifier SOMME(B1:C1) pour qu'Excel
"fasse la rotation" des lignes.
Merci d'avance si vous avez une idée.
jpg
jero
Le #20589281
Merci à tous, ça roule...

"jero"
Bonjour à tous,
J'ai 3 colonnes : A contient un texte ("A","B",etc. par ex.) et B et C des
nombres ; x lignes
Je cherche à écrire une formule matricielle (une seule formule) qui me
ferait la somme des nombres en B et C si la colonne A contient "A" par ex.
J'ai essayé {=SOMME(SI(A1:A33="A";SOMME(B1:C1);0))} et autres... mais le
résultat n'est pas bon...
Ce que je ne trouve pas, c'est comment modifier SOMME(B1:C1) pour qu'Excel
"fasse la rotation" des lignes.
Merci d'avance si vous avez une idée.
jpg





Publicité
Poster une réponse
Anonyme