Formule matricielle

Le
jero
Bonjour à tous,
J'ai 3 colonnes : A contient un texte ("A","B",etc. par ex.) et B et C des
nombres ; x lignes
Je cherche à écrire une formule matricielle (une seule formule) qui me
ferait la somme des nombres en B et C si la colonne A contient "A" par ex.
J'ai essayé {=SOMME(SI(A1:A33="A";SOMME(B1:C1);0))} et autres mais le
résultat n'est pas bon
Ce que je ne trouve pas, c'est comment modifier SOMME(B1:C1) pour qu'Excel
"fasse la rotation" des lignes.
Merci d'avance si vous avez une idée.
jpg
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Bear76
Le #20593441
jero vient de nous annoncer :
Bonjour à tous,
J'ai 3 colonnes : A contient un texte ("A","B",etc. par ex.) et B et C des
nombres ; x lignes
Je cherche à écrire une formule matricielle (une seule formule) qui me ferait
la somme des nombres en B et C si la colonne A contient "A" par ex.
J'ai essayé {=SOMME(SI(A1:A33="A";SOMME(B1:C1);0))} et autres... mais le
résultat n'est pas bon...
Ce que je ne trouve pas, c'est comment modifier SOMME(B1:C1) pour qu'Excel
"fasse la rotation" des lignes.
Merci d'avance si vous avez une idée.
jpg



Salut Jero
Je pense que la formule suivante devrait le faire
{=SOMME(SI((A1:A33="A");(B1:B33)+(C1:C33);0))}
@+
Publicité
Poster une réponse
Anonyme