Formule matricielle sommeprod et indirect

Le
cousinhub
Bonsoir tout le monde,
j'aurais une petite question à vous poser :
Lorsque je tape ceci : =INDIRECT("A"&LIGNE()), j'ai le bon résultat.
Si je tape (en matriciel):
=SOMMEPROD((client=INDIRECT("A"&LIGNE()))*(nbre)), j'ai une valeur
d'erreur (#VALEUR)
Merci pour toutes vos lumières
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #4657041
Bonsoir cousinhub,

Petite précision, Sommeprod ne nécessite pas de validation matricielle
(validation normale par la touche entrée seule)
Sinon, que représentent "client" et "nbre" dans ta formule (des plages
nommées ?) ; que cherches tu à dénombrer exactement ?
Il est par ailleurs indispensable que les plages sur lesquelles la formule
s'applique soient de même dimension.
--
Avec plaisir
Philippe.R
"cousinhub" news:
Bonsoir tout le monde,
j'aurais une petite question à vous poser :
Lorsque je tape ceci : =INDIRECT("A"&LIGNE()), j'ai le bon résultat.
Si je tape (en matriciel):
=SOMMEPROD((client=INDIRECT("A"&LIGNE()))*(nbre)), j'ai une valeur
d'erreur (#VALEUR)
Merci pour toutes vos lumières


cousinhub
Le #4657021
Bonsoir, effectivement, client et nbre sont des plages nommées, et elles
ont la même dimension.
Je sais que :
=SOMMEPROD((client¢)*(nbr)) fonctionne, mais j'aurais voulu avoir le
même résultat avec ligne et indirect
Merci

Bonsoir cousinhub,

Petite précision, Sommeprod ne nécessite pas de validation matricielle
(validation normale par la touche entrée seule)
Sinon, que représentent "client" et "nbre" dans ta formule (des plages
nommées ?) ; que cherches tu à dénombrer exactement ?
Il est par ailleurs indispensable que les plages sur lesquelles la
formule s'applique soient de même dimension.


JB
Le #4805131
Bonsoir ,

INDIRECT("A"&LIGNE()) représente un champ. Je ne vois pas le rapport
avec A2 qui représente une cellule.

JB

On 14 août, 19:14, cousinhub
Bonsoir, effectivement, client et nbre sont des plages nommées, et elles
ont la même dimension.
Je sais que :
=SOMMEPROD((client¢)*(nbr)) fonctionne, mais j'aurais voulu avoir le
même résultat avec ligne et indirect
Merci




Bonsoir cousinhub,

Petite précision, Sommeprod ne nécessite pas de validation matricie lle
(validation normale par la touche entrée seule)
Sinon, que représentent "client" et "nbre" dans ta formule (des plages
nommées ?) ; que cherches tu à dénombrer exactement ?
Il est par ailleurs indispensable que les plages sur lesquelles la
formule s'applique soient de même dimension.- Masquer le texte des me ssages précédents -


- Afficher le texte des messages précédents -



cousinhub
Le #4805031
Bonsoir, et merci pour la réponse.
Désolé, je pensais que INDIRECT("A"&LIGNE(), pouvait être utilisé
également dans une fonction telle SOMMEPROD, vu que utilisée toute
seule, elle donnait le bon résultat, mais qu'insérée dans cette
fonction, ben, ça marche pas...
Merci encore, et bonne soirée
Bonsoir ,

INDIRECT("A"&LIGNE()) représente un champ. Je ne vois pas le rapport
avec A2 qui représente une cellule.

JB

On 14 août, 19:14, cousinhub
Bonsoir, effectivement, client et nbre sont des plages nommées, et elles
ont la même dimension.
Je sais que :
=SOMMEPROD((client¢)*(nbr)) fonctionne, mais j'aurais voulu avoir le
même résultat avec ligne et indirect
Merci




Bonsoir cousinhub,
Petite précision, Sommeprod ne nécessite pas de validation matricielle
(validation normale par la touche entrée seule)
Sinon, que représentent "client" et "nbre" dans ta formule (des plages
nommées ?) ; que cherches tu à dénombrer exactement ?
Il est par ailleurs indispensable que les plages sur lesquelles la
formule s'applique soient de même dimension.- Masquer le texte des messages précédents -
- Afficher le texte des messages précédents -








JB
Le #4804931
On peut utiliser indirect() dans sommeprod():

Par ex nombre de jours différents de mercredi et dimanche:
=SOMMEPROD(ESTNA(EQUIV(JOURSEM(LIGNE(INDIRECT(A1&":"&B1)));{1;4};
0))*1)

mais sur ton exemple, je ne vois pas comment remplacer A2.

http://cjoint.com/?ipbHPkojE4

JB

On 14 août, 21:26, cousinhub
Bonsoir, et merci pour la réponse.
Désolé, je pensais que INDIRECT("A"&LIGNE(), pouvait être utilisé
également dans une fonction telle SOMMEPROD, vu que utilisée toute
seule, elle donnait le bon résultat, mais qu'insérée dans cette
fonction, ben, ça marche pas...
Merci encore, et bonne soirée



Bonsoir ,

INDIRECT("A"&LIGNE()) représente un champ. Je ne vois pas le rapport
avec A2 qui représente une cellule.

JB

On 14 août, 19:14, cousinhub
Bonsoir, effectivement, client et nbre sont des plages nommées, et e lles
ont la même dimension.
Je sais que :
=SOMMEPROD((client¢)*(nbr)) fonctionne, mais j'aurais voulu avoi r le
même résultat avec ligne et indirect
Merci




Bonsoir cousinhub,
Petite précision, Sommeprod ne nécessite pas de validation matric ielle
(validation normale par la touche entrée seule)
Sinon, que représentent "client" et "nbre" dans ta formule (des pla ges
nommées ?) ; que cherches tu à dénombrer exactement ?
Il est par ailleurs indispensable que les plages sur lesquelles la
formule s'applique soient de même dimension.- Masquer le texte des messages précédents -
- Afficher le texte des messages précédents -- Masquer le texte de s messages précédents -




- Afficher le texte des messages précédents -





Publicité
Poster une réponse
Anonyme