Formule min/max sur date avec plages variables

Le
FREDSCOPE
Bonjour à tous,

J'ai un problème de mise en place d'une fonction min() sur des dates
sur des plages variables. J'ai essayé de mixer la fonction min avec la
fonction décaler, mais ne maitrisant pas cette dernière fonction, je
tourne en rond et je n'arrive pas à mes fins. Je pensais me servir du
nombre de contrats indiqué en colonne B pour faire le décalage de la
plage, mais sans succès.

Aussi, je me permet de venir vers vous pour que quelqu'un puisse me
conseiller sur la marche à suivre.

J'ai un certain nombre de contrats salariés avec des matricules en
colonne A, des n° de contrats allant de 1 à n pour chaque salarié et
en colonne D et E j'ai les dates de début et fin de contrat.Cf ci-
dessous

Je souhaiterai avoir en colonne F et G, sur la dernière ligne des
contrats de chaque salarié la date mini en F et la date maxi en G.

A B C D. E
F G

Mat N° période Nom Début Fin
Mini Maxi
14 1 DUPUIS 09/01/2010 10/01/2010
14 2 DUPUIS 12/01/2010 18/01/2010
14 3 DUPUIS 22/01/2010 22/01/2010
14 4 DUPUIS 24/01/2010 27/01/2010 09/01/2010 27/01/2010
18 1 LOUPION 09/01/2010 09/01/2010 09/01/2010 09/01/2010
22 1 ZIANI 12/01/2010 18/01/2010
22 2 ZIANI 22/01/2010 22/01/2010
22 3 ZIANI 24/01/2010 29/01/2010 12/01/2010 29/01/2010


Je souhaiterai mettre en place ce système sans code VB. Je
m'arrangerai après pour mettre une condition pour que la formule ne
soit que sur le dernier contrat.

Merci d'avance pour votre aide précieuse.

Fred
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ellimac
Le #21116991
Bonjour,

Avec un tableau de A1 à E9 :
En F :
=SI(C3Â;"";MIN(DECALER($D$2;EQUIV(C2;$C$2:$C$9;0)-1;0;NB.SI($C$2:$C$9;C2);1)))

En G :
=SI(C3Â;"";MAX(DECALER($E$2;EQUIV(C2;$C$2:$C$9;0)-1;0;NB.SI($C$2:$C$9;C2);1)))

Camille

"FREDSCOPE"
Bonjour à tous,

J'ai un problème de mise en place d'une fonction min() sur des dates
sur des plages variables. J'ai essayé de mixer la fonction min avec la
fonction décaler, mais ne maitrisant pas cette dernière fonction, je
tourne en rond et je n'arrive pas à mes fins. Je pensais me servir du
nombre de contrats indiqué en colonne B pour faire le décalage de la
plage, mais sans succès.

Aussi, je me permet de venir vers vous pour que quelqu'un puisse me
conseiller sur la marche à suivre.

J'ai un certain nombre de contrats salariés avec des matricules en
colonne A, des n° de contrats allant de 1 à n pour chaque salarié et
en colonne D et E j'ai les dates de début et fin de contrat.Cf ci-
dessous

Je souhaiterai avoir en colonne F et G, sur la dernière ligne des
contrats de chaque salarié la date mini en F et la date maxi en G.

A B C D. E
F G

Mat N° période Nom Début Fin
Mini Maxi
14 1 DUPUIS 09/01/2010 10/01/2010
14 2 DUPUIS 12/01/2010 18/01/2010
14 3 DUPUIS 22/01/2010 22/01/2010
14 4 DUPUIS 24/01/2010 27/01/2010 09/01/2010 27/01/2010
18 1 LOUPION 09/01/2010 09/01/2010 09/01/2010 09/01/2010
22 1 ZIANI 12/01/2010 18/01/2010
22 2 ZIANI 22/01/2010 22/01/2010
22 3 ZIANI 24/01/2010 29/01/2010 12/01/2010 29/01/2010


Je souhaiterai mettre en place ce système sans code VB. Je
m'arrangerai après pour mettre une condition pour que la formule ne
soit que sur le dernier contrat.

Merci d'avance pour votre aide précieuse.

Fred
Caetera
Le #21117081
>Je souhaiterai avoir en colonne F et G, sur la dernière ligne des
contrats de chaque salarié la date mini en F et la date maxi en G.



***************

Avec les données en A2:G9 (à adapter)
En F2 et recopie>> F9
Matricielle
=SI(C3<>C2;MIN(SI($C$2:C9Â;$D$2:D9));"")
En G2 et recopie>> G9
Matricielle
=SI(C3<>C2;MAX(SI($C$2:C9Â;$E$2:E9));"")

http://www.cijoint.fr/cjlink.php?file=cj201002/cijSpu6CcH.xls

Etc
FREDSCOPE
Le #21117071
Merci beaucoup pour votre réponse. C'est une toute autre approche que
celle que j'avais envisagé. Cette méthode utilise des fonctions plus
familières pour moi.

J'ai de mon coté réussit à faire quelque chose qui semble
fonctionner :

En cellule H4 =SI(B4<B5;"";MIN(DECALER(D4;;;-B4)))

Idem en I4 pour le MAX.

Merci encore.




On 3 fév, 09:57, "Caetera"
>Je souhaiterai avoir en colonne F et G, sur la dernière ligne des
>contrats de chaque salarié la date mini en F et la date maxi en G.

***************

Avec les données en A2:G9 (à adapter)
En F2 et recopie>> F9
Matricielle
=SI(C3<>C2;MIN(SI($C$2:C9Â;$D$2:D9));"")
En G2 et recopie>> G9
Matricielle
=SI(C3<>C2;MAX(SI($C$2:C9Â;$E$2:E9));"")

http://www.cijoint.fr/cjlink.php?file=cj201002/cijSpu6CcH.xls

Etc


Publicité
Poster une réponse
Anonyme