Formule pour reconnaissance de cellules

Le
mcconstruction
Je voudrait savoir si il existe une formule qui me semblerait assez complexe.
J'ai concu un fichier excel pour pouvoir calculer le nombre d'heures des
employés. Donc, chaque Feuille d'excel dans mon fichier correspond a 1
employé. Chaque feuille sont concu comme cela:

Feuille #1

Employé A

Lundi 123, Rue ZZZ 9 heures
Mardi 123, Rue YYY 10 heures


Feuille #2

Employé B

Lundi 123, Rue ZZZ 12 heures
Mardi 123, Rue YYY 8 heures



Je voudrait savoir si il est possible de faire une autre feuille dans
laquelle il y aurait une formule ( ou autre chose ) qui saurai reconnaitre le
nom des rues pour que les heures travaillée par peu importe quels employés
soient additionner.

Par exemple si j'entrerait la rue ZZZ ( ou un ongle créé ??? ) il
reconnaitrait automatiquement 9 heures travaillé par l'employé A et 12
heures travaillées par l'employé B donc il indiquerait 21 heures travaillées
pour la rue ZZZ.


Merci de votre coopération

l'équipe de MC Contructions Inc.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #4855941
Bonjour,

=SI(A2="";"";SOMMEPROD((A!$B$2:$B$10¢)*A!$C$2:$C$10)+SOMMEPROD((B!$B$2:$B$10¢)*B!$C$2:$C$10)+SOMMEPROD(('C'!$B$2:$B$10¢)*'C'!$C$2:$C$10))
Exemple simple ici
http://cjoint.com/?jCsExoHosP
Salutations
JJ


"mcconstruction" message de news:
Je voudrait savoir si il existe une formule qui me semblerait assez
complexe.
J'ai concu un fichier excel pour pouvoir calculer le nombre d'heures des
employés. Donc, chaque Feuille d'excel dans mon fichier correspond a 1
employé. Chaque feuille sont concu comme cela:

Feuille #1

Employé A

Lundi 123, Rue ZZZ 9 heures
Mardi 123, Rue YYY 10 heures


Feuille #2

Employé B

Lundi 123, Rue ZZZ 12 heures
Mardi 123, Rue YYY 8 heures



Je voudrait savoir si il est possible de faire une autre feuille dans
laquelle il y aurait une formule ( ou autre chose ) qui saurai reconnaitre
le
nom des rues pour que les heures travaillée par peu importe quels employés
soient additionner.

Par exemple... si j'entrerait la rue ZZZ ( ou un ongle créé ??? )... il
reconnaitrait automatiquement 9 heures travaillé par l'employé A et 12
heures travaillées par l'employé B donc il indiquerait 21 heures
travaillées
pour la rue ZZZ.


Merci de votre coopération

l'équipe de MC Contructions Inc.


JB
Le #4855641
Bonsoir,

En matriciel (+ souple s'il y a beaucoup de feuilles):

=SOMMEPROD(SOMME.SI(INDIRECT(NomsClasseurs&"!b1:b12");$A
$2;INDIRECT(NomsClasseurs&"!c1:c12")))
Valider avec Maj+Ctrl+Entrée

NomsClasseurs est un champ qui contient les noms des feuilles à sommer

http://cjoint.com/?jCv4HMBFJR

On peut obtenir le nom des onglets automatiquement avec une fonction
perso:

http://boisgontierjacques.free.fr/fichiers/Matriciel/Somme3DConditionnel5B. xls

JB
http://boisgontierjacques.free.fr

On 28 sep, 16:52, mcconstruction
Je voudrait savoir si il existe une formule qui me semblerait assez compl exe.
J'ai concu un fichier excel pour pouvoir calculer le nombre d'heures des
employés. Donc, chaque Feuille d'excel dans mon fichier correspond a 1
employé. Chaque feuille sont concu comme cela:

Feuille #1

Employé A

Lundi 123, Rue ZZZ 9 heures
Mardi 123, Rue YYY 10 heures

Feuille #2

Employé B

Lundi 123, Rue ZZZ 12 heures
Mardi 123, Rue YYY 8 heures

Je voudrait savoir si il est possible de faire une autre feuille dans
laquelle il y aurait une formule ( ou autre chose ) qui saurai reconnaitr e le
nom des rues pour que les heures travaillée par peu importe quels emplo yés
soient additionner.

Par exemple... si j'entrerait la rue ZZZ ( ou un ongle créé ??? )... il
reconnaitrait automatiquement 9 heures travaillé par l'employé A et 12
heures travaillées par l'employé B donc il indiquerait 21 heures trav aillées
pour la rue ZZZ.

Merci de votre coopération

l'équipe de MC Contructions Inc.


Publicité
Poster une réponse
Anonyme