Formule ne répond pas correctement

Le
pellet15
Bonjour à tous

La formuli suivante de vrais me donner un chiffre qui est extrais
d'une liste.
Mais elle ne me donne pas le bon nombre????

=SI(ESTERREUR(INDEX(Mat;EQUIV(GAUCHE($B34;24);Surtemp_E;
1)));"";INDEX(Mat;EQUIV(GAUCHE($B34;24);Surtemp_E;1)))

Voir La cellule B35 réponce C35

Pourquoi & quoi faire ???

Voire le fichier attacher
http://cjoint.com/?jctcFtFivJ

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #4757391
Bonsoir,


=SI(ESTERREUR(INDEX(Mat;EQUIV(GAUCHE($B35;24);Surtemp_E;
0)));"";INDEX(Mat;EQUIV(GAUCHE($B35;24);Surtemp_E;0)))

JB

On 2 sep, 19:13, pellet15
Bonjour à tous

La formuli suivante de vrais me donner un chiffre qui est extrais
d'une liste.
Mais elle ne me donne pas le bon nombre????

=SI(ESTERREUR(INDEX(Mat;EQUIV(GAUCHE($B34;24);Surtemp_E;
1)));"";INDEX(Mat;EQUIV(GAUCHE($B34;24);Surtemp_E;1)))

Voir La cellule B35 réponce C35

Pourquoi & quoi faire ???

Voire le fichier attacherhttp://cjoint.com/?jctcFtFivJ

Merci


Dav
Le #4757381
Bonsoir pellet15

J'ai regardé ton fichier.
J'ai tout trié dans l'ordre croissant des "Nom Prénom" ta feuille
"Empl_Liste" et tes formules en feuille "Surtemp" semblent fonctionner très
bien. En tout cas moi je n'y vois pas d'erreur.
Il me semble que pour utiliser les formules de recherche dans une liste, il
faut impérativement que cette liste soit triée en ordre croissant. c'est
peut-être la raison.

Dis nous si ça fonctionne comme ça !

Bonne après midi chez toi.

Dav

"pellet15" news:
Bonjour à tous

La formuli suivante de vrais me donner un chiffre qui est extrais
d'une liste.
Mais elle ne me donne pas le bon nombre????

=SI(ESTERREUR(INDEX(Mat;EQUIV(GAUCHE($B34;24);Surtemp_E;
1)));"";INDEX(Mat;EQUIV(GAUCHE($B34;24);Surtemp_E;1)))

Voir La cellule B35 réponce C35

Pourquoi & quoi faire ???

Voire le fichier attacher
http://cjoint.com/?jctcFtFivJ

Merci
Philippe.R
Le #4757371
Bonsoir,
Cette syntaxe devrait améliorer le résultat :

=SI(ESTERREUR(INDEX(Mat;EQUIV(GAUCHE($B34;NBCAR($B34));Surtemp_E;0)));"";INDEX(Mat;EQUIV(GAUCHE($B34;NBCAR($B34));Surtemp_E;0))
--
Avec plaisir
Philippe.R
"pellet15" news:
Bonjour à tous

La formuli suivante de vrais me donner un chiffre qui est extrais
d'une liste.
Mais elle ne me donne pas le bon nombre????

=SI(ESTERREUR(INDEX(Mat;EQUIV(GAUCHE($B34;24);Surtemp_E;
1)));"";INDEX(Mat;EQUIV(GAUCHE($B34;24);Surtemp_E;1)))

Voir La cellule B35 réponce C35

Pourquoi & quoi faire ???

Voire le fichier attacher
http://cjoint.com/?jctcFtFivJ

Merci
JB
Le #4757351
Bonsoir,

Il n'y a pas besoin de trier le fichier. Il suffit de remplacer 1 par
0 dans Equiv()

http://boisgontierjacques.free.fr/pages_site/equivindex.htm

JB



On 2 sep, 20:17, "Dav"
Bonsoir pellet15

J'ai regardé ton fichier.
J'ai tout trié dans l'ordre croissant des "Nom Prénom" ta feuille
"Empl_Liste" et tes formules en feuille "Surtemp" semblent fonctionner tr ès
bien. En tout cas moi je n'y vois pas d'erreur.
Il me semble que pour utiliser les formules de recherche dans une liste, il
faut impérativement que cette liste soit triée en ordre croissant. c' est
peut-être la raison.

Dis nous si ça fonctionne comme ça !

Bonne après midi chez toi.

Dav

"pellet15" Bonjour à tous

La formuli suivante de vrais me donner un chiffre qui est extrais
d'une liste.
Mais elle ne me donne pas le bon nombre????

=SI(ESTERREUR(INDEX(Mat;EQUIV(GAUCHE($B34;24);Surtemp_E;
1)));"";INDEX(Mat;EQUIV(GAUCHE($B34;24);Surtemp_E;1)))

Voir La cellule B35 réponce C35

Pourquoi & quoi faire ???

Voire le fichier attacherhttp://cjoint.com/?jctcFtFivJ

Merci


Modeste
Le #4757341
Bonsour® pellet15 avec ferveur ;o))) vous nous disiez :

La formuli suivante de vrais me donner un chiffre qui est extrais
d'une liste.
Mais elle ne me donne pas le bon nombre????

=SI(ESTERREUR(INDEX(Mat;EQUIV(GAUCHE($B34;24);Surtemp_E;
1)));"";INDEX(Mat;EQUIV(GAUCHE($B34;24);Surtemp_E;1)))

Voir La cellule B35 réponce C35

Pourquoi & quoi faire ???


--Pourquoi :
parceque EQUIV trouve la première valeur la plus élevée qui est inférieure ou
égale à celle de l'argument valeur_cherchée.
et que la plage Surtemp devrait etre triée en ordre croissant

--Quoi faire :
l'utilisation de la fonction EQUIV comporte un 3eme argument qu'il est important
de préciser :
- Si l'argument type est omis, la valeur par défaut est 1.
- Si la valeur de l'argument type est 0, la fonction EQUIV trouve la première
valeur exactement équivalente à celle de l'argument valeur_cherchée. Les valeurs
de l'argument matrice_recherche peuvent être placées dans un ordre quelconque.
- Si la valeur de l'argument type est 1, la fonction Les valeurs de l'argument
matrice_recherche doivent être placées en ordre croissant : ...-2, -1, 0, 1, 2,
..., A-Z, FAUX, VRAI.
- Si la valeur de l'argument type est -1, la fonction EQUIV trouve la plus
petite valeur qui est supérieure ou égale à celle de l'argument valeur_cherchée.
Les valeurs de l'argument matrice_recherche doivent être placées en ordre
décroissant : VRAI, FAUX, Z-A, ..., 2, 1, 0, -1, -2, ..., et ainsi de suite.


@+
;o)))

Philippe.R
Le #4757331
Re,
En fait, pourquoi gauche(...;24) ?
on gagnerait avec :

=SI(ESTERREUR(INDEX(Mat;EQUIV($B35;Surtemp_E;0)));"";INDEX(Mat;EQUIV($B35;Surtemp_E;0)))

sinon, si une limitation à 24 caractères est obligatoire :

=SI(ESTERREUR(INDEX(Mat;EQUIV(GAUCHE($B34;MAX(24;NBCAR($B34)));Surtemp_E;0)));"";INDEX(Mat;EQUIV(GAUCHE($B34;MAX(24;NBCAR($B34)));Surtemp_E;0)))

pour la ligne 34
--
Avec plaisir
Philippe.R
"pellet15" news:
Bonjour à tous

La formuli suivante de vrais me donner un chiffre qui est extrais
d'une liste.
Mais elle ne me donne pas le bon nombre????

=SI(ESTERREUR(INDEX(Mat;EQUIV(GAUCHE($B34;24);Surtemp_E;
1)));"";INDEX(Mat;EQUIV(GAUCHE($B34;24);Surtemp_E;1)))

Voir La cellule B35 réponce C35

Pourquoi & quoi faire ???

Voire le fichier attacher
http://cjoint.com/?jctcFtFivJ

Merci
Modeste
Le #4757311
Bonsour® JB avec ferveur ;o))) vous nous disiez :

Il n'y a pas besoin de trier le fichier. Il suffit de remplacer 1 par
0 dans Equiv()


;o)))
cela dépend si l'on veut une valeur exacte ou approchante (afin d'éviter les
#NA)


@+
;o)))

pellet15
Le #4757271
On 2 sep, 14:32, "Modeste"
Bonsour® JB avec ferveur ;o))) vous nous disiez :

Il n'y a pas besoin de trier le fichier. Il suffit de remplacer 1 par
0 dans Equiv()


;o)))
cela dépend si l'on veut une valeur exacte ou approchante (afin d'évi ter les
#NA)

@+
;o)))


La je voie la valeur 0 est mieux car je me sert d'un dérouler
validation.(donc exactement la même recherche).

Merci beaucoup
(encore un peut plus dans ma mémoire)


JB
Le #4757191
Bonsoir,

Lorsqu'il s'agit d'un libellé, une valeur inférieure ou supérieure ne
présente pas d'intérêt.

JB
On 2 sep, 20:32, "Modeste"
Bonsour® JB avec ferveur ;o))) vous nous disiez :

Il n'y a pas besoin de trier le fichier. Il suffit de remplacer 1 par
0 dans Equiv()


;o)))
cela dépend si l'on veut une valeur exacte ou approchante (afin d'évi ter les
#NA)

@+
;o)))



Modeste
Le #4757091
Bonsour® JB avec ferveur ;o))) vous nous disiez :

Bonsoir,

Lorsqu'il s'agit d'un libellé, une valeur inférieure ou supérieure ne
présente pas d'intérêt.


;o)))
quoique ....
Libellés genre :
Reférence de pièce alpha numérique(avec gestion de modif ou version)
recherche dicotomique
Notation scolaire sous forme Alpha (A B C D E F)
Liste Nom,Prénom (Surtemp dans l'exemple de Pellet15 si les tours de garde se
font par ordre alphabétique)

@+
;o)))

Publicité
Poster une réponse
Anonyme