Formule sommeprod

Le
syleg35
Bonjour à tous;
j'ai une formule qu'on ma gentiment transmis et dans celle-ci il y a
(Semaine_35! c'est le nom de ma feuille, qu'es ce qui faudrait changer
pour que le nom de ma feuille soit mis automatiquement dans cette
formule, sachant que le nom de la feuille se trouve en cellule (B2),
d'ailleur c'est la cellule (B2) qui nomme ma feuille.
Dans ce classeur j'ai une macro pour faire des ajouts de feuille et je
suis obligé de revenir sur chaque formule pour changer le N° de
semaine.

=SOMMEPROD((Modul!$A$2:$A$40=Semaine_35!B4)*(Modul!$B$1:$L
$1=Semaine_35!$R$1)*Modul!$B$2:$L$40)

Merci à vous
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichDenis
Le #6944451
Tu remplaces par exemple : Semaine_35!B4
Par : INDIRECT("B2")&"!B4"

et : Semaine_35!$R$1 par INDIRECT("B2")&"!$R$1"

Est-ce que ta formule fonctionne ? Avant et après les changements ?



Bonjour à tous;
j'ai une formule qu'on ma gentiment transmis et dans celle-ci il y a
(Semaine_35! c'est le nom de ma feuille, qu'es ce qui faudrait changer
pour que le nom de ma feuille soit mis automatiquement dans cette
formule, sachant que le nom de la feuille se trouve en cellule (B2),
d'ailleur c'est la cellule (B2) qui nomme ma feuille.
Dans ce classeur j'ai une macro pour faire des ajouts de feuille et je
suis obligé de revenir sur chaque formule pour changer le N° de
semaine.

=SOMMEPROD((Modul!$A$2:$A$40=Semaine_35!B4)*(Modul!$B$1:$L
$1=Semaine_35!$R$1)*Modul!$B$2:$L$40)

Merci à vous
syleg35
Le #6947531
Bonjour "MichDenis"
merci pour ta réponse mais je n'arrive pas à la faire fonctionner
alors ci-joint fichier exemple
merci beaucoup et bonne soiré

http://cjoint.com/?gmaScBEfdG




On 12 juin, 00:00, "MichDenis"
Tu remplaces par exemple : Semaine_35!B4
Par :  INDIRECT("B2")&"!B4"

et : Semaine_35!$R$1 par  INDIRECT("B2")&"!$R$1"

Est-ce que ta formule fonctionne ? Avant et après les changements ?


Bonjour à tous;
j'ai une formule qu'on ma gentiment transmis et dans celle-ci il y a
(Semaine_35! c'est le nom de ma feuille, qu'es ce qui faudrait changer
pour que le nom de ma feuille soit mis automatiquement dans cette
formule, sachant que le nom de la feuille se trouve en cellule (B2),
d'ailleur c'est la cellule (B2) qui nomme ma feuille.
Dans ce classeur j'ai une macro pour faire des ajouts de feuille et je
suis obligé de revenir sur chaque formule pour changer le N° de
semaine.

=SOMMEPROD((Modul!$A$2:$A$40=Semaine_35!B4)*(Modul!$B$1:$L
$1=Semaine_35!$R$1)*Modul!$B$2:$L$40)

Merci à vous


MichDenis
Le #6947521
La première formule en B3

=SOMMEPROD((Valeur!$A$2:$A$10=INDIRECT($B$1&"!A3"))*(Valeur!$B$1:$G$1=INDIRECT($B$1&"!$C$1"))*(Valeur!$B$2:$G$10))





Bonjour "MichDenis"
merci pour ta réponse mais je n'arrive pas à la faire fonctionner
alors ci-joint fichier exemple
merci beaucoup et bonne soiré

http://cjoint.com/?gmaScBEfdG




On 12 juin, 00:00, "MichDenis"
Tu remplaces par exemple : Semaine_35!B4
Par : INDIRECT("B2")&"!B4"

et : Semaine_35!$R$1 par INDIRECT("B2")&"!$R$1"

Est-ce que ta formule fonctionne ? Avant et après les changements ?


Bonjour à tous;
j'ai une formule qu'on ma gentiment transmis et dans celle-ci il y a
(Semaine_35! c'est le nom de ma feuille, qu'es ce qui faudrait changer
pour que le nom de ma feuille soit mis automatiquement dans cette
formule, sachant que le nom de la feuille se trouve en cellule (B2),
d'ailleur c'est la cellule (B2) qui nomme ma feuille.
Dans ce classeur j'ai une macro pour faire des ajouts de feuille et je
suis obligé de revenir sur chaque formule pour changer le N° de
semaine.

=SOMMEPROD((Modul!$A$2:$A$40=Semaine_35!B4)*(Modul!$B$1:$L
$1=Semaine_35!$R$1)*Modul!$B$2:$L$40)

Merci à vous


syleg35
Le #6978371
Bonjour "MicDenis"
c'est ok sa fonctionne, merci pour ton aide

Bonne journée ! @+


On 12 juin, 01:16, "MichDenis"
La première formule en B3

=SOMMEPROD((Valeur!$A$2:$A$10=INDIRECT($B$1&"!A3"))*(Valeur!$B$1:$G$1 =INDIR­ECT($B$1&"!$C$1"))*(Valeur!$B$2:$G$10))


Bonjour "MichDenis"
merci pour ta réponse mais je n'arrive pas à la faire fonctionner
alors ci-joint fichier exemple
merci beaucoup et bonne soiré

http://cjoint.com/?gmaScBEfdG

On 12 juin, 00:00, "MichDenis"


Tu remplaces par exemple : Semaine_35!B4
Par : INDIRECT("B2")&"!B4"

et : Semaine_35!$R$1 par INDIRECT("B2")&"!$R$1"

Est-ce que ta formule fonctionne ? Avant et après les changements ?


Bonjour à tous;
j'ai une formule qu'on ma gentiment transmis et dans celle-ci il y a
(Semaine_35! c'est le nom de ma feuille, qu'es ce qui faudrait changer
pour que le nom de ma feuille soit mis automatiquement dans cette
formule, sachant que le nom de la feuille se trouve en cellule (B2),
d'ailleur c'est la cellule (B2) qui nomme ma feuille.
Dans ce classeur j'ai une macro pour faire des ajouts de feuille et je
suis obligé de revenir sur chaque formule pour changer le N° de
semaine.

=SOMMEPROD((Modul!$A$2:$A$40=Semaine_35!B4)*(Modul!$B$1:$L
$1=Semaine_35!$R$1)*Modul!$B$2:$L$40)

Merci à vous- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



Jacky
Le #6978341
Bonjour,
c'est ok sa fonctionne...
Evidemment une formule.... entre ces doigts.

;o))
Bon je sors...
--
Salutations
JJ



Bonjour "MicDenis"
c'est ok sa fonctionne, merci pour ton aide

Bonne journée ! @+


On 12 juin, 01:16, "MichDenis"
La première formule en B3

=SOMMEPROD((Valeur!$A$2:$A$10=INDIRECT($B$1&"!A3"))*(Valeur!$B$1:$G$1=INDIR­ECT($B$1&"!$C$1"))*(Valeur!$B$2:$G$10))


Bonjour "MichDenis"
merci pour ta réponse mais je n'arrive pas à la faire fonctionner
alors ci-joint fichier exemple
merci beaucoup et bonne soiré

http://cjoint.com/?gmaScBEfdG

On 12 juin, 00:00, "MichDenis"


Tu remplaces par exemple : Semaine_35!B4
Par : INDIRECT("B2")&"!B4"

et : Semaine_35!$R$1 par INDIRECT("B2")&"!$R$1"

Est-ce que ta formule fonctionne ? Avant et après les changements ?


Bonjour à tous;
j'ai une formule qu'on ma gentiment transmis et dans celle-ci il y a
(Semaine_35! c'est le nom de ma feuille, qu'es ce qui faudrait changer
pour que le nom de ma feuille soit mis automatiquement dans cette
formule, sachant que le nom de la feuille se trouve en cellule (B2),
d'ailleur c'est la cellule (B2) qui nomme ma feuille.
Dans ce classeur j'ai une macro pour faire des ajouts de feuille et je
suis obligé de revenir sur chaque formule pour changer le N° de
semaine.

=SOMMEPROD((Modul!$A$2:$A$40=Semaine_35!B4)*(Modul!$B$1:$L
$1=Semaine_35!$R$1)*Modul!$B$2:$L$40)

Merci à vous- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



Publicité
Poster une réponse
Anonyme