Formule très simple

Le
Laurent
Hello,

je cherche à compter le nombre de caractère étoiles (*) dans un tableau
Ca parait simple mais si je fais: =COUNTIF(B1:B8;"=*") (c'est un nombresi
en francais je crois), ca me retourne le nombre total de cellule, le * étant
compris comme une wild card

Une idée ?

Merci d'avance

Laurent
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pascal
Le #4321721
Bonjour,
De A1 à A10 tes * en B10 par exemple
=NB.SI(A1:A9;"*")

pascal
"Laurent"
Hello,

je cherche à compter le nombre de caractère étoiles (*) dans un tableau...
Ca parait simple mais si je fais: =COUNTIF(B1:B8;"=*") (c'est un nombresi
en francais je crois), ca me retourne le nombre total de cellule, le *
étant compris comme une wild card...

Une idée ?

Merci d'avance

Laurent


---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000726-0, 20/03/2007
Analyse le : 21/03/2007 10:14:42
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000726-0, 20/03/2007
Analyse le : 21/03/2007 10:18:01
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com

Pascal
Le #4321691
En VBA à adapter
Sub comptage()
'AV, mpfe
For Each cel In Range("A1:a9") 'tu adaptes
For i = 1 To Len(cel)
If Mid(cel, i, 1) = "*" Then cpt = cpt + 1
Next
Next
MsgBox cpt
End Sub
"Laurent"
Hello,

je cherche à compter le nombre de caractère étoiles (*) dans un tableau...
Ca parait simple mais si je fais: =COUNTIF(B1:B8;"=*") (c'est un nombresi
en francais je crois), ca me retourne le nombre total de cellule, le *
étant compris comme une wild card...

Une idée ?

Merci d'avance

Laurent


---
Antivirus avast! : message Entrant sain.
Base de donnees virale (VPS) : 000726-0, 20/03/2007
Analyse le : 21/03/2007 10:14:42
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com








---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000726-0, 20/03/2007
Analyse le : 21/03/2007 10:33:04
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com

JB
Le #4321681
Bonjour,

=NB.SI(B1:B8;"~*")

JB

On 21 mar, 09:38, "Laurent"
Hello,

je cherche à compter le nombre de caractère étoiles (*) dans un tab leau...
Ca parait simple mais si je fais: =COUNTIF(B1:B8;"=*") (c'est un nom bresi
en francais je crois), ca me retourne le nombre total de cellule, le * étant
compris comme une wild card...

Une idée ?

Merci d'avance

Laurent


Robi
Le #4321211
Bonjour JB
Pourrais-tu me dire à quoi sert le tilde qui apparaît juste avant l'étoile
ci-bas? Merci
robi, du Québec


Bonjour,

=NB.SI(B1:B8;"~*")

JB

On 21 mar, 09:38, "Laurent"
Hello,

je cherche à compter le nombre de caractère étoiles (*) dans un tableau...
Ca parait simple mais si je fais: =COUNTIF(B1:B8;"=*") (c'est un nombresi
en francais je crois), ca me retourne le nombre total de cellule, le * étant
compris comme une wild card...

Une idée ?

Merci d'avance

Laurent







JB
Le #4321141
Bonjour,

-Le caractère * est un joker . Nb.Si(A1:A100;"B*") donne le nombre de
cellules qui commencent par B.

-Le caractère ~ indique que le caractère qui suit - * - est un
caractère spécial.
Sans ~, * Nb.Si() serait équivalent de Nbval.

JB
On 21 mar, 16:48, Robi
Bonjour JB
Pourrais-tu me dire à quoi sert le tilde qui apparaît juste avant l' étoile
ci-bas? Merci
robi, du Québec




Bonjour,

=NB.SI(B1:B8;"~*")

JB

On 21 mar, 09:38, "Laurent"
Hello,

je cherche à compter le nombre de caractère étoiles (*) dans un tableau...
Ca parait simple mais si je fais: =COUNTIF(B1:B8;"=*") (c'est un nombresi
en francais je crois), ca me retourne le nombre total de cellule, le * étant
compris comme une wild card...

Une idée ?

Merci d'avance

Laurent- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -




Publicité
Poster une réponse
Anonyme