Quelle formule utiliser ?

Le
A COSTA
Bonjour,

Dans le cas suivant, si la période de permanence entre, même partiellement,
dans la plage horaire de 13:00 à 14:00, le résultat doit être 1, sinon zéro

Permanence Resultat
de à
9:00 12:45 0
10:00 13:30 1 (partiel)
11:00 15:00 1 (total)
13:15 13:30 1 (partiel)
13:15 20:00 1 (partiel)
12:00 14:30 1 (total)
14:01 17:00 0

Les données de "permanence de" sont à la colonne A, "permanence à" dans la B
et résultat dans la colonne C.
Quelle formule utiliser ?
Merci d'avance pour votre aide.
A. Costa
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
garnote
Le #4745781
Salut,

Peut-être ceci :

=SI(OU(ET(A1>/24;A1</24);ET(B1>/24;B1</24));1;0)

Serge


"A COSTA"
Bonjour,

Dans le cas suivant, si la période de permanence entre, même partiellement,
dans la plage horaire de 13:00 à 14:00, le résultat doit être 1, sinon zéro

Permanence Resultat
de à
9:00 12:45 0
10:00 13:30 1 (partiel)
11:00 15:00 1 (total)
13:15 13:30 1 (partiel)
13:15 20:00 1 (partiel)
12:00 14:30 1 (total)
14:01 17:00 0

Les données de "permanence de" sont à la colonne A, "permanence à" dans la B
et résultat dans la colonne C.
Quelle formule utiliser ?
Merci d'avance pour votre aide.
A. Costa



garnote
Le #4745771
Oups !

Plutôt ceci :

=SI(OU(ET(A1<13/24;B1</24);ET(A1>14/24;B1>14/24));0;1)

Serge





"garnote"
Salut,

Peut-être ceci :

=SI(OU(ET(A1>/24;A1</24);ET(B1>/24;B1</24));1;0)

Serge


"A COSTA"
Bonjour,

Dans le cas suivant, si la période de permanence entre, même partiellement,
dans la plage horaire de 13:00 à 14:00, le résultat doit être 1, sinon zéro

Permanence Resultat
de à
9:00 12:45 0
10:00 13:30 1 (partiel)
11:00 15:00 1 (total)
13:15 13:30 1 (partiel)
13:15 20:00 1 (partiel)
12:00 14:30 1 (total)
14:01 17:00 0

Les données de "permanence de" sont à la colonne A, "permanence à" dans la B
et résultat dans la colonne C.
Quelle formule utiliser ?
Merci d'avance pour votre aide.
A. Costa







A COSTA
Le #4745761
Merci
Il me manquait le 13/24 et 14/24.
Bonne fin de journée.
A. Costa


Oups !

Plutôt ceci :

=SI(OU(ET(A1<13/24;B1</24);ET(A1>14/24;B1>14/24));0;1)

Serge





"garnote"
Salut,

Peut-être ceci :

=SI(OU(ET(A1>/24;A1</24);ET(B1>/24;B1</24));1;0)

Serge


"A COSTA"
Bonjour,

Dans le cas suivant, si la période de permanence entre, même partiellement,
dans la plage horaire de 13:00 à 14:00, le résultat doit être 1, sinon zéro

Permanence Resultat
de à
9:00 12:45 0
10:00 13:30 1 (partiel)
11:00 15:00 1 (total)
13:15 13:30 1 (partiel)
13:15 20:00 1 (partiel)
12:00 14:30 1 (total)
14:01 17:00 0

Les données de "permanence de" sont à la colonne A, "permanence à" dans la B
et résultat dans la colonne C.
Quelle formule utiliser ?
Merci d'avance pour votre aide.
A. Costa












Publicité
Poster une réponse
Anonyme