Formule en vrac lors d'un tri

Le
Fred
Bonjour,

Sur un tableau, je fais la formule suivante :

=SOMMEPROD(('Archives BAF-CAF'!$A$9:$A$200='Asie-MED'!$D9)*('Archives
BAF-CAF'!$B$9:$B$200ÚTE(ANNEE(AUJOURDHUI());MOIS(AUJOURDHUI());1))*('Archives
BAF-CAF'!$G$9:$G$200))

Hors, lorsque je fais un tri dans mon tableau, le premier argument :
Archives BAF-CAF'!$A$9:$A$200='Asie-MED'!$D9
qui compare le nom d'une compagnie dans la feuille "Archives" avec la
cellule (D9) de la feuille dans laquelle on se trouve va chercher cette info
un peu n'importe où (D50, D158.).
Il me semble que ce qui met cette valeur en vrac, c'est le filtre et le fait
qu'il cache certaines cellulesMais je n'arrive pas à savoir pourquoi ni à
sollutionner

Lorsque l'on annule le filtre, tout redevient normal

Merci pour votre aide,

FRED.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Fred
Le #18035131
Je me réponds:

A priori, cela venait du fait que la recherche se faisait sur :
Asie-MED'!$D9. Si l'on met D9, cela fonctionne.

FRED.



"Fred" news:
Bonjour,

Sur un tableau, je fais la formule suivante :

=SOMMEPROD(('Archives BAF-CAF'!$A$9:$A$200='Asie-MED'!$D9)*('Archives
BAF-CAF'!$B$9:$B$200ÚTE(ANNEE(AUJOURDHUI());MOIS(AUJOURDHUI());1))*('Archives
BAF-CAF'!$G$9:$G$200))

Hors, lorsque je fais un tri dans mon tableau, le premier argument :
Archives BAF-CAF'!$A$9:$A$200='Asie-MED'!$D9
qui compare le nom d'une compagnie dans la feuille "Archives" avec la
cellule (D9) de la feuille dans laquelle on se trouve va chercher cette
info un peu n'importe où (D50, D158....).
Il me semble que ce qui met cette valeur en vrac, c'est le filtre et le
fait qu'il cache certaines cellules...Mais je n'arrive pas à savoir
pourquoi ni à sollutionner...

Lorsque l'on annule le filtre, tout redevient normal...

Merci pour votre aide,

FRED.




Publicité
Poster une réponse
Anonyme