[freebsd 7] grosse betise lors d'un update

Le
neuneu
Bonsoir..

J'ai une machine en freebsd 7.0, que je viens d'upgrader
en 7.1. Enfin presque. Car après reboot, le bootloader
refuse de trouver un kernel. C'est la première fois que
ça m'arrive. Est-ce que quelqu'un a déjà vu ça ? (*)

auparavant le système était un 7.0 prerelease le nouveau est
un 7.1 pris sur la RELENG_7. La machine (et le système
recompilé sont en amd64 et le système comporte une partition
en zfs (mais pas le root: uniquement le /usr)).

je pense avoir fait une betise lors de l'update, mais comme
je le fais toujours pareil, je doute un peu des idées ?

ZZ.

(*) je ne sais pas si c'est bien le bootloader qui doit trouver
un noyeau: je n'ai jamais été très fort sur cette étape
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Thierry Herbelot
Le #18125941
neuneu wrote:



Bonsoir..

J'ai une machine en freebsd 7.0, que je viens d'upgrader
en 7.1. Enfin presque. Car après reboot, le bootloader
refuse de trouver un kernel. C'est la première fois que
ça m'arrive. Est-ce que quelqu'un a déjà vu ça ? (*)



Bonjour,

Si tu vois le menu du loader (menu mode texte, avec le démon en graphique
ASCII), tu as le choix (6?) qui permet de retomber au prompt du loader : il
y a des commmandes basiques pour lister le contenu du disque et donc
charger un kernel qui n'a pas le nom conventionnel (important pour revenir
à kernel.old)

par ailleurs, comment l'upgrade a-t-il été fait ? théoriquement on reboot
sur le nouveau kernel avant d'installer le nouveau userland)

TfH

auparavant le système était un 7.0 prerelease le nouveau est
un 7.1 pris sur la RELENG_7. La machine (et le système
recompilé sont en amd64 et le système comporte une partition
en zfs (mais pas le root: uniquement le /usr)).

je pense avoir fait une betise lors de l'update, mais comme
je le fais toujours pareil, je doute un peu... des idées ?

ZZ.

(*) je ne sais pas si c'est bien le bootloader qui doit trouver
un noyeau: je n'ai jamais été très fort sur cette étape...


neuneu
Le #18132641
Thierry Herbelot wrote:

Si tu vois le menu du loader (menu mode texte, avec le démon en graphique
ASCII), tu as le choix (6?) qui permet de retomber au prompt du loader : il
y a des commmandes basiques pour lister le contenu du disque et donc
charger un kernel qui n'a pas le nom conventionnel (important pour revenir
à kernel.old)



c'est gentil, mais je connais ça par coeur ;-)

par contre, ça:
----------------------------------
BTX loader 1.00 BTX version is 1.02
Console: internal video/keyboard
BIOS drive C: is disk0
BIOS drive D: is disk1
BIOS 639kB/2095808kB available memory

FreeBSD/i386 bootstrap loader, Version 1.1
...
Can't work out which disk we are booting from.
Guessed BIOS device 0xffffffff not found by probes, defaulting to disk0:

can't load 'kernel'
------------------------------------
première fois que je vois ça...

- un autre disque en 7.1 (32 bits) fait un panic peu après cette phase
- un cdrom de 7.1 beta2 fraichement gravé plante sur un driver
qui n'a rien a voir (chip attansic merdique de la carte mère).

Par contre, je peux monter ce disque sans problème dans une autre machine
mais je ne sais pas si boot0cfg est la bonne solution... la machine que
j'utilise pour la réparation utilise un kernel 32 bits, le disque cible
fait tourner un système 64bits.

Des avis, expériences, contres indications ?
(j'aime pas bidouiller la mbr d'un disque vital....)

ZZ.
Thierry Herbelot
Le #18133701
neuneu wrote:

Thierry Herbelot wrote:

Si tu vois le menu du loader (menu mode texte, avec le démon en graphique
ASCII), tu as le choix (6?) qui permet de retomber au prompt du loader :
il y a des commmandes basiques pour lister le contenu du disque et donc
charger un kernel qui n'a pas le nom conventionnel (important pour
revenir à kernel.old)



c'est gentil, mais je connais ça par coeur ;-)

par contre, ça:
----------------------------------
BTX loader 1.00 BTX version is 1.02
Console: internal video/keyboard
BIOS drive C: is disk0
BIOS drive D: is disk1
BIOS 639kB/2095808kB available memory

FreeBSD/i386 bootstrap loader, Version 1.1
...
Can't work out which disk we are booting from.
Guessed BIOS device 0xffffffff not found by probes, defaulting to disk0:



pas good !!!! ça ressemble à un problème que j'avais vu en démarrant un
FreeBSD en PXE (boot réseau), et le loader a des problèmes d'allocation
mémoire.

puisque tu peux monter le disque sur une autre machine, essaie d'échanger le
loader (binaire /boot/loader) de 7.1 avec un loader plus ancien (celui de
la 7.0, si celui-là marchait mieux)

sinon, il est aussi possible de changer de loader dans le prompt du boot en
tapant quelque chose comme "0:ad(0,a)/boot/loader.old"

bon courage

TfH

can't load 'kernel'
------------------------------------
première fois que je vois ça...

- un autre disque en 7.1 (32 bits) fait un panic peu après cette phase
- un cdrom de 7.1 beta2 fraichement gravé plante sur un driver
qui n'a rien a voir (chip attansic merdique de la carte mère).

Par contre, je peux monter ce disque sans problème dans une autre machine
mais je ne sais pas si boot0cfg est la bonne solution... la machine que
j'utilise pour la réparation utilise un kernel 32 bits, le disque cible
fait tourner un système 64bits.

Des avis, expériences, contres indications ?
(j'aime pas bidouiller la mbr d'un disque vital....)

ZZ.


neuneu
Le #18167271
Thierry Herbelot wrote:

sinon, il est aussi possible de changer de loader dans le prompt du boot en
tapant quelque chose comme "0:ad(0,a)/boot/loader.old"



un grand merci: c'est la commande qui m'a sauvé.

En montant une autre une machine hier soir, j'ai refais
la même manip (passage d'une 7.0 à une 7.1), et suis retombé
sur le même soucis : le seul point commun est mon make.conf:
le soucis vient manifestement de mon CFLAGS qui n'est
probablement pas adapté pour compiler le bootloader.

si ça peut servir a d'autres... ZZ.
Publicité
Poster une réponse
Anonyme