freebsd + install scanner usb

Le
michel.wagner
bonjour à tous !

TENTATIVE D'INSTALLATION DU SCANNER AGFA snapscan 1212U
AVEC XSANE EN PLUGIN DE GIMP

j'utilise DESKTOPBSD : http://www.desktopbsd.net/
et je viens vers vous car je suis tout nouveau en
dehors de windows, si vous pouviez m'aider, ce serait
très sympa de votre part



voici ce que j'obtiens avec la commande dmesg :

mikedesktop# dmesg
Copyright (c) 1992-2007 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993,
1994
The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 6.3-RC1 #19: Wed Nov 28 22:58:32 UTC 2007
root@tinderbox.3c-consulting.lokal:/usr/obj/usr/src/sys/GENERIC
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Athlon(tm) 64 Processor 3500+ (2211.35-MHz 686-class CPU)
Origin = "AuthenticAMD" Id = 0x20ff2 Stepping = 2
Features=0x78bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MC=
A,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2>
Features2=0x1<SSE3>
AMD Features=0xe2500800<SYSCALL,NX,MMX+,FFXSR,LM,3DNow!+,3DNow!>
AMD Features2=0x1<LAHF>
real memory = 2147418112 (2047 MB)
avail memory = 2087686144 (1990 MB)
ACPI APIC Table: <Nvidia AWRDACPI>
ioapic0 <Version 1.1> irqs 0-23 on motherboard
kbd1 at kbdmux0
ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413,
RF5413)
acpi0: <Nvidia AWRDACPI> on motherboard
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x4008-0x400b on acpi0
cpu0: <ACPI CPU> on acpi0
powernow0: <Cool`n'Quiet K8> on cpu0
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pci0: <memory> at device 0.0 (no driver attached)
isab0: <PCI-ISA bridge> at device 1.0 on pci0
isa0: <ISA bus> on isab0
pci0: <serial bus, SMBus> at device 1.1 (no driver attached)
ohci0: <OHCI (generic) USB controller> mem 0xd2104000-0xd2104fff irq
21 at device 2.0 on pci0
ohci0: [GIANT-LOCKED]
usb0: OHCI version 1.0, legacy support
usb0: SMM does not respond, resetting
usb0: <OHCI (generic) USB controller> on ohci0
usb0: USB revision 1.0
uhub0: nVidia OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 10 ports with 10 removable, self powered
ehci0: <NVIDIA nForce4 USB 2.0 controller> mem 0xfeb00000-0xfeb000ff
irq 22 at device 2.1 on pci0
ehci0: [GIANT-LOCKED]
usb1: EHCI version 1.0
usb1: companion controller, 4 ports each: usb0
usb1: <NVIDIA nForce4 USB 2.0 controller> on ehci0
usb1: USB revision 2.0
uhub1: nVidia EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub1: 10 ports with 10 removable, self powered
pcm0: <nVidia nForce4> port 0xdc00-0xdcff,0xe000-0xe0ff mem
0xd2103000-0xd2103fff irq 23 at device 4.0 on pci0
pcm0: <Avance Logic ALC850 AC97 Codec>
atapci0: <nVidia nForce CK804 UDMA133 controller> port
0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xf000-0xf00f at device 6.0 on
pci0
ata0: <ATA channel 0> on atapci0
ata1: <ATA channel 1> on atapci0
atapci1: <nVidia nForce CK804 SATA300 controller> port
0x9f0-0x9f7,0xbf0-0xbf3,0x970-0x977,0xb70-0xb73,0xd800-0xd80f mem
0xd2102000-0xd2102fff irq 21 at device 7.0 on pci0j'Ã(c)dite
ata2: <ATA channel 0> on atapci1
ata3: <ATA channel 1> on atapci1
atapci2: <nVidia nForce CK804 SATA300 controller> port
0x9e0-0x9e7,0xbe0-0xbe3,0x960-0x967,0xb60-0xb63,0xc400-0xc40f mem
0xd2101000-0xd2101fff irq 22 at device 8.0 on pci0
ata4: <ATA channel 0> on atapci2
ata5: <ATA channel 1> on atapci2
pcib1: <ACPI PCI-PCI bridge> at device 9.0 on pci0
pci5: <ACPI PCI bus> on pcib1
pci5: <simple comms, UART> at device 8.0 (no driver attached)
fwohci0: <Texas Instruments TSB43AB22/A> mem 0xd2004000-0xd20047ff,
0xd2000000-0xd2003fff irq 16 at device 11.0 on pci5
fwohci0: OHCI version 1.10 (ROM=1)
fwohci0: No. of Isochronous channels is 4.
fwohci0: EUI64 00:11:d8:00:00:4e:a5:0e
fwohci0: Phy 1394a available S400, 2 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 02:11:d8:4e:a5:0e
fwe0: Ethernet address: 02:11:d8:4e:a5:0e
fwe0: if_start running deferred for Giant
sbp0: <SBP-2/SCSI over FireWire> on firewire0
fwohci0: Initiate bus resetce serait tres sympa
fwohci0: BUS reset
fwohci0: node_id=0xc800ffc0, gen=1, CYCLEMASTER mode
firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
firewire0: bus manager 0 (me)
nve0: <NVIDIA nForce MCP9 Networking Adapter> port 0xb000-0xb007 mem
0xd2100000-0xd2100fff irq 23 at device 10.0 on pci0
nve0: Ethernet address 00:13:d4:77:7a:a7
miibus0: <MII bus> on nve0
e1000phy0: <Marvell 88E1111 Gigabit PHY> on miibus0
e1000phy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseTX-
FDX, auto
nve0: Ethernet address: 00:13:d4:77:7a:a7
pcib2: <ACPI PCI-PCI bridge> at device 11.0 on pci0
pci4: <ACPI PCI bus> on pcib2
pcib3: <ACPI PCI-PCI bridge> at device 12.0 on pci0
pci3: <ACPI PCI bus> on pcib3
pcib4: <ACPI PCI-PCI bridge> at device 13.0 on pci0
pci2: <ACPI PCI bus> on pcib4
pcib5: <ACPI PCI-PCI bridge> at device 14.0 on pci0
pci1: <ACPI PCI bus> on pcib5
pci1: <display, VGA> at device 0.0 (no driver attached)
pci1: <display> at device 0.1 (no driver attached)
acpi_tz0: <Thermal Zone> on acpi0j'Ã(c)dite
fdc0: <floppy drive controller> port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on
acpi0
fdc0: [FAST]
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10
on acpi0
sio0: type 16550A
ppc0: <ECP parallel printer port> port 0x378-0x37f,0x778-0x77b irq 7
drq 3 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/16 bytes threshold
ppbus0: <Parallel port bus> on ppc0
ppi0: <Parallel I/O> on ppbus0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0j'Ã(c)dite
lpt0: Interrupt-driven port
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: model IntelliMouse, device ID 3
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xcdfff,0xd0000-0xd3fff on
isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on
isa0
Timecounter "TSC" frequency 2211345326 Hz quality 800
Timecounters tick every 1.000 msec
acd0: DVDROM <PHILIPS PCDV5016L2/F5S4> at ata0-master UDMA33
acd1: DMA limited to UDMA33, device found non-ATA66 cable
acd1: DVDR <ASUS DRW-1814BL/1.10> at ata0-slave UDMA33
acd0: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00
acd1: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00
ad8: 152627MB <Maxtor 6V160E0 VA111630> at ata4-master SATA300
ad10: 152627MB <Maxtor 6V160E0 VA111630> at ata5-master SATA300
acd0: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00
acd1: FAILURE - INQUIRY ILLEGAL REQUEST asc=0x24 ascq=0x00
cd0 at ata0 bus 0 target 0 lun 0
cd0: <PHILIPS PCDV5016L2 F5S4> Removable CD-ROM SCSI-0 device
cd0: 33.000MB/s transfers
cd0: Attempt to query device size failed: NOT READY, Medium not
present
cd1 at ata0 bus 0 target 1 lun 0
cd1: <ASUS DRW-1814BL 1.10> Removable CD-ROM SCSI-0 device
cd1: 33.000MB/s transfers
cd1: Attempt to query device size failed: NOT READY, Medium not
present - tray closed
Trying to mount root from ufs:/dev/ad8s1a
uscanner0: AGFA SNAPSCAN, rev 1.00/1.00, addr 2
umass0: vendor 0x0d7d USB DISK 2.0, rev 2.00/0.50, addr 2
da0 at umass-sim0 bus 0 target 0 lun 0
da0: < USB DISK 2.0 1.15> Removable Direct Access SCSI-0 device
da0: 40.000MB/s transfers
da0: 124MB (253952 512 byte sectors: 64H 32S/T 124C)
mikedesktop#

donc le scanner agfa est reconnu :
uscanner0: AGFA SNAPSCAN, rev 1.00/1.00, addr 2


dans http://snapscan.sourceforge.net/

je trouve 2 lignes pour le SNAPSCAN DE AGFA :


USB 0x06bd, 0x0001 "SNAPSCAN 1212U" not necessary(?)
0x06bd, 0x2061 "SNAPSCAN 1212U_2" Snapscan 1212U_2.bin

DONC D'APRES LE SITE SANE MON SCANNER EST UN U2 ALORS QUE
L'APPAREIl EST ESTAMPILLE.1212U ET PAS U2 !

j'ai trouvé dans dans mon dossier agfa sous windows xp un fichier
intitulé : SnapScan 1212U_2.bin
il ne peut pas être lu par un éditeur apparemment ! (ça me dit fichier=

binaire)

et sur le net j'ai trouvé un fichier qui est donné pour correspondre
au scanner dont voici la teneur :
********************************************************
#!/usr/bin/perl

sub inquiry {
@cmd = (0x12,0x00,0x00,0x00,120,0x00 );

usb_cmd(@cmd);
usb_read(8);
$inq = usb_read(120);
usb_read(8);

$ivendor = substr($inq,8,8);
$iproduct = substr($inq,16,16);
$irev = substr($inq,32,4);
$ifirmware = substr($inq,96,22);

if($verbose) {
print "Scanner Information (from scanner)";
print "tVendor: $ivendor";
print "tVersion: $irev";
print "tModel: $iproduct";
print "tFirmware date: $ifirmware";
print "";
}

}

sub upload_firmware {
$filename = shift;

open FIRM, "<$filename" or die("Can't open $filename");
undef $/;
$firmware = <FIRM>;
close FIRM;

$info = substr($firmware, length($firmware)-128);
$chip = substr($info,0,5);
$vendor = substr($info,0x5,0x8);
$model = substr($info,0xd,0x10);
$version = substr($info,0x1d,5);
$size = substr($info,0x22,0x2);
$size = ord(substr($size,0,1)) + (ord(substr($size,1,1)) << 8);
$fdate = substr($info,0x26,22);

if( $vendor eq $ivendor &&
$model eq $iproduct &&
$fdate eq $ifirmware ) {
if($verbose) {
printf "Firmware is up to date.";
}
return 1;
}

if($verbose) {
print "Firmware Information (from file)";
print "tChip: $chip";
print "tVendor: $vendor";
print "tVersion: $version";
print "tModel: $model";
print "tFirmware date: $fdate";
print "tSize: $size";
print "";
}

@cmd = (0x2a,0x00,0x87,0x00,0x00,0x00,0x00,0x00,0x00,0x00);

$cmd[7] = $size >> 8;
$cmd[8] = $size & 0xff;

usb_cmd(@cmd);
usb_read(8);
if($verbose) {
print "Uploading new firmware";
}
usb_write(substr($firmware,0,$size));
sleep(1);

if($verbose) {
print "Done!";
}
return 0;
}

sub print_binstr
{
my $str = shift;
for($i=0; $i<length($str); $i++) {
printf("0x%02x ", ord(substr($str,$i,1)));
}
print "";
}

sub usb_cmd {
my $cmd="";
my $c;
foreach $c (@_) {
$cmd .= chr($c);
}
syswrite(S,$cmd,length($cmd));
}

sub usb_write {
$data = shift;
syswrite(S,$data,length($data));
}

sub usb_read {
my $length = shift;
my $response="";
sysread(S,$response,$length);
return $response;
}

if($ARGV[0] eq "-v") {
$verbose = 1;
shift(@ARGV);
}

if($ARGV[0] eq "-h" || $#ARGV < 0) {
print 'AGFA Snapscan 1212U firmware uploader',"";
print 'Written by Henrik Johansson (henrikjo@post.utfors.se)
2000-01-29',"";
print 'THIS SOFTWARE COMES WITH ABSOLUTELY NO WARRANTY! USE AT YOUR
OWN RISK!',"";

print "Usage: agfafirm [-v] [-h] [DEVICE] FILE";
print "DEVICE is the USB scanner device. If omitted, /dev/usbscanner
will be used";
print "FILE refers to the firmware file that comes with the Windows
driver.";
print "Example: SnapScan 1212U_2.bin.";
print "Options:";
print "t-vtverbose mode";
print "t-htthis helptext";
exit 1;
}

if($#ARGV >= 1) {
$device = shift(@ARGV);
} else {
$device = "/dev/usbscanner";
}

open(S,"+>$device") or die("Can't open scanner device");
inquiry();
if(!upload_firmware($ARGV[0])) {
inquiry();
}
close S;

exit 0;
********************************************************

si je fais cd /usr/local/etc/sane.d/
et que j'édite snapscan.conf j'ai ceci :
*******************************************
" General
--

# Change to the fully qualified filename of your firmware file, if
# firmware upload is needed by the scanner
firmware /usr/local/share/sane/snapscan/your-firmwarefile.bin

# If not automatically found you may manually specify a device name.

# For USB scanners also specify bus=usb, e.g.
# /dev/usb/scanner0 bus=usb

# For SCSI scanners specify the generic device, e.g. /dev/sg0 on
Linux.
# /dev/sg0

#=

# No changes should be necessary below this line
#=


#-- SCSI scanners
-
# These SCSI devices will be probed automatically
scsi AGFA * Scanner
scsi COLOR * Scanner
scsi Color * Scanner
scsi ACERPERI * Scanner

# USB scanners
--
# These USB devices will be probed automatically
# (This will currently work only on Linux)

# Benq/Acer/Vuego 310U
usb 0x04a5 0x1a20
usb 0x04a5 0x1a26

# Benq/Acer/Vuego 320U
usb 0x04a5 0x2022

# Benq/Acer/Vuego 620U / 620UT
usb 0x04a5 0x1a2a
usb 0x04a5 0x2040

# Benq/Acer/Vuego 640U
usb 0x04a5 0x20605°)

# Benq/Acer/Vuego 640BU
usb 0x04a5 0x207e

# Benq/Acer/Vuego 640BT
usb 0x04a5 0x20be

# Benq/Acer/Vuego 1240U
usb 0x04a5 0x20c0

# Benq/Acer/Vuego 3300 / 4300
usb 0x04a5 0x20b0

# Benq/Acer/Vuego 4300
usb 0x04a5 0x20de

# Benq 5000E / 5000U
usb 0x04a5 0x20f8

# Benq 5000
usb 0x04a5 0x20fc

# Benq/Acer 5300
usb 0x04a5 0x20fe

# Benq 5250C
usb 0x04a5 0x2137

# Agfa 1236U
usb 0x06bd 0x0002

# Agfa 1212U
usb 0x06bd 0x0001
usb 0x06bd 0x2061

# Agfa Snapscan e10
usb 0x06bd 0x2093

# Agfa Snapscan e20
usb 0x06bd 0x2091

# Agfa Snapscan e25
usb 0x06bd 0x2095

# Agfa Snapscan e26
usb 0x06bd 0x2097

# Agfa Snapscan e40
usb 0x06bd 0x208d

# Agfa Snapscan e42
usb 0x06bd 0x20ff

# Agfa Snapscan e50
usb 0x06bd 0x208f

# Agfa Snapscan e52
usb 0x06bd 0x20fd

# Epson Perfection 660
usb 0x04b8 0x0114

# Epson Perfection 1670
usb 0x04b8 0x011f

# Epson Perfection 2480
usb 0x04b8 0x0121

# Epson Perfection 3490
usb 0x04b8 0x0122

# Epson Stylus CX-1500
usb 0x04b8 0x080c
****************************************************


dans /etc/devfs.rules j'ai :
# Scanners
add path uscanner[0-9]* mode 0660 group mount



je me suis basÃ(c) sur le document suivant:
mirabellug.org/wikini/upload/Documentations_scanner.pdf
et aussi sur la page du handbook :
http://www.freebsd.org/doc/fr_FR.ISO/scanners.html

et j'ai essayé d'en déduire les manip suivantes :

1°) en su je tape :
mikedesktop# cd /usr/ports/graphics/gimp/
puis mikedesktop# make install clean

2°) ensuite :
mikedesktop# cd /usr/ports/graphics/xsane/
puis :
mikedesktop# make WITH_GIMP=yes
et make install clean


et enfin comme dit le document :
mikedesktop# ln -s /usr/X11R6/bin/xsane /usr/home/mike/.gimp-2.4/plug-
ins/xsane

la ligne Xsane apparait dans le menu de gimp

et si je fais en su
mikedesktop# scanimage -L j'obtiens :device `snapscan:/dev/uscanner0'
is a AGFA SNAPSCAN flatbed scanner
et
mikedesktop# sane-find-scanner -q
found USB scanner (vendor=0x06bd, product=0x2061) at /dev/uscanner0

ensuite je fais :
mikedesktop# chmod 666 /dev/uscanner0
mikedesktop# chmod 666 /dev/usb0

ensuite j'ai ajouté dans /etc/devfs.conf
les 2 lignes suivantes :
perm uscanner0 0666
perm usb0 0666





A)et quand je clique sur Xsane dans le menu de gimp, puis "accepter"
sur le menu
d'acceptation de xsane j'ai une fenetre qui s'ouvre "recherche du
périphérique"
et ensuite une fenetre d'erreur qui dit :
"erreur d'ouverture du périphérique snapscan : /dev/uscanner0:
argument invalide"
B)autre manip : ee /usr/local/etc/sane.d/snapscan/
dans lequel je remplace la ligne firmware /usr/local/share/sane/
snapscan/your-firmwarefile.bin
par firmware /usr/local/share/sane/snapscan/1212U.bin (fichier perl
plus haut)
puis cp /home/mike/SCANNER_SNAPSCAN_1212U/1212* /usr/local/share/sane/
snapscan/
je n'obtiens plus le même message mais celui-ci :
"erreur d'ouverture du périphérique snapscan : /dev/uscanner0:erreur
d'I/O sur le périphérique"
C)enfin losque je teste xsane en mike, jobtiens ceci:

[mike@mikedesktop /usr/home/mike]$ xsane
/usr/local/share/themes/Clearlooks-DeepSky/gtk-2.0/gtkrc:44:
Clearlooks configuration option "menuitemstyle" is not supported and
will be ignored.
/usr/local/share/themes/Clearlooks-DeepSky/gtk-2.0/gtkrc:45:
Clearlooks configuration option "listviewitemstyle" is not supported
and will be ignored.
/usr/local/share/themes/Clearlooks-DeepSky/gtk-2.0/gtkrc:46:
Clearlooks configuration option "progressbarstyle" is not supported
and will be ignored.
/home/mike/.gtkrc-2.0:12: Impossible de trouver le fichier Ã*
inclureÂ*: Â<<Â*~/.gtkrc.mineÂ*Â>>





voilà j'en suis là et je ne sais pas quoi faire
Etant donné que je suis tout nouveau avec BSD et que mes notions de
lignes de commandes se résument à peu de choses
pouvez vous m'aider ?

merci d'avance à vous tous !
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Marc Fonvieille
Le #901048
On Fri, 7 Dec 2007 01:44:53 -0800 (PST),
[...]

dans /etc/devfs.rules j'ai :
# Scanners
add path uscanner[0-9]* mode 0660 group mount



Cette ligne ne sera jamais prise en compte. Il faut déclarer un nouvel
ensemble de règle:

dans /etc/devfs.rules
[system=5]
add path uscanner[0-9]* mode 0660

puis dans /etc/rc.conf
devfs_system_ruleset="system"



je me suis basÃ(c) sur le document suivant:
mirabellug.org/wikini/upload/Documentations_scanner.pdf
et aussi sur la page du handbook :
http://www.freebsd.org/doc/fr_FR.ISO.../scanners.html

et j'ai essayé d'en déduire les manip suivantes :

1°) en su je tape :
mikedesktop# cd /usr/ports/graphics/gimp/
puis mikedesktop# make install clean

2°) ensuite :
mikedesktop# cd /usr/ports/graphics/xsane/
puis :
mikedesktop# make WITH_GIMP=yes
et make install clean


et enfin comme dit le document :
mikedesktop# ln -s /usr/X11R6/bin/xsane /usr/home/mike/.gimp-2.4/plug-
ins/xsane

la ligne Xsane apparait dans le menu de gimp

et si je fais en su
mikedesktop# scanimage -L j'obtiens :device `snapscan:/dev/uscanner0'
is a AGFA SNAPSCAN flatbed scanner
et
mikedesktop# sane-find-scanner -q
found USB scanner (vendor=0x06bd, product=0x2061) at /dev/uscanner0

[...]


Là, les messages sont encourageant, normalement il est possible de
numériser un document:

% scanimage -p > image.pnm

doit fonctionner, si c'est le cas le problème avec Xsane est juste au
niveau de Xsane et non de la configuration du scanner.
Il faut cependant bien vérifier que la ligne

firmware /usr/local/share/sane/snapscan/your-firmwarefile.bin

du fichier /usr/local/etc/sane.d/snapscan.conf point bien sur le
firmware.


ensuite je fais :
mikedesktop# chmod 666 /dev/uscanner0
mikedesktop# chmod 666 /dev/usb0

ensuite j'ai ajouté dans /etc/devfs.conf
les 2 lignes suivantes :
perm uscanner0 0666
perm usb0 0666


[...]


tout cela est inutile si devfs.rules et rc.conf ont été modifié comme je
l'ai précisé plus haut.

donc pour résumer:

- mettre à jour la ligne firmware de /usr/local/etc/sane.d/snapscan.conf
- rédiger un devfs.rules correct avec le rajout nécessaire au rc.conf
- redémarrer
- faire un test avec scanimage en root puis en utilisateur normal

--
Marc

Publicité
Poster une réponse
Anonyme