[freebsd] plantages étranges en VM

Le
patpro ~ patrick proniewski
Bonjour,

j'ai un souci étrange avec un serveur MX sous FreeBSD. C'est une machine
virtuelle dans une infra VMware VSphere 5.
Le serveur est en FreeBSD 8.3. Il a planté une fois hier, et une fois
aujourd'hui, sans que je puisse tirer d'explications ou d'indices
probants des logs.

Le truc le plus étrange, c'est que j'ai 2 serveurs MX en balance de
charge (grace à un switch en amont), le second est le clone du premier,
et seul un des deux a des plantages récurants.
Les deux machines sont identiques, seule l'IP et l'adresse MAC étaient
différents. Comme l'un plante et l'autre pas, j'imagine qu'elles
divergent. Peut être que le filesystem a pris un coup, je ne sais pas,
j'ai pas trop de piste.

Y a-t-il des choses que je peux mettre en place, ou chercher, pour
déterminer d'où vient mon problème ? J'ai plus l'habitude des soucis
hardware, mais là le matériel n'est pas en cause.

patpro

--
photo http://photo.patpro.net/
blog http://www.patpro.net/
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
patpro ~ Patrick Proniewski
Le #25223802
desole pour l'encodage, again.

Bonjour,

j'ai un souci etrange avec un serveur MX sous FreeBSD. C'est une machine
virtuelle dans une infra VMware VSphere 5.
Le serveur est en FreeBSD 8.3. Il a plante une fois hier, et une fois
aujourd'hui, sans que je puisse tirer d'explications ou d'indices
probants des logs.

Le truc le plus etrange, c'est que j'ai 2 serveurs MX en balance de
charge (grace a un switch en amont), le second est le clone du premier,
et seul un des deux a des plantages recurants.
Les deux machines sont identiques, seule l'IP et l'adresse MAC etaient
differents. Comme l'un plante et l'autre pas, j'imagine qu'elles
divergent. Peut etre que le filesystem a pris un coup, je ne sais pas,
j'ai pas trop de piste.

Y a-t-il des choses que je peux mettre en place, ou chercher, pour
determiner d'ou vient mon probleme ? J'ai plus l'habitude des soucis
hardware, mais la le materiel n'est pas en cause.

patpro
Patrick Lamaizière
Le #25224462
patpro ~ Patrick Proniewski :

desole pour l'encodage, again.

Bonjour,

j'ai un souci etrange avec un serveur MX sous FreeBSD. C'est une machine
virtuelle dans une infra VMware VSphere 5.
Le serveur est en FreeBSD 8.3. Il a plante une fois hier, et une fois
aujourd'hui, sans que je puisse tirer d'explications ou d'indices
probants des logs.



Tu peux configurer un crash dump déjà, non ?

Le truc le plus etrange, c'est que j'ai 2 serveurs MX en balance de
charge (grace a un switch en amont), le second est le clone du premier,
et seul un des deux a des plantages recurants.
Les deux machines sont identiques, seule l'IP et l'adresse MAC etaient
differents. Comme l'un plante et l'autre pas, j'imagine qu'elles
divergent. Peut etre que le filesystem a pris un coup, je ne sais pas,
j'ai pas trop de piste.

Y a-t-il des choses que je peux mettre en place, ou chercher, pour
determiner d'ou vient mon probleme ? J'ai plus l'habitude des soucis
hardware, mais la le materiel n'est pas en cause.



J'essaierais un fsck pour voir, éventuellement migrer la VM qui merde
un ESX différent (tu es sûr que tu n'as pas un ESX qui merde ?)

Bon courage...
patpro ~ Patrick Proniewski
Le #25224622
In article Patrick Lamaizière
patpro ~ Patrick Proniewski :

> desole pour l'encodage, again.
>
> Bonjour,
>
> j'ai un souci etrange avec un serveur MX sous FreeBSD. C'est une machine
> virtuelle dans une infra VMware VSphere 5.
> Le serveur est en FreeBSD 8.3. Il a plante une fois hier, et une fois
> aujourd'hui, sans que je puisse tirer d'explications ou d'indices
> probants des logs.

Tu peux configurer un crash dump déjà, non ?



hmmm le souci c'est quoi en faire :)
L'avant dernier plantage j'ai eu un kernel panic mais seulement au
moment de rebooter, et le dernier plantage la machine était même pas
totalement inaccessible puisqu'à la console on pouvait encore tenter de
se loguer (sans succès, certes), et elle avait perdu son réseau.

J'essaierais un fsck pour voir, éventuellement migrer la VM qui merde
un ESX différent (tu es sûr que tu n'as pas un ESX qui merde ?)



il FSCK automatiquement au reboot, et sur le même ESX j'ai 12 VM dont
des gros trucs genre le SAP de prod. J'ose espérer que l'ESX n'est pas
en cause :D

Je vais me pencher sur le crash dump, à tout hasard.

patpro
Publicité
Poster une réponse
Anonyme