[FreeBSD] plus de clavier

Le
JKB
Bonjour à tous,

Petit problème du jour avec un FreeBSD 10.1. Étant toujours dans mes
problèmes de compilation de knoda (au passage, le paquet a été
repris sous le nom knoda4), j'ai dû installer un certain nombre de
dépendances et ces dépendances m'ont mis à jour l'ensemble du
système. Depuis le redémarrage de X, je n'ai plus de clavier (ni le
clavier du portable, ni un clavier USB, rien).

Dans les logs de X, j'ai :

[ 7238.714] (II) config/devd: probing input devices
[ 7238.714] (II) config/devd: adding input device (null) (/dev/kbdmux)
[ 7238.714] (**) kbdmux: Applying InputClass "Keyboard Defaults"
[ 7238.714] (II) LoadModule: "kbd"
[ 7238.715] (II) Loading /usr/local/lib/xorg/modules/input/kbd_drv.so
[ 7238.715] (II) Module kbd: vendor="X.Org Foundation"
[ 7238.715] compiled for 1.14.7, module version = 1.8.0
[ 7238.715] Module class: X.Org XInput Driver
[ 7238.715] ABI class: X.Org XInput driver, version 19.1
[ 7238.715] (II) Using input driver 'kbd' for 'kbdmux'
[ 7238.715] (**) kbdmux: always reports core events
[ 7238.715] (**) kbdmux: always reports core events
[ 7238.715] (**) Option "Protocol" "standard"
[ 7238.715] (**) Option "XkbRules" "base"
[ 7238.715] (**) Option "XkbModel" "pc105"
[ 7238.715] (**) Option "XkbLayout" "fr"
[ 7238.715] (**) Option "XkbVariant" "latin9"
[ 7238.716] (**) Option "config_info" "devd:kbdmux"
[ 7238.716] (II) XINPUT: Adding extended input device "kbdmux" (type:
KEYBOARD, id 6)
[ 7238.833] (II) config/devd: kbdmux is enabled, ignoring device ukbd0
[ 7238.833] (II) config/devd: kbdmux is enabled, ignoring device atkbd0

Je n'aime pas les lignes ignoring device *0 J'ai essayé de forcer
une configuration de clavier dans
/usr/local/etc/X11/xorg.conf.d/intput.conf, cela ne change rien au
problème.

Une idée pour corriger ce problème ? Je viens de googliser et je
n'ai rien trouvé de probant (sauf des personnes qui avaient
récemment le même problème mais sans proposer de solution).

Cordialement,

JKB

--
Si votre demande me parvient sur carte perforée, je titiouaillerai très
volontiers une réponse
=> http://grincheux.de-charybde-en-scylla.fr
=> http://loubardes.de-charybde-en-scylla.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JKB
Le #26337678
Le Fri, 6 Feb 2015 09:45:52 +0000 (UTC),
JKB
Bonjour à tous,

Petit problème du jour avec un FreeBSD 10.1. Étant toujours dans mes
problèmes de compilation de knoda (au passage, le paquet a été
repris sous le nom knoda4), j'ai dû installer un certain nombre de
dépendances et ces dépendances m'ont mis à jour l'ensemble du
système. Depuis le redémarrage de X, je n'ai plus de clavier (ni le
clavier du portable, ni un clavier USB, rien...).



Bon, je corrige. J'ai viré hald qui semblait gêner edevd et ça
fonctionne. J'ai récupéré le clavier. En revanche, il reste des
problèmes de fontes. Visiblement, elles sont installées mais ne
s'affichent pas correctement au moins dans les menus de wmaker
(dixit la personne que j'ai au téléphone).

Cordialement,

JKB

--
Si votre demande me parvient sur carte perforée, je titiouaillerai très
volontiers une réponse...
=> http://grincheux.de-charybde-en-scylla.fr
=> http://loubardes.de-charybde-en-scylla.fr
Damien Wyart
Le #26337677
* JKB
Bon, je corrige. J'ai viré hald qui semblait gêner edevd et ça
fonctionne. J'ai récupéré le clavier. En revanche, il reste des
problèmes de fontes. Visiblement, elles sont installées mais ne
s'affichent pas correctement au moins dans les menus de wmaker
(dixit la personne que j'ai au téléphone).



En général, tu soulignes que BSD fait moins de mauvaises surprises aux
utilisateurs, mais là ça ne semble pas être le cas. Enfin, c'est
peut-être FreeBSD qui se "linuxise", c'est sans doute moins marqué pour
NetBSD.

--
DW
JKB
Le #26337679
Le Fri, 06 Feb 2015 11:19:02 +0100,
Damien Wyart
* JKB
Bon, je corrige. J'ai viré hald qui semblait gêner edevd et ça
fonctionne. J'ai récupéré le clavier. En revanche, il reste des
problèmes de fontes. Visiblement, elles sont installées mais ne
s'affichent pas correctement au moins dans les menus de wmaker
(dixit la personne que j'ai au téléphone).



En général, tu soulignes que BSD fait moins de mauvaises surprises aux
utilisateurs, mais là ça ne semble pas être le cas. Enfin, c'est
peut-être FreeBSD qui se "linuxise", c'est sans doute moins marqué pour
NetBSD.



C'est surtout que je ne maîtrise pas aussi bien FreeBSD que NetBSD
et que je fais de l'administration par téléphone depuis ce matin :-(

JKB

--
Si votre demande me parvient sur carte perforée, je titiouaillerai très
volontiers une réponse...
=> http://grincheux.de-charybde-en-scylla.fr
=> http://loubardes.de-charybde-en-scylla.fr
Bruno Ducrot
Le #26337727
On 2015-02-06, JKB wrote:
Le Fri, 6 Feb 2015 09:45:52 +0000 (UTC),
JKB
Bonjour à tous,

Petit problème du jour avec un FreeBSD 10.1. Étant toujours dans mes
problèmes de compilation de knoda (au passage, le paquet a été
repris sous le nom knoda4), j'ai dû installer un certain nombre de
dépendances et ces dépendances m'ont mis à jour l'ensemble du
système. Depuis le redémarrage de X, je n'ai plus de clavier (ni le
clavier du portable, ni un clavier USB, rien...).



Bon, je corrige. J'ai viré hald qui semblait gêner edevd et ça
fonctionne. J'ai récupéré le clavier. En revanche, il reste des
problèmes de fontes. Visiblement, elles sont installées mais ne
s'affichent pas correctement au moins dans les menus de wmaker
(dixit la personne que j'ai au téléphone).





Normalement, en suivant point par point le handbook à partir de
http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/x11.html

tu ne devrais pas avoir trop de problèmes. On y voit, par exemple,
comment configurer correctement son clavier.

En ce qui concerne les fontes, le sous-chapitre correspondant est :
http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/x11.html

A plus,

--
Bruno Ducrot

A quoi ca sert que Ducrot hisse des carcasses ?
Bruno Ducrot
Le #26337726
On 2015-02-06, Damien Wyart wrote:
* JKB
Bon, je corrige. J'ai viré hald qui semblait gêner edevd et ça
fonctionne. J'ai récupéré le clavier. En revanche, il reste des
problèmes de fontes. Visiblement, elles sont installées mais ne
s'affichent pas correctement au moins dans les menus de wmaker
(dixit la personne que j'ai au téléphone).



En général, tu soulignes que BSD fait moins de mauvaises surprises aux
utilisateurs, mais là ça ne semble pas être le cas. Enfin, c'est
peut-être FreeBSD qui se "linuxise", c'est sans doute moins marqué pour
NetBSD.



Quel sacré trolleur reconnu, ce Damien.

--
Bruno Ducrot

A quoi ca sert que Ducrot hisse des carcasses ?
Damien Wyart
Le #26337756
* Bruno Ducrot
Quel sacré trolleur reconnu, ce Damien.



C'était juste pour te réveiller ;-)

--
DW
Bruno Ducrot
Le #26337786
On 2015-02-06, Damien Wyart wrote:
* Bruno Ducrot
Quel sacré trolleur reconnu, ce Damien.



C'était juste pour te réveiller ;-)




Sinon, à part ça, faudrait qu'on se fasse une bouffe.

--
Bruno Ducrot

A quoi ca sert que Ducrot hisse des carcasses ?
Eric Demeester
Le #26337802
Bruno Ducrot (Fri, 6 Feb 2015 20:12:52 +0000 (UTC) - fr.comp.os.bsd) :

Sinon, à part ça, faudrait qu'on se fasse une bouffe.



Enfin une parole sensée (enfin si c'est pas une proposition privée et
que les ex-bsdistes passés sous Linux pour d'obscures raisons sont
acceptés).
JKB
Le #26337859
Le Fri, 6 Feb 2015 14:02:56 +0000 (UTC),
Bruno Ducrot
On 2015-02-06, JKB wrote:
Le Fri, 6 Feb 2015 09:45:52 +0000 (UTC),
JKB
Bonjour à tous,

Petit problème du jour avec un FreeBSD 10.1. Étant toujours dans mes
problèmes de compilation de knoda (au passage, le paquet a été
repris sous le nom knoda4), j'ai dû installer un certain nombre de
dépendances et ces dépendances m'ont mis à jour l'ensemble du
système. Depuis le redémarrage de X, je n'ai plus de clavier (ni le
clavier du portable, ni un clavier USB, rien...).



Bon, je corrige. J'ai viré hald qui semblait gêner edevd et ça
fonctionne. J'ai récupéré le clavier. En revanche, il reste des
problèmes de fontes. Visiblement, elles sont installées mais ne
s'affichent pas correctement au moins dans les menus de wmaker
(dixit la personne que j'ai au téléphone).





Normalement, en suivant point par point le handbook à partir de
http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/x11.html

tu ne devrais pas avoir trop de problèmes. On y voit, par exemple,
comment configurer correctement son clavier.

En ce qui concerne les fontes, le sous-chapitre correspondant est :
http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/x11.html

A plus,



Bon, bon, bon... C'est très étrange. Toutes les fontes s'affichent
_sauf_ celles qui sont dans les menus de Windowmaker... Chose
étrange, lorsque le menu passe sur une fenêtre ouverte, on voit
fugitivement l'écriture du menu. Je sèche totalement...

JKB

--
Si votre demande me parvient sur carte perforée, je titiouaillerai très
volontiers une réponse...
=> http://grincheux.de-charybde-en-scylla.fr
=> http://loubardes.de-charybde-en-scylla.fr
Bruno Ducrot
Le #26338654
On 2015-02-07, JKB wrote:
Le Fri, 6 Feb 2015 14:02:56 +0000 (UTC),
Bruno Ducrot
On 2015-02-06, JKB wrote:
Le Fri, 6 Feb 2015 09:45:52 +0000 (UTC),
JKB
Bonjour à tous,

Petit problème du jour avec un FreeBSD 10.1. Étant toujours dans mes
problèmes de compilation de knoda (au passage, le paquet a été
repris sous le nom knoda4), j'ai dû installer un certain nombre de
dépendances et ces dépendances m'ont mis à jour l'ensemble du
système. Depuis le redémarrage de X, je n'ai plus de clavier (ni le
clavier du portable, ni un clavier USB, rien...).



Bon, je corrige. J'ai viré hald qui semblait gêner edevd et ça
fonctionne. J'ai récupéré le clavier. En revanche, il reste des
problèmes de fontes. Visiblement, elles sont installées mais ne
s'affichent pas correctement au moins dans les menus de wmaker
(dixit la personne que j'ai au téléphone).





Normalement, en suivant point par point le handbook à partir de
http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/x11.html

tu ne devrais pas avoir trop de problèmes. On y voit, par exemple,
comment configurer correctement son clavier.

En ce qui concerne les fontes, le sous-chapitre correspondant est :
http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/x11.html

A plus,



Bon, bon, bon... C'est très étrange. Toutes les fontes s'affichent
_sauf_ celles qui sont dans les menus de Windowmaker... Chose
étrange, lorsque le menu passe sur une fenêtre ouverte, on voit
fugitivement l'écriture du menu. Je sèche totalement...




J'ai installé un FreeBSD 10.1 (386), mis à jour par freebsd-update, puis
j'ai installé xorg, quelques fontes, et enfin windowmaker, le tout via
pkg.

Je n'arrive pas à reproduire le comportement que tu décris. Je ne
connais pas très bien ce wm, et donc peut-être que je fais faire une
hypothèse foireuse. Je me demande si ce n'est un problème lié à un
mauvais support du driver de la carte graphique.

Pour tester cette hypothèse, il faudrait forcer le driver VESA,
puis, si l'hypothèse se confirme, revenir au driver de ta carte, en
testant la désactivation de certaines accélérations matérielles.

A plus,

--
Bruno Ducrot

A quoi ca sert que Ducrot hisse des carcasses ?
Publicité
Poster une réponse
Anonyme