frequence

Le
Manu
Bonsoir,

J'ai dans ma feuil1 en col A des dates de naissance, et en col B des heures

Dans ma feuil2, j'ai un tableau comme ci-dessous :

A B C
1 Age Nb de pers somme des heures
2 20
3 25
4 30
5 35
6 40
7 45
8 50
9 60
10 80

en B2, je souhaite compter le nombre de personne qui ont moins de 20 ans
puis en B3 entre 20 et 25 .etc, cela, je pense avoir réussi avec une
matricielle en selectionnant de B2 à B10 comme celle ci :
{=FREQUENCE(DATEDIF(Feuil1!A2:A3000;AUJOURDHUI();"y");Feuil2!A2:A10)}, en
tous cas, ca fonctionne.

En revanche, je bloque pour la formules de la colonne C où je souhaite
connaitre la somme des heures de la col B en Feuil1 en fonction de leurs
tranches d'ages.

Help SVP.

Merci

Manu
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sam
Le #18174791
Bonjour,
voici une solution mais à mon avis il doit y avoir mieux

en C3 :
=SOMMEPROD((DATEDIF(Feuil1!$A$2:$A$3000;AUJOURDHUI();"y")<£)*(DATEDIF(Feuil1!$A$2:$A$3000;AUJOURDHUI();"y")>A2)*Feuil1!$B$2:$B$3000)
et tirer jusque C10

en C2
=SOMMEPROD((DATEDIF(Feuil1!$A$2:$A$3000;AUJOURDHUI();"y")<¢)*Feuil1!$B$2:$B$3000)

Cordialement
Michel dit "Sam"

"Manu" %
Bonsoir,

J'ai dans ma feuil1 en col A des dates de naissance, et en col B des
heures

Dans ma feuil2, j'ai un tableau comme ci-dessous :

A B C
1 Age Nb de pers somme des heures
2 20
3 25
4 30
5 35
6 40
7 45
8 50
9 60
10 80

en B2, je souhaite compter le nombre de personne qui ont moins de 20 ans
puis en B3 entre 20 et 25 ....etc, cela, je pense avoir réussi avec une
matricielle en selectionnant de B2 à B10 comme celle ci :
{=FREQUENCE(DATEDIF(Feuil1!A2:A3000;AUJOURDHUI();"y");Feuil2!A2:A10)}, en
tous cas, ca fonctionne.

En revanche, je bloque pour la formules de la colonne C où je souhaite
connaitre la somme des heures de la col B en Feuil1 en fonction de leurs
tranches d'ages.

Help SVP.

Merci

Manu





Manu
Le #18174941
Il y a certainement mieux Sam, mais ca fonctionne, super, mais je t'avoues
que j'etais vraiment pas loin de la solution mais en plus complexe que toi.
Non seulement c'est plus simple, mais surtout tu as trouvé ! Merci Sam.

Pour le sport, si quelqu'un trouve une solution simplifier.... sais t'on
jamais.....

Manu

"Sam" 494ab91d$0$4093$

Bonjour,
voici une solution mais à mon avis il doit y avoir mieux

en C3 :
=SOMMEPROD((DATEDIF(Feuil1!$A$2:$A$3000;AUJOURDHUI();"y")<£)*(DATEDIF(Feuil1!$A$2:$A$3000;AUJOURDHUI();"y")>A2)*Feuil1!$B$2:$B$3000)
et tirer jusque C10

en C2
=SOMMEPROD((DATEDIF(Feuil1!$A$2:$A$3000;AUJOURDHUI();"y")<¢)*Feuil1!$B$2:$B$3000)

Cordialement
Michel dit "Sam"

"Manu" %
Bonsoir,

J'ai dans ma feuil1 en col A des dates de naissance, et en col B des
heures

Dans ma feuil2, j'ai un tableau comme ci-dessous :

A B C
1 Age Nb de pers somme des heures
2 20
3 25
4 30
5 35
6 40
7 45
8 50
9 60
10 80

en B2, je souhaite compter le nombre de personne qui ont moins de 20 ans
puis en B3 entre 20 et 25 ....etc, cela, je pense avoir réussi avec une
matricielle en selectionnant de B2 à B10 comme celle ci :
{=FREQUENCE(DATEDIF(Feuil1!A2:A3000;AUJOURDHUI();"y");Feuil2!A2:A10)}, en
tous cas, ca fonctionne.

En revanche, je bloque pour la formules de la colonne C où je souhaite
connaitre la somme des heures de la col B en Feuil1 en fonction de leurs
tranches d'ages.

Help SVP.

Merci

Manu









Publicité
Poster une réponse
Anonyme