Fréquence de valeurs

Le
Soria
Bonjour,

Dans une plage contenant exclusivement des valeurs numériques, je souhaite
renvoyer (avec une formule) la ou les valeur(s) "présente(s) le plus grand
nombre de fois"
Pour être plus claire, des exemples de données en A1:A10 et les résultats
attendus en B1:B10 :

A1:A10 = 1;2;3;4;5;6;7;8;9;10 ==> en B1:B10 = 1;2;3;4;5;6;7;8;9;10
A1:A10 = 1;2;3;4;5;6;1;8;9;10 ==> en B1 = 1
A1:A10 = 1;2;3;4;5;6;1;8;9;4 ==> en B1:B2 = 1;4
A1:A10 = 100;9;3;100;3;100;3;2;2;2 ==> en B1:B3 = 100;3;2

Merci de votre attention
Soria
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Filochard
Le #5025621
Dans une plage contenant exclusivement des valeurs numériques, je souhaite
renvoyer (avec une formule) la ou les valeur(s) "présente(s) le plus grand
nombre de fois"
Pour être plus claire, des exemples de données en A1:A10 et les résultats
attendus en B1:B10 :

A1:A10 = 1;2;3;4;5;6;7;8;9;10 ==> en B1:B10 = 1;2;3;4;5;6;7;8;9;10
A1:A10 = 1;2;3;4;5;6;1;8;9;10 ==> en B1 = 1
A1:A10 = 1;2;3;4;5;6;1;8;9;4 ==> en B1:B2 = 1;4
A1:A10 = 100;9;3;100;3;100;3;2;2;2 ==> en B1:B3 = 100;3;2



Pour obtenir ce résultat avec une formule, vous devez utiliser une formule
matricielle sur la plage B1:B10
Pour ce faire, sélectionner d'abord B1:B10 puis saisir dans la barre de formule
la formule suivante sur une seule ligne :

=SI(ESTNUM(PETITE.VALEUR(SI(FREQUENCE(A1:A10;A1:A10)=MAX(FREQUENCE(A1:A10;A1:A10));LIGNE(INDIRECT("$1:$"&LIGNES(A1:A10))));LIGNE(INDIRECT("$1:$"&LIGNES(A1:A10)))));INDEX(A1:A10;PETITE.VALEUR(SI(FREQUENCE(A1:A10;A1:A10)=MAX(FREQUENCE(A1:A10;A1:A10));LIGNE(INDIRECT("$1:$"&LIGNES(A1:A10))));LIGNE(INDIRECT("$1:$"&LIGNES(A1:A10)))));"")

Valider la formule par ctrl+maj+enter

Publicité
Poster une réponse
Anonyme