FTP IIS

Le
smk
Bonjour

J'ai encore des soucis avec mon serveur FTP de IIS sous wxp pro

En fait, je m'en était pas rencu compte, mais je me connecte tres bien
depuis les pc du lan.
Mais qd je suis a l'exterieur, via une carte Orange (PCMCIA) qui fait office
de modem.
J'ai bien acces a internet, et ma connexion FTP sur mon serveur(qui tourne)
se fait.
Mais impossible de recuperer un fichier du serveur vers le portable.
il me dit "le serveur ne repond pas" (logiciel ftp expert)
meme une connexion via l'eplorateur windows, ne fonctionne pas, et là c'est
pire puisque je ne peux meme
pas voir le contenu des dossier, puis erreur : connexion impossible,
mes identifiants de connexions sont bons. Qd je tap des identifiants
erronés, j'ai un message explicite, correspondant.

Merci d'avance pour vos suggestions
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jbongran
Le #11346131
smk wrote:
Bonjour

J'ai encore des soucis avec mon serveur FTP de IIS sous wxp pro

En fait, je m'en était pas rencu compte, mais je me connecte tres bien
depuis les pc du lan.
Mais qd je suis a l'exterieur, via une carte Orange (PCMCIA) qui fait
office de modem.
J'ai bien acces a internet, et ma connexion FTP sur mon serveur(qui
tourne) se fait.
Mais impossible de recuperer un fichier du serveur vers le portable.
il me dit "le serveur ne repond pas" (logiciel ftp expert)
meme une connexion via l'eplorateur windows, ne fonctionne pas, et là
c'est pire puisque je ne peux meme
pas voir le contenu des dossier, puis erreur : connexion impossible,
mes identifiants de connexions sont bons. Qd je tap des identifiants
erronés, j'ai un message explicite, correspondant.

Merci d'avance pour vos suggestions



Bonjour,
Merci de préciser si c'est en mode actif ou passif, ou les deux.;-)
Un bon moyen de tester et déliminer la partie 'cliente' (le poste qui essaye
de se connecter) est de se servir d'un serveur FTP 'de référence', tel celui
de free ftp://ftp.free.fr et d'essayer de s'y connecter en mode anonyme
(anonymous et )
Si on peut s'y connecter et faire un ls du repertoire, la partie cliente est
bonne, il faudra se concentrer sur la partie serveur FTP.

Visiblement dans ton cas, c'est la connection Data qui ne passe pas
Si c'est en mode actif, faire un trou de sécurité dans le parefeu de la
livebox en forwardant tout ce qui est en provenance de n'importe qui depuis
le port 20 (si c'est possible, je n'ai pas de livebox sous les yeux)

Si c'est en mode passif, il faut forwarder tous les ports source > 1024 vers
les m^me ports sur le serveur. (je ne pense pas que ce soit possible avec
une livebox.

Enfin, regarder si dans la livebox, il n'y a pas au niveau firewall, quelque
chose de déja prévu pour des services bien connus, tel le http ou le ftp. Si
c'est le cas, enlever TOUTES tes règles manuelles concernant ton serveur
FTP, et juste selectionner FTP dans la liste des services.

Allez, un peu de courage, c'est pas une 'boite vivante' qui va nous embêter
...
smk
Le #11346121
jbongran a utilisé son clavier pour écrire :
smk wrote:
Bonjour

J'ai encore des soucis avec mon serveur FTP de IIS sous wxp pro

En fait, je m'en était pas rencu compte, mais je me connecte tres bien
depuis les pc du lan.
Mais qd je suis a l'exterieur, via une carte Orange (PCMCIA) qui fait
office de modem.
J'ai bien acces a internet, et ma connexion FTP sur mon serveur(qui
tourne) se fait.
Mais impossible de recuperer un fichier du serveur vers le portable.
il me dit "le serveur ne repond pas" (logiciel ftp expert)
meme une connexion via l'eplorateur windows, ne fonctionne pas, et là
c'est pire puisque je ne peux meme
pas voir le contenu des dossier, puis erreur : connexion impossible,
mes identifiants de connexions sont bons. Qd je tap des identifiants
erronés, j'ai un message explicite, correspondant.

Merci d'avance pour vos suggestions



Bonjour,
Merci de préciser si c'est en mode actif ou passif, ou les deux.;-)
Un bon moyen de tester et déliminer la partie 'cliente' (le poste qui essaye
de se connecter) est de se servir d'un serveur FTP 'de référence', tel celui
de free ftp://ftp.free.fr et d'essayer de s'y connecter en mode anonyme
(anonymous et )
Si on peut s'y connecter et faire un ls du repertoire, la partie cliente est
bonne, il faudra se concentrer sur la partie serveur FTP.

Visiblement dans ton cas, c'est la connection Data qui ne passe pas
Si c'est en mode actif, faire un trou de sécurité dans le parefeu de la
livebox en forwardant tout ce qui est en provenance de n'importe qui depuis
le port 20 (si c'est possible, je n'ai pas de livebox sous les yeux)

Si c'est en mode passif, il faut forwarder tous les ports source > 1024 vers
les m^me ports sur le serveur. (je ne pense pas que ce soit possible avec une
livebox.

Enfin, regarder si dans la livebox, il n'y a pas au niveau firewall, quelque
chose de déja prévu pour des services bien connus, tel le http ou le ftp. Si
c'est le cas, enlever TOUTES tes règles manuelles concernant ton serveur FTP,
et juste selectionner FTP dans la liste des services.

Allez, un peu de courage, c'est pas une 'boite vivante' qui va nous embêter
...



Merci pour cette piste

Bonne FETE(qd meme)

Je viens de me connecter au serveur ftp://ftp.free.fr en anonymous,
et j'ai pu recuperer un fichier, de leur serveur vers mon ordi.
Je crois que le soucis c'est donc mon serveur ftp, sous IIS.
Cest peut etre ma LiveBox qui fait des siennes.

Pardon mais je sais pas comment "forwarder", ou
"faire un trou de sécurité"...
Des que je me connecte en dehors du
jbongran
Le #11346111
"smk"
jbongran a utilisé son clavier pour écrire :
smk wrote:
Bonjour

J'ai encore des soucis avec mon serveur FTP de IIS sous wxp pro

En fait, je m'en était pas rencu compte, mais je me connecte tres bien
depuis les pc du lan.
Mais qd je suis a l'exterieur, via une carte Orange (PCMCIA) qui fait
office de modem.
J'ai bien acces a internet, et ma connexion FTP sur mon serveur(qui
tourne) se fait.
Mais impossible de recuperer un fichier du serveur vers le portable.
il me dit "le serveur ne repond pas" (logiciel ftp expert)
meme une connexion via l'eplorateur windows, ne fonctionne pas, et là
c'est pire puisque je ne peux meme
pas voir le contenu des dossier, puis erreur : connexion impossible,
mes identifiants de connexions sont bons. Qd je tap des identifiants
erronés, j'ai un message explicite, correspondant.

Merci d'avance pour vos suggestions



Bonjour,
Merci de préciser si c'est en mode actif ou passif, ou les deux.;-)
Un bon moyen de tester et déliminer la partie 'cliente' (le poste qui
essaye de se connecter) est de se servir d'un serveur FTP 'de référence',
tel celui de free ftp://ftp.free.fr et d'essayer de s'y connecter en mode
anonyme (anonymous et )
Si on peut s'y connecter et faire un ls du repertoire, la partie cliente
est bonne, il faudra se concentrer sur la partie serveur FTP.

Visiblement dans ton cas, c'est la connection Data qui ne passe pas
Si c'est en mode actif, faire un trou de sécurité dans le parefeu de la
livebox en forwardant tout ce qui est en provenance de n'importe qui
depuis le port 20 (si c'est possible, je n'ai pas de livebox sous les
yeux)

Si c'est en mode passif, il faut forwarder tous les ports source > 1024
vers les m^me ports sur le serveur. (je ne pense pas que ce soit possible
avec une livebox.

Enfin, regarder si dans la livebox, il n'y a pas au niveau firewall,
quelque chose de déja prévu pour des services bien connus, tel le http ou
le ftp. Si c'est le cas, enlever TOUTES tes règles manuelles concernant
ton serveur FTP, et juste selectionner FTP dans la liste des services.

Allez, un peu de courage, c'est pas une 'boite vivante' qui va nous
embêter ...



Merci pour cette piste

Bonne FETE(qd meme)

Je viens de me connecter au serveur ftp://ftp.free.fr en anonymous,
et j'ai pu recuperer un fichier, de leur serveur vers mon ordi.
Je crois que le soucis c'est donc mon serveur ftp, sous IIS.
Cest peut etre ma LiveBox qui fait des siennes.

Pardon mais je sais pas comment "forwarder", ou
"faire un trou de sécurité"...
Des que je me connecte en dehors du





Du Lan j'imagine ?
Dernière astuce pour accélerer le dépannage: utiliser un client FTP qui
affiche le log de toutes les commandes et réponses, tel smartftp
www.smartftp.com, et qui supporte les deux modes FTP.
Eventuellement, poster ici le log correspondant à chaque mode, ça peut aider
à y voir plus clair.
Il est aussi possible de donner ton IP, ou le nom de domaine permettant
d'accèder à ton serveur FTP (sans compte utilisateur, juste un accès anonyme
à un repertoire contenant au moins un fichier).
smk
Le #11346101
jbongran avait écrit le 15/07/2007 :
"smk"
jbongran a utilisé son clavier pour écrire :
smk wrote:
Bonjour

J'ai encore des soucis avec mon serveur FTP de IIS sous wxp pro

En fait, je m'en était pas rencu compte, mais je me connecte tres bien
depuis les pc du lan.
Mais qd je suis a l'exterieur, via une carte Orange (PCMCIA) qui fait
office de modem.
J'ai bien acces a internet, et ma connexion FTP sur mon serveur(qui
tourne) se fait.
Mais impossible de recuperer un fichier du serveur vers le portable.
il me dit "le serveur ne repond pas" (logiciel ftp expert)
meme une connexion via l'eplorateur windows, ne fonctionne pas, et là
c'est pire puisque je ne peux meme
pas voir le contenu des dossier, puis erreur : connexion impossible,
mes identifiants de connexions sont bons. Qd je tap des identifiants
erronés, j'ai un message explicite, correspondant.

Merci d'avance pour vos suggestions



Bonjour,
Merci de préciser si c'est en mode actif ou passif, ou les deux.;-)
Un bon moyen de tester et déliminer la partie 'cliente' (le poste qui
essaye de se connecter) est de se servir d'un serveur FTP 'de référence',
tel celui de free ftp://ftp.free.fr et d'essayer de s'y connecter en mode
anonyme (anonymous et )
Si on peut s'y connecter et faire un ls du repertoire, la partie cliente
est bonne, il faudra se concentrer sur la partie serveur FTP.

Visiblement dans ton cas, c'est la connection Data qui ne passe pas
Si c'est en mode actif, faire un trou de sécurité dans le parefeu de la
livebox en forwardant tout ce qui est en provenance de n'importe qui
depuis le port 20 (si c'est possible, je n'ai pas de livebox sous les
yeux)

Si c'est en mode passif, il faut forwarder tous les ports source > 1024
vers les m^me ports sur le serveur. (je ne pense pas que ce soit possible
avec une livebox.

Enfin, regarder si dans la livebox, il n'y a pas au niveau firewall,
quelque chose de déja prévu pour des services bien connus, tel le http ou
le ftp. Si c'est le cas, enlever TOUTES tes règles manuelles concernant
ton serveur FTP, et juste selectionner FTP dans la liste des services.

Allez, un peu de courage, c'est pas une 'boite vivante' qui va nous
embêter ...



Merci pour cette piste

Bonne FETE(qd meme)

Je viens de me connecter au serveur ftp://ftp.free.fr en anonymous,
et j'ai pu recuperer un fichier, de leur serveur vers mon ordi.
Je crois que le soucis c'est donc mon serveur ftp, sous IIS.
Cest peut etre ma LiveBox qui fait des siennes.

Pardon mais je sais pas comment "forwarder", ou
"faire un trou de sécurité"...
Des que je me connecte en dehors du





Du Lan j'imagine ?
Dernière astuce pour accélerer le dépannage: utiliser un client FTP qui
affiche le log de toutes les commandes et réponses, tel smartftp
www.smartftp.com, et qui supporte les deux modes FTP.
Eventuellement, poster ici le log correspondant à chaque mode, ça peut aider
à y voir plus clair.
Il est aussi possible de donner ton IP, ou le nom de domaine permettant
d'accèder à ton serveur FTP (sans compte utilisateur, juste un accès anonyme
à un repertoire contenant au moins un fichier).



Bonjour

Qd je me connecte du LAN, tout est Ok.
Qd je me connecte hors du LAN je peux rien uploader, ni downloader.
La cnx au serveur ftp de free, c'est faites hors du lan, et cela a
fonctionner. Le probleme est donc du coté de ma liveBox, ou de mon IIS.
Voici le log de la connexion avec FileZilla FTP
///////////////////////////////////////////////
Etat : Connexion à toto.com ...
Etat : Connecté à toto.com. Attente du message d'accueil...
Réponse : 220-Microsoft FTP Service
Réponse : toto.com
Réponse : 220 Domaine FTP
Commande : USER toto_gil_ftp
Réponse : 331 Password required for toto_gil_ftp.
Commande : PASS *************
Réponse : 230-Bonjour, toto.com est heureux de vous accueillir.
Réponse : 230 User toto_gil_ftp logged in.
Commande : SYST
Réponse : 215 Windows_NT
Commande : FEAT
Réponse : 500 'FEAT': command not understood
Etat : Connecté
Etat : Récupération de la liste de répertoires...
Commande : PWD
Réponse : 257 "/" is current directory.
Commande : TYPE A
Réponse : 200 Type set to A.
Commande : PASV
Réponse : 227 Entering Passive Mode (aaa,bbb,ccc,ddd,4,112).
Commande : LIST
Réponse : 425 Can't open data connection.
Erreur : N'a pas pu récupérer la liste du répertoire
Commande : TYPE I
Réponse : 200 Type set to I.
Commande : PWD
Réponse : 257 "/" is current directory.
Commande : TYPE I
Réponse : 200 Type set to I.
//////////////////////////////////////////////////

Question
la ligne "Réponse : 227 Entering Passive Mode
(aaa,bbb,ccc,ddd,4,112)."
le 4 et le 112 signifie quoi ?(sachant que les aaa,bbb,...corespondent
a l'ip du serveur)

merci
smk
Le #11346091
>>>> smk wrote:
Bonjour

J'ai encore des soucis avec mon serveur FTP de IIS sous wxp pro

En fait, je m'en était pas rencu compte, mais je me connecte tres bien
depuis les pc du lan.
Mais qd je suis a l'exterieur, via une carte Orange (PCMCIA) qui fait
office de modem.
J'ai bien acces a internet, et ma connexion FTP sur mon serveur(qui
tourne) se fait.
Mais impossible de recuperer un fichier du serveur vers le portable.
il me dit "le serveur ne repond pas" (logiciel ftp expert)
meme une connexion via l'eplorateur windows, ne fonctionne pas, et là
c'est pire puisque je ne peux meme
pas voir le contenu des dossier, puis erreur : connexion impossible,
mes identifiants de connexions sont bons. Qd je tap des identifiants
erronés, j'ai un message explicite, correspondant.

Merci d'avance pour vos suggestions



Bonjour,
Merci de préciser si c'est en mode actif ou passif, ou les deux.;-)
Un bon moyen de tester et déliminer la partie 'cliente' (le poste qui
essaye de se connecter) est de se servir d'un serveur FTP 'de
référence', tel celui de free ftp://ftp.free.fr et d'essayer de s'y
connecter en mode anonyme (anonymous et )
Si on peut s'y connecter et faire un ls du repertoire, la partie
cliente est bonne, il faudra se concentrer sur la partie serveur FTP.

Visiblement dans ton cas, c'est la connection Data qui ne passe pas
Si c'est en mode actif, faire un trou de sécurité dans le parefeu de la
livebox en forwardant tout ce qui est en provenance de n'importe qui
depuis le port 20 (si c'est possible, je n'ai pas de livebox sous les
yeux)

Si c'est en mode passif, il faut forwarder tous les ports source > 1024
vers les m^me ports sur le serveur. (je ne pense pas que ce soit
possible avec une livebox.

Enfin, regarder si dans la livebox, il n'y a pas au niveau firewall,
quelque chose de déja prévu pour des services bien connus, tel le http
ou le ftp. Si c'est le cas, enlever TOUTES tes règles manuelles
concernant ton serveur FTP, et juste selectionner FTP dans la liste des
services.

Allez, un peu de courage, c'est pas une 'boite vivante' qui va nous
embêter ...



Merci pour cette piste

Bonne FETE(qd meme)

Je viens de me connecter au serveur ftp://ftp.free.fr en anonymous,
et j'ai pu recuperer un fichier, de leur serveur vers mon ordi.
Je crois que le soucis c'est donc mon serveur ftp, sous IIS.
Cest peut etre ma LiveBox qui fait des siennes.

Pardon mais je sais pas comment "forwarder", ou
"faire un trou de sécurité"...
Des que je me connecte en dehors du





Du Lan j'imagine ?
Dernière astuce pour accélerer le dépannage: utiliser un client FTP qui
affiche le log de toutes les commandes et réponses, tel smartftp
www.smartftp.com, et qui supporte les deux modes FTP.
Eventuellement, poster ici le log correspondant à chaque mode, ça peut
aider à y voir plus clair.
Il est aussi possible de donner ton IP, ou le nom de domaine permettant
d'accèder à ton serveur FTP (sans compte utilisateur, juste un accès
anonyme à un repertoire contenant au moins un fichier).



Bonjour

Qd je me connecte du LAN, tout est Ok.
Qd je me connecte hors du LAN je peux rien uploader, ni downloader.
La cnx au serveur ftp de free, c'est faites hors du lan, et cela a
fonctionner. Le probleme est donc du coté de ma liveBox, ou de mon IIS.
Voici le log de la connexion avec FileZilla FTP
///////////////////////////////////////////////
Etat : Connexion à toto.com ...
Etat : Connecté à toto.com. Attente du message d'accueil...
Réponse : 220-Microsoft FTP Service
Réponse : toto.com
Réponse : 220 Domaine FTP
Commande : USER toto_gil_ftp
Réponse : 331 Password required for toto_gil_ftp.
Commande : PASS *************
Réponse : 230-Bonjour, toto.com est heureux de vous accueillir.
Réponse : 230 User toto_gil_ftp logged in.
Commande : SYST
Réponse : 215 Windows_NT
Commande : FEAT
Réponse : 500 'FEAT': command not understood
Etat : Connecté
Etat : Récupération de la liste de répertoires...
Commande : PWD
Réponse : 257 "/" is current directory.
Commande : TYPE A
Réponse : 200 Type set to A.
Commande : PASV
Réponse : 227 Entering Passive Mode (aaa,bbb,ccc,ddd,4,112).
Commande : LIST
Réponse : 425 Can't open data connection.
Erreur : N'a pas pu récupérer la liste du répertoire
Commande : TYPE I
Réponse : 200 Type set to I.
Commande : PWD
Réponse : 257 "/" is current directory.
Commande : TYPE I
Réponse : 200 Type set to I.
//////////////////////////////////////////////////

Question
la ligne "Réponse : 227 Entering Passive Mode (aaa,bbb,ccc,ddd,4,112)."
le 4 et le 112 signifie quoi ?(sachant que les aaa,bbb,...corespondent a
l'ip du serveur)

merci



Je viens de constater que le soucis est vraiment de la LiveBox
dans les parametrages du parefeu de cette derniere, si je passe en "minimum"
au lieu de "moyen"
C'est tout bon, je peu me connecter du LAN et de "l'exterieur" sans probleme
avec 100% des possibilités
mais pour le moment je sais pas trop c'est qoui la difference entre ces 2
modes.
Des que j'ai l'info, je vous tiens informé

Au plaisir
jbongran
Le #11346071
"smk"
[...]
Commande : PASV
Réponse : 227 Entering Passive Mode (aaa,bbb,ccc,ddd,4,112).


[...]
Question
la ligne "Réponse : 227 Entering Passive Mode (aaa,bbb,ccc,ddd,4,112)."
le 4 et le 112 signifie quoi ?(sachant que les aaa,bbb,...corespondent a
l'ip du serveur)

merci


aaa.bbb.ccc.ddd => doit être l'IP publique du serveur FTP (donc pas celle du
lan)
4, 112 correspond au port tcp sur lequel le serveur attend la connexion du
client, pour connaitre le port tcp, il faut faire un peu de calcul
(mental?):
(4*256)+112 = 1136
Ps: je précise tcp car je suis tombé sur au moins un "tuto" qui faisait
ouvrir les ports 20 et 21 (déja le port 20, ça fache) mais en plus en tcp ET
en udp.
jbongran
Le #11346061
"smk" eZlx%
[...]
Je viens de constater que le soucis est vraiment de la LiveBox
dans les parametrages du parefeu de cette derniere, si je passe en
"minimum" au lieu de "moyen"
C'est tout bon, je peu me connecter du LAN et de "l'exterieur" sans
probleme
avec 100% des possibilités
mais pour le moment je sais pas trop c'est qoui la difference entre ces 2
modes.
Des que j'ai l'info, je vous tiens informé

Au plaisir



Moyen ça bloque tout en entrée (donc depuis internet)
Elevé ça bloque tout en entrée et en sortie
Minimum ça bloque .... logiquement rien ! (ou peut être que ça ne bloque
qu'en entrée vers la livebox elle même, va savoir)
Personnalisé,
http://www.orange.fr/bin/frame.cgi?u=http://assistance.orange.fr/1354.php

Peux tu nous indiquer si il s'agit d'une inventel ou d'une Sagem ?
smk
Le #11346041
> "smk" eZlx%
[...]
Je viens de constater que le soucis est vraiment de la LiveBox
dans les parametrages du parefeu de cette derniere, si je passe en
"minimum" au lieu de "moyen"
C'est tout bon, je peu me connecter du LAN et de "l'exterieur" sans
probleme
avec 100% des possibilités
mais pour le moment je sais pas trop c'est qoui la difference entre ces 2
modes.
Des que j'ai l'info, je vous tiens informé

Au plaisir



Moyen ça bloque tout en entrée (donc depuis internet)
Elevé ça bloque tout en entrée et en sortie
Minimum ça bloque .... logiquement rien ! (ou peut être que ça ne bloque
qu'en entrée vers la livebox elle même, va savoir)
Personnalisé,
http://www.orange.fr/bin/frame.cgi?u=http://assistance.orange.fr/1354.php

Peux tu nous indiquer si il s'agit d'une inventel ou d'une Sagem ?



Oui c'est une Inventel.
Sur le site Orange, je ne trouve rien de vraiment precis sur le parametrage
du parefeu de cette LB...
jbongran
Le #11346031
smk wrote:
"smk" eZlx%
[...]
Je viens de constater que le soucis est vraiment de la LiveBox
dans les parametrages du parefeu de cette derniere, si je passe en
"minimum" au lieu de "moyen"
C'est tout bon, je peu me connecter du LAN et de "l'exterieur" sans
probleme
avec 100% des possibilités
mais pour le moment je sais pas trop c'est qoui la difference entre
ces 2 modes.
Des que j'ai l'info, je vous tiens informé

Au plaisir



Moyen ça bloque tout en entrée (donc depuis internet)
Elevé ça bloque tout en entrée et en sortie
Minimum ça bloque .... logiquement rien ! (ou peut être que ça ne
bloque qu'en entrée vers la livebox elle même, va savoir)
Personnalisé,
http://www.orange.fr/bin/frame.cgi?u=http://assistance.orange.fr/1354.php

Peux tu nous indiquer si il s'agit d'une inventel ou d'une Sagem ?



Oui c'est une Inventel.
Sur le site Orange, je ne trouve rien de vraiment precis sur le
parametrage du parefeu de cette LB...



Incroyable !
Rien, Nada, peau de balle en ce qui concerne la doc pour les livebox sur le
site d'Orange.
Quelle misère !
Enfin, grâce à glouglou, j'ai déniché ça:
http://jean.luc.coulon.free.fr/livebox/manuel_inventel.pdf

Pour ton souci, bien lire à partir de la page 69, et particulièrement la 73.
Ps: il semblerait qu'il faille mettre le parefeu sur 'minimum'
(avertissement en rouge page 70)
Publicité
Poster une réponse
Anonyme