Fwd: Re: [testing] mise à jour xorg

Le
Vivien Barousse
Bonjour,

Concernant les paquets xserver-xorg-video-*, ils sont liés aux paquets de
xorg concerné car il s'agit de pilotes spécifiques à xorg. Concernant le
paquet dont tu parle, il peut très bien être utilisé en tant que pilote
graphique pour xorg, mais également pour les autres serveurs X. Imposer
xorg à l'installation de ce pilote serait imposer à l'utilisateur un
serveur X dont il n'a pas forcément envie. Par exemple, si tu installe
XFree86, tu peux avoir besoin du paquet du pilote sans avoir installé le
serveur xorg.

Concernant les liaisons matériel/logiciel (et vice-versa), nono à raison. Si
tu as du Nvidia, tu peux utiliser xorg, XFree86, ou tout autre serveur X
dont je ne connaîtrais pas le nom. Réciproquement, si tu installe xorg, tu
peux avoir une carte ATI, NVidia, Intel ou même SIS.

Ensuite, GNU/Linux te laisse toujours le choix, même sous Debian. Certes
elle a un contour. Certes XFCE suggère x-window-system-core. Cela dit, tu
peux compiler toi même un serveur X, que tu installeras sur ton système, et
installer les paquets de XFCE. Si x-window-system-core était en dépendance
de XFCE, tu serais obligé de compiler XFCE à la main, ou d'installer deux
serveurs X sur ta machine. D'où le principe de recommandation et de
non-dépendance. Question de choix ;)

Vivien Barousse

Gaëtan PERRIER wrote:

> Le Wed, 13 Jun 2007 07:11:16 +0200
> nono <nonodeb@tele2.fr> a écrit:
>
>> Le mardi 12 juin 2007 à 22:30 +0200, Gaëtan PERRIER a écrit :
>> > Bonsoir,
>> >
>> > Je viens de bien galérer avec la mise à jour d'aujourd'hui de xorg.
>> > N'ayant pas fait gaffe, je ne l'avais pas vu. Et bien sur comme le
>> > driver Nvidia n'a pas suivi la mise à jour de xorg au redémarrage
>> > suivant plus de serveur X. Je viens donc de m'amuser pendant 2 heures à
>> > revenir à la version précédente de xorg (rapatrier les anciens paquets
>> > et forcer l'ancienne version)! Ma question est donc comment se fait-il
>> > qu'il n'y ait pas de dépendance entre les paquets nvidia et xorg ce qui
>> > éviterait de foutre en l'air une machine lors des mise à jour de xorg
>> > non coordonnées avec celle des paquets nvidia?
>>
>> parce qu'il existe d'autres cartes (par exemple ATI)
>
> Oui et alors ? Les paquets xserver-xorg-video-xxx ont une dépendance sur
> le xorg auquel ils correspondent, je ne vois donc pas pourquoi le pilote
> nvidia n'aurait pas lui aussi une dépendance ce qui empêcherait que xorg
> se mettent à jour sans qu'une version correspondante du pilote nvidia,
> ati, toto, etc. ne soit présente, non ?
>
>>
>> le matériel n'est pas lié a un logiciel et vice-versa.
>
> Alors là tu me permettras de n'être pas d'accord ! Ou alors je n'ai pas
> compris ce que tu veux dire ?
>
>>
>> C'est pareil quand tu installes XFCE, xserver-xorg n'est pas une
>> dépendance parce qu'il n'existe pas que xorg (il y a d'autres serveurs
>> x). GNU/Linux te laisse le choix.
>
> GNU/Linux oui mais là je parle de la distri Debian qui a un certains
> contour. D'ailleurs xfce suggère x-window-system-core
>
> Gaëtan
>
>


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Tiago Saboga
Le #9790481
On Thu, Jun 14, 2007 at 08:01:56AM +0200, Vivien Barousse wrote:
elle a un contour. Certes XFCE suggère x-window-system-core. Cela dit, tu
peux compiler toi même un serveur X, que tu installeras sur ton système, et
installer les paquets de XFCE. Si x-window-system-core était en dépendance
de XFCE, tu serais obligé de compiler XFCE à la main, ou d'installer deux
serveurs X sur ta machine. D'où le principe de recommandation et de
non-dépendance. Question de choix ;)



Pas nécessairement. Le principe des dépendances c'est de dire: si xfce
par exemple ne marche qu'avec un système X11 (qu'il soit XFree86, Xorg
ou n'importe quel autre) il doit avoir une dépendance. Si je compile
moi-même un serveur X11 et je l'installe à la main, le paquet equivs
sert exactement à dire à apt: je n'ai pas le paquet debian de xorg
d'installé, mais fais-moi confiance, j'ai quelque chose d'équivalent.
Si xfce ne dépend pas de xorg, ce n'est pas pour laisser le choix (ou
alors les dépendances n'existeraient jamais), mais simplement parce
que xorg n'est pas nécessaire: il doit être possible de tourner xfce
sans X (par exemple avec un serveur X sur une autre machine).

Le mardi 12 juin 2007 à 22:30 +0200, Gaëtan PERRIER a écrit :
Ma question est donc comment se fait-il
qu'il n'y ait pas de dépendance entre les paquets nvidia et xorg ce qui
éviterait de foutre en l'air une machine lors des mise à jour de xorg
non coordonnées avec celle des paquets nvidia?



Le paquet nvidia-glx dépend bien de x11-common, le problème est autre
part. D'après ce que tu dis (je n'en ai pas encore fait l'essai) le
driver nvidia ne marche pas sur la dernière version de xorg (7.2).
Mais les responsables du paquet nvidia ne pouvaient pas le savoir à
l'avance, et nvidia-glx dépend donc de x11-common >= 7.0.0 .

Tiago Saboga.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
FauSer17
Le #9790421
Tiago Saboga a écrit :
On Thu, Jun 14, 2007 at 08:01:56AM +0200, Vivien Barousse wrote:
elle a un contour. Certes XFCE suggère x-window-system-core. Cela dit, tu
peux compiler toi même un serveur X, que tu installeras sur ton système, et
installer les paquets de XFCE. Si x-window-system-core était en dépendance
de XFCE, tu serais obligé de compiler XFCE à la main, ou d'installer deux
serveurs X sur ta machine. D'où le principe de recommandation et de
non-dépendance. Question de choix ;)



Pas nécessairement. Le principe des dépendances c'est de dire: si xfce
par exemple ne marche qu'avec un système X11 (qu'il soit XFree86, Xorg
ou n'importe quel autre) il doit avoir une dépendance. Si je compile
moi-même un serveur X11 et je l'installe à la main, le paquet equivs
sert exactement à dire à apt: je n'ai pas le paquet debian de xorg
d'installé, mais fais-moi confiance, j'ai quelque chose d'équivalent.
Si xfce ne dépend pas de xorg, ce n'est pas pour laisser le choix (ou
alors les dépendances n'existeraient jamais), mais simplement parce
que xorg n'est pas nécessaire: il doit être possible de tourner xfce
sans X (par exemple avec un serveur X sur une autre machine).

Le mardi 12 juin 2007 à 22:30 +0200, Gaëtan PERRIER a écrit :
Ma question est donc comment se fait-il
qu'il n'y ait pas de dépendance entre les paquets nvidia et xorg ce qui
éviterait de foutre en l'air une machine lors des mise à jour de xorg
non coordonnées avec celle des paquets nvidia?



Le paquet nvidia-glx dépend bien de x11-common, le problème est autre
part. D'après ce que tu dis (je n'en ai pas encore fait l'essai) le
driver nvidia ne marche pas sur la dernière version de xorg (7.2).
Mais les responsables du paquet nvidia ne pouvaient pas le savoir à
l'avance, et nvidia-glx dépend donc de x11-common >= 7.0.0 .

Tiago Saboga.




Cela fait maintenant plus d'un mois que j'essaie d'installer le pilote
nvidia sans succès quelque soit la méthode.Je suis sous SID, noyau
2.6.21-1-686. .Le problème semble provenir de la Glib? De toutes façons
il n'y a apparemment pas de possibilités d'installer nvidia-glx qui est
indispensable.
Si qq'un a des infos j'aimerai bien car ce pilote me manque,nv me décale
l'écran quand je passe de windows à Debian. Il me faut chaque fois
régler le moniteur.
Fauser17


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Txo
Le #9790411
En ce jeudi 14 juin 2007 à 18:43:33 FauSer17 nous susurrait :

Cela fait maintenant plus d'un mois que j'essaie d'installer le pilote
nvidia sans succès quelque soit la méthode.Je suis sous SID, no yau
2.6.21-1-686. .Le problème semble provenir de la Glib? De toutes fa çons
il n'y a apparemment pas de possibilités d'installer nvidia-glx qui est
indispensable.
Si qq'un a des infos j'aimerai bien car ce pilote me manque,nv me dé cale
l'écran quand je passe de windows à Debian. Il me faut chaqu e fois
régler le moniteur.




Ça ne répondra pas peut être au problème car j'utilise Lenny. Quand
j'ai voulu réinstaller le pilote Nvidia pour récupérer les a pplications
avec de l'Opengl après la mise à jour d'Xorg dans les dépà ´ts Debian,
j'ai perdu l'interface graphique. Il m'a suffit de télécharger la
dernière version du pilote Nvidia pour que ça compile bien et ret rouver
X.

--
-+- Dominique Marin http://txodom.free.fr -+-
- Combien d'économistes libéraux faut-il pour changer une ampoule ?
- Aucun. Si le gouvernement la laissait en paix, l'ampoule se
-+- revisserait toute seule. -+-
Gaëtan PERRIER
Le #9790341
Le Thu, 14 Jun 2007 08:01:56 +0200
Vivien Barousse
Bonjour,

Concernant les paquets xserver-xorg-video-*, ils sont liés aux paquets de
xorg concerné car il s'agit de pilotes spécifiques à xorg. Concernant le
paquet dont tu parle, il peut très bien être utilisé en tant que pilote
graphique pour xorg, mais également pour les autres serveurs X. Imposer
xorg à l'installation de ce pilote serait imposer à l'utilisateur un
serveur X dont il n'a pas forcément envie.



Pourtant xorg impose l'installation de xserver-xorg-video-all et donc de tous
un tas de pilote dont l'utilisateur n'a pas forcément besoin!
Mais de toute façon ce n'est la dépendance dans ce sens qui manquerait mais
dans l'autre: paquet nvidia dépend de xorg < x.xx j'ai l'impression.

Par exemple, si tu installe
XFree86, tu peux avoir besoin du paquet du pilote sans avoir installé le
serveur xorg.



Je doute que ça fonctionne avec XFree vu les chemins d'installation de
nvidia-glx (/usr/lib/xorg). De plus Xfree n'est plus dans testing il n'y a
donc rien de choquant à ce que la dépendance se fasse sur xorg. Mais on peut
aussi mettre xorg | xfree | ..., non?


Concernant les liaisons matériel/logiciel (et vice-versa), nono à raison. Si
tu as du Nvidia, tu peux utiliser xorg, XFree86, ou tout autre serveur X
dont je ne connaîtrais pas le nom. Réciproquement, si tu installe xorg, tu
peux avoir une carte ATI, NVidia, Intel ou même SIS.



Dans ce cas précis je suis d'accord mais sa phrase me semblait bien plus
générique.


Ensuite, GNU/Linux te laisse toujours le choix, même sous Debian. Certes
elle a un contour. Certes XFCE suggère x-window-system-core. Cela dit, tu
peux compiler toi même un serveur X, que tu installeras sur ton système, et
installer les paquets de XFCE. Si x-window-system-core était en dépendance
de XFCE, tu serais obligé de compiler XFCE à la main, ou d'installer deux
serveurs X sur ta machine. D'où le principe de recommandation et de
non-dépendance. Question de choix ;)



Tu peux aussi faire un meta paquet qui t'évite le problème de dépendance ou
mettre en paquet le serveur X que tu as compilé.

Gaëtan


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Gaëtan PERRIER
Le #9790351
Le Thu, 14 Jun 2007 09:14:19 -0300
Tiago Saboga

Le paquet nvidia-glx dépend bien de x11-common, le problème est autre
part. D'après ce que tu dis (je n'en ai pas encore fait l'essai) le
driver nvidia ne marche pas sur la dernière version de xorg (7.2).
Mais les responsables du paquet nvidia ne pouvaient pas le savoir à
l'avance, et nvidia-glx dépend donc de x11-common >= 7.0.0 .



D'ailleurs ça doit correspondre au bug #420177, non?

Gaëtan


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Gaëtan PERRIER
Le #9790331
Le Thu, 14 Jun 2007 09:14:19 -0300
Tiago Saboga
Le paquet nvidia-glx dépend bien de x11-common, le problème est autre
part. D'après ce que tu dis (je n'en ai pas encore fait l'essai) le
driver nvidia ne marche pas sur la dernière version de xorg (7.2).
Mais les responsables du paquet nvidia ne pouvaient pas le savoir à
l'avance, et nvidia-glx dépend donc de x11-common >= 7.0.0 .



Effectivement le problème doit venir d'ici!

Gaëtan


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme