Ne garder qu'un seul doublon avec une formule

Le
michir
Bonjour à tous,
Voilà, soit un tableau à 2 colonnes, une colonne de noms dont
plusieurs sont en en doublon et une colonne d'indemnités de 8,00€
systématiquement.
Je souhaiterais que n'apparaisse qu''une seule fois l' indemnité pour
un nom donné, dans la colonne indemnités.
Ceci serait parfait si cela pouvait s'obtenir par une formule

Je joins un fichier exemple, en espérant avoir été suffisamment clair

http://cjoint.com/?0boi5rYO8eK

Merci à tous,

Michel
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #23021591
bonjour Michel,

peut tu mettre une version xl2003 ou moins

isabelle

Le 2011-01-14 03:00, michir a écrit :
Bonjour à tous,
Voilà, soit un tableau à 2 colonnes, une colonne de noms dont
plusieurs sont en en doublon et une colonne d'indemnités de 8,00€
systématiquement.
Je souhaiterais que n'apparaisse qu''une seule fois l' indemnité pour
un nom donné, dans la colonne indemnités.
Ceci serait parfait si cela pouvait s'obtenir par une formule

Je joins un fichier exemple, en espérant avoir été suffisamment clair

http://cjoint.com/?0boi5rYO8eK

Merci à tous,

Michel
michir
Le #23021921
On 14 jan, 17:00, isabelle
bonjour Michel,

peut tu mettre une version xl2003 ou moins

isabelle

Le 2011-01-14 03:00, michir a écrit :







> Bonjour à tous,
> Voilà, soit un tableau à 2 colonnes, une colonne de noms dont
> plusieurs sont en en doublon et une colonne d'indemnités de 8,00€
> systématiquement.
> Je souhaiterais que n'apparaisse qu''une seule fois l' indemnité pour
> un nom donné, dans la colonne indemnités.
> Ceci serait parfait si cela pouvait s'obtenir par une formule

> Je joins un fichier exemple, en espérant avoir été suffisamment c lair

>http://cjoint.com/?0boi5rYO8eK

> Merci à tous,

> Michel



Bonjour Isabelle,
Merci pour ton message.
Je te joins mon fichier exemple enregistré sous une version compatible
avec Excel 2003
http://cjoint.com/?0bosmVeNbme
Merci
isabelle
Le #23022141
bonjour Michel,

=SI(NB.SI($B$4:$B4;B4)>1;"";INDEX(Indemnité;EQUIV(E4;Noms;0)))

isabelle

Le 2011-01-14 12:14, michir a écrit :
On 14 jan, 17:00, isabelle
bonjour Michel,

peut tu mettre une version xl2003 ou moins

isabelle

Le 2011-01-14 03:00, michir a écrit :







Bonjour à tous,
Voilà, soit un tableau à 2 colonnes, une colonne de noms dont
plusieurs sont en en doublon et une colonne d'indemnités de 8,00€
systématiquement.
Je souhaiterais que n'apparaisse qu''une seule fois l' indemnité pour
un nom donné, dans la colonne indemnités.
Ceci serait parfait si cela pouvait s'obtenir par une formule



Je joins un fichier exemple, en espérant avoir été suffisamment clair



http://cjoint.com/?0boi5rYO8eK



Merci à tous,



Michel





Bonjour Isabelle,
Merci pour ton message.
Je te joins mon fichier exemple enregistré sous une version compatible
avec Excel 2003
http://cjoint.com/?0bosmVeNbme
Merci
Jacky
Le #23022411
Bonsoir,

=SI(NB.SI($B$4:$B4;B4)=1;$G$1;"")
ou
=SI(NB.SI($B$4:$B4;B4)=1;8;"")

Ton classeur
http://www.cijoint.fr/cjlink.php?file=cj201101/cijKMFcSYt.xls
--
Salutations
JJ


"michir"
On 14 jan, 17:00, isabelle
bonjour Michel,

peut tu mettre une version xl2003 ou moins

isabelle

Le 2011-01-14 03:00, michir a écrit :







> Bonjour à tous,
> Voilà, soit un tableau à 2 colonnes, une colonne de noms dont
> plusieurs sont en en doublon et une colonne d'indemnités de 8,00€
> systématiquement.
> Je souhaiterais que n'apparaisse qu''une seule fois l' indemnité pour
> un nom donné, dans la colonne indemnités.
> Ceci serait parfait si cela pouvait s'obtenir par une formule

> Je joins un fichier exemple, en espérant avoir été suffisamment clair

>http://cjoint.com/?0boi5rYO8eK

> Merci à tous,

> Michel



Bonjour Isabelle,
Merci pour ton message.
Je te joins mon fichier exemple enregistré sous une version compatible
avec Excel 2003
http://cjoint.com/?0bosmVeNbme
Merci
michir
Le #23022401
On 14 jan, 18:49, isabelle
bonjour Michel,

=SI(NB.SI($B$4:$B4;B4)>1;"";INDEX(Indemnité;EQUIV(E4;Noms;0)))

isabelle

Le 2011-01-14 12:14, michir a écrit :







> On 14 jan, 17:00, isabelle >> bonjour Michel,

>> peut tu mettre une version xl2003 ou moins

>> isabelle

>> Le 2011-01-14 03:00, michir a écrit :

>>> Bonjour à tous,
>>> Voilà, soit un tableau à 2 colonnes, une colonne de noms dont
>>> plusieurs sont en en doublon et une colonne d'indemnités de 8,00€
>>> systématiquement.
>>> Je souhaiterais que n'apparaisse qu''une seule fois l' indemnité po ur
>>> un nom donné, dans la colonne indemnités.
>>> Ceci serait parfait si cela pouvait s'obtenir par une formule

>>> Je joins un fichier exemple, en espérant avoir été suffisamment clair

>>>http://cjoint.com/?0boi5rYO8eK

>>> Merci à tous,

>>> Michel

> Bonjour Isabelle,
> Merci pour ton message.
> Je te joins mon fichier exemple enregistré sous une version compatibl e
> avec Excel 2003
>http://cjoint.com/?0bosmVeNbme
> Merci



Isabelle
Merci beaucoup pour ton aide. Toutefois je veux raisonner sur le seul
tableau (B4:C16)
L'indemnité est constante et je peux en faire une référence à part
dans une cellule hors du tableau
Vois tu comment faire pour placer une formule (sans référence
circulaire en colonne C) ?
Merci à toi
Michel
isabelle
Le #23022531
alors,

=SI(NB.SI($B$4:$B4;B4)>1;"";8)

isabelle

Le 2011-01-14 15:00, michir a écrit :
On 14 jan, 18:49, isabelle
bonjour Michel,

=SI(NB.SI($B$4:$B4;B4)>1;"";INDEX(Indemnité;EQUIV(E4;Noms;0)))

isabelle

Le 2011-01-14 12:14, michir a écrit :



Isabelle
Merci beaucoup pour ton aide. Toutefois je veux raisonner sur le seul
tableau (B4:C16)
L'indemnité est constante et je peux en faire une référence à part
dans une cellule hors du tableau
Vois tu comment faire pour placer une formule (sans référence
circulaire en colonne C) ?
Merci à toi
Michel

michir
Le #23023311
On 14 jan, 21:05, isabelle
alors,

=SI(NB.SI($B$4:$B4;B4)>1;"";8)

isabelle

Le 2011-01-14 15:00, michir a crit :







> On 14 jan, 18:49, isabelle >> bonjour Michel,

>> =SI(NB.SI($B$4:$B4;B4)>1;"";INDEX(Indemnit ;EQUIV(E4;Noms;0)))

>> isabelle

>> Le 2011-01-14 12:14, michir a crit :
> Isabelle
> Merci beaucoup pour ton aide. Toutefois je veux raisonner sur le seul
> tableau (B4:C16)
> L'indemnit est constante et je peux en faire une r f rence part
> dans une cellule hors du tableau
> Vois tu comment faire pour placer une formule (sans r f rence
> circulaire en colonne C) ?
> Merci toi
> Michel



Merci à vous deux Isabelle et Jacky, cela fonctionne parfaitement bien
Michel
Publicité
Poster une réponse
Anonyme