Gdm etch ne démarre plus tout seul.

Le
Sil
Bonjour à tous,
Depuis quelques jours le script gdm de mon portable sous etch est incatif.
/etc/init.d/gdm start est inopérant.
Au démarrage c'est pareil la ligne apparait bien au lancement des
services mais X ne démarre pas.
Je suis obligé de me loguer sous root et de lancer :
# gdm && logout
La X démarre et j'arrive au login gdm.

Le script test bien là :
~$ ls -lha /etc/init.d/gdm
-rwxr-xr-x 1 root root 2,1K 2007-12-01 19:37 /etc/init.d/gdm

Mes log ne sont pas bavards et je n'ai pas de messages sur la console.
Je pensait que certains auraient eu le même problème, mais apparement non.
J'ai reinstallé gdm mais sans que cela ne change rien.
La googlisation ne donne rien non plus.

Quelqu'un aurait une petite piste.
Merci d'avance
Silvère Maugain


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Thierry Leurent
Le #9716031
Bonjour,

Je n'utilise pas GDM mais je vais essayer de t'aider.
Dans une console, affiches le code de /etc/init.d/gdm et essaies de le
parcourir. Regardes ce qui ressemble à des fichiers et utilises une secon de
console pour vérifier leur présence.
Je pense à un fichier qui n'existerait pas ou aurait été deplacé.
On Saturday 16 February 2008 19:42:03 Sil wrote:
Bonjour à tous,
Depuis quelques jours le script gdm de mon portable sous etch est incatif.
/etc/init.d/gdm start est inopérant.
Au démarrage c'est pareil la ligne apparait bien au lancement des
services mais X ne démarre pas.
Je suis obligé de me loguer sous root et de lancer :
# gdm && logout
La X démarre et j'arrive au login gdm.

Le script test bien là :
~$ ls -lha /etc/init.d/gdm
-rwxr-xr-x 1 root root 2,1K 2007-12-01 19:37 /etc/init.d/gdm

Mes log ne sont pas bavards et je n'ai pas de messages sur la console.
Je pensait que certains auraient eu le même problème, mais apparement non.
J'ai reinstallé gdm mais sans que cela ne change rien.
La googlisation ne donne rien non plus.

Quelqu'un aurait une petite piste.
Merci d'avance
Silvère Maugain





--
Thierry Leurent
Milou
Le #9715931
Le Sat, 16 Feb 2008 19:42:03 +0100
Sil à écrit:

Bonjour à tous,



Bonjour

Depuis quelques jours le script gdm de mon portable sous etch est incatif.
/etc/init.d/gdm start est inopérant.
Au démarrage c'est pareil la ligne apparait bien au lancement des
services mais X ne démarre pas.
Je suis obligé de me loguer sous root et de lancer :
# gdm && logout
La X démarre et j'arrive au login gdm.

Le script test bien là :
~$ ls -lha /etc/init.d/gdm
-rwxr-xr-x 1 root root 2,1K 2007-12-01 19:37 /etc/init.d/gdm

Mes log ne sont pas bavards et je n'ai pas de messages sur la console.
Je pensait que certains auraient eu le même problème, mais apparement non.
J'ai reinstallé gdm mais sans que cela ne change rien.
La googlisation ne donne rien non plus.



J'ai le même pb sur un portable en sid depuis une maj, je n'ai pas de
solution, mais je peux ajouter que xdm me fait pareil que gdm, et que
tout ceci me semblait venir de la nouvelle façon de configurer
automatiquement xorg... Mais après avoir installé xdebconfigurator, mon
X remarche avec un "startx" mais ni gdm ni xdm ne veulent fonctionner...

mil
--
C'est par accident que celui qui creuse la fosse trouve un trésor car
l'un de ces faits n'est ni la conséquence de l'autre, et il n'est pas
constant qu'en plantant un arbre on trouve un trésor.
-+- Aristote, Métaphysique Delta, 30 -+-
Sil
Le #9715911
Milou a écrit :
Le Sat, 16 Feb 2008 19:42:03 +0100
Sil à écrit:


J'ai le même pb sur un portable en sid depuis une maj, je n'ai pas de
solution, mais je peux ajouter que xdm me fait pareil que gdm, et que
tout ceci me semblait venir de la nouvelle façon de configurer
automatiquement xorg... Mais après avoir installé xdebconfigurator, mon
X remarche avec un "startx" mais ni gdm ni xdm ne veulent fonctionner...


Bonjour,
J'ai fait une grossière erreur dans le titre de mon post, mon portable est en testing donc "lenny".
J'ai mi à jour le titre du post, désolé.
Sil


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sil
Le #9715901
Thierry Leurent a écrit :
Je n'utilise pas GDM mais je vais essayer de t'aider.
Dans une console, affiches le code de /etc/init.d/gdm et essaies de le
parcourir. Regardes ce qui ressemble à des fichiers et utilises une seconde
console pour vérifier leur présence.
Je pense à un fichier qui n'existerait pas ou aurait été deplacé.




Bonjour,
J'ai cherché et la seule différebce que j'ai pu trouver est dans le
fichier /etc/X11/default-display-manager
Il contenait /usr/bin/gdm alors qu'il est situé dans /usr/sbin/
J'ai modifié le fichier mais ça ne change rien.
Je continue...

J'ai remarqué autre chose : le script ne fait jamais de retour chariot,
il n'a pas l'air de bien se finir.

:~$ sudo /etc/init.d/gdm start
Starting GNOME Display Manager: :~$

Je ne pense pas qu'il y ai moyen d'augmenter la verbosité du script pour
controler son execution.

Sil


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Frédéric Moinard
Le #9713181
Bonjour,

Sil a écrit :
Milou a écrit :
Le Sat, 16 Feb 2008 19:42:03 +0100
Sil à écrit:

J'ai le même pb sur un portable en sid depuis une maj, je n'ai pas de
solution, mais je peux ajouter que xdm me fait pareil que gdm, et que
tout ceci me semblait venir de la nouvelle façon de configurer
automatiquement xorg... Mais après avoir installé xdebconfigurator, mon
X remarche avec un "startx" mais ni gdm ni xdm ne veulent fonctionner...


Bonjour,
J'ai fait une grossière erreur dans le titre de mon post, mon portable
est en testing donc "lenny".
J'ai mi à jour le titre du post, désolé.
Sil



Sur une unstable, j'ai eu ce genre de pb il y a quelques temps... pistes:
- le bug 454097 de gdm (vérifier /etc/profile /root/.bashrc etc)
- dans mon cas: commenter la ligne 42 de /etc/init.d/gdm :
(...)
# log_daemon_msg "Starting GNOME Display Manager" "gdm"
a suffit...

--
hth,

Frédéric Moinard

--
ps: je n'ai pas tout compris, mais j'ai trouvé ces solutions avec
reportbug-ng ;-)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sil
Le #9710421
Frédéric Moinard a écrit :
Sur une unstable, j'ai eu ce genre de pb il y a quelques temps... pistes:
- le bug 454097 de gdm (vérifier /etc/profile /root/.bashrc etc)
- dans mon cas: commenter la ligne 42 de /etc/init.d/gdm :
(...)
# log_daemon_msg "Starting GNOME Display Manager" "gdm"
a suffit...


Bonjour,
Je suis un peu en retard pour donner des nouvelles, mais hier soir je
n'ai même pas allumé le portable.

J'ai commenté la ligne 42 et ça marche chez moi aussi.
Merci.

J'ai regardé le post sur le bug mais je n'ai pas tout compris.

@+
Sil


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sylvain Sauvage
Le #9710321
Sil, mercredi 20 février 2008, 22:02:30 CET
[…]
J'ai commenté la ligne 42 et ça marche chez moi aussi.



« 42 », c’était évident que c†™Ã©tait _la_ réponse…

--
Sylvain Sauvage
Jean-Yves F. Barbier
Le #9710301
Sylvain Sauvage a écrit :
Sil, mercredi 20 février 2008, 22:02:30 CET
[...]
J'ai commenté la ligne 42 et ça marche chez moi aussi.



« 42 », c'était évident que c'était _la_ réponse...



arf, j'ai bien mis une bonne minute pour me rappeler pourquoi:)

--
All generalisations are dangerous, including this one.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Fabien Dubois
Le #9710261
>>
« 42 », c'était évident que c'était _la_ réponse...



arf, j'ai bien mis une bonne minute pour me rappeler pourquoi:)



ben oui, à cause des souris.

--
#
# Powered by GNU/Linux Debian Sid & Icedove
# Libérez votre ordinateur de l'oppression capitaliste,
# utilisez les logiciels libres !
#



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Frédéric Moinard
Le #9710251
Bonjour,

Fabien Dubois a écrit :
« 42 », c'était évident que c'était _la_ réponse...


arf, j'ai bien mis une bonne minute pour me rappeler pourquoi:)



ben oui, à cause des souris.



ch'suis trop nul, j'avais même pas réalisé !

--
pff... c'est pas beau de vieillir ;)

F.M.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme