Geler les références VBA project

Le
xavier powaga
Bonjour à tous,
voilà ce qui m'amène, j'ai développé une petite applic VBA excel qui pour
fonctionner necessite quelques complément dont le complément Microsoft
office 9.0.
Ce programme passe de main en main car chacun l'enrichie avec un certain
nombre de données. Le problème c'est que si un de mes collègues utilise mon
programme sur un ordi ayant une version plus recente d'office (11.0) la
référence change automatiquement. cela ne pose pas vraiment de pb dans ce
sens là car il y a un compatibilité ascendante et le programme continue à
fontionner en ayant automatiquement remplacé le complément 9.0 par le
complément 11.0. Mais maintenant s'il decide d'utiliser à nouveau le
programme avec une version d'office plus ancienne, le programme se plante
car il ne trouve plus le complément office 11.0 et il ne le remplace pas
automatiquement par le complément 9.0.
Y a t'il une solution pour que pour programme puisse fonctionner quelque
soit les versions d'office

merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #4913601
bonjour xavier,

il faudrait ajouter une option pour cette version et peut être pour d'autres,

Select Case Val(Application.Version)
Case 8: action1 ' Office 97
Case 9: action2 ' Office 2000
Case 10: action3 ' Office 2002
End Select


isabelle


Bonjour à tous,
voilà ce qui m'amène, j'ai développé une petite applic VBA excel qui pour
fonctionner necessite quelques complément dont le complément Microsoft
office 9.0.
Ce programme passe de main en main car chacun l'enrichie avec un certain
nombre de données. Le problème c'est que si un de mes collègues utilise mon
programme sur un ordi ayant une version plus recente d'office (11.0) la
référence change automatiquement. cela ne pose pas vraiment de pb dans ce
sens là car il y a un compatibilité ascendante et le programme continue à
fontionner en ayant automatiquement remplacé le complément 9.0 par le
complément 11.0. Mais maintenant s'il decide d'utiliser à nouveau le
programme avec une version d'office plus ancienne, le programme se plante
car il ne trouve plus le complément office 11.0 et il ne le remplace pas
automatiquement par le complément 9.0.
Y a t'il une solution pour que pour programme puisse fonctionner quelque
soit les versions d'office

merci




LSteph
Le #4912721
Bonjour,

outre un WorkbookOpen et un select case il faudra sans doute, ensuite
connaître le chemin (fullpath) complet donc de cette référence que tu
veux invoquer par le code. C'est précisément , une question que je me
creusé depuis peu.Comment cocher une réf par le code...
Voici une méthode qui semble fonctionner:

Sub ajoutREfvbext()
With ThisWorkbook.VBProject.References
.AddFromFile "C:Program FilesFichiers communsMicrosoft
SharedVBAVBEEXT1.OLB"
End With
End Sub


Sinon à pour faire référence à référence il faut le déclarer mais pas
as Reference, ;o) car faut cocher VBextensibility et c'est précisément
ce que je recherchais.
En fin de compte on peut s'en passer en déclarant as object.
Mais le principe de AddFromFile est bon à connaître m^me s'il requiert
ce fâmeux chemin. Tu peux aussi utiliser addfromguide mais là il faut un
identifiant. Voir ici: http://www.excelabo.net/excel/macrosdiv.php

Cordialement.

lSteph

Bonjour à tous,
voilà ce qui m'amène, j'ai développé une petite applic VBA excel qui pour
fonctionner necessite quelques complément dont le complément Microsoft
office 9.0.
Ce programme passe de main en main car chacun l'enrichie avec un certain
nombre de données. Le problème c'est que si un de mes collègues utilise mon
programme sur un ordi ayant une version plus recente d'office (11.0) la
référence change automatiquement. cela ne pose pas vraiment de pb dans ce
sens là car il y a un compatibilité ascendante et le programme continue à
fontionner en ayant automatiquement remplacé le complément 9.0 par le
complément 11.0. Mais maintenant s'il decide d'utiliser à nouveau le
programme avec une version d'office plus ancienne, le programme se plante
car il ne trouve plus le complément office 11.0 et il ne le remplace pas
automatiquement par le complément 9.0.
Y a t'il une solution pour que pour programme puisse fonctionner quelque
soit les versions d'office

merci




Publicité
Poster une réponse
Anonyme