[gentoo-user-fr] [AMD64] sandbox

Le
Anthony
Bonjour,
J'ai un problème avec le package sandbox. Je suis sur amd64 et j'ai
installe la glibc- qui visiblement pose des problème de compatibilite.

Mais, meme le FEATURE=-sandbox emerge sandbox ne donne rien :-( J'ai
tenté le coup de le désinstaller. Même si tout marche bien, portage se
plein.

Quelqu'un aurait une idée ? J'ai pensé downgradé la glib, re-merge
sandbox, puis remettre la glib courante.

Quelqu'un a une idée ?

Anthony
--
gentoo-user-fr@lists.gentoo.org mailing list
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Anthony
Le #7801101
Didier Link a écrit :
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Le Thu, 17 Jan 2008 23:03:19 +0100,
Anthony

Bonjour,




Bonsoir Anthony,


J'ai un problème avec le package sandbox. Je suis sur amd64 et j'ai
installe la glibc-... qui visiblement pose des problème de
compatibilite.

Mais, meme le FEATURE=-sandbox emerge sandbox ne donne rien :-( J'ai
tenté le coup de le désinstaller. Même si tout marche bien, portage se
plein.

Quelqu'un aurait une idée ? J'ai pensé downgradé la glib, re-merge
sandbox, puis remettre la glib courante.

Quelqu'un a une idée ?




Tu pourrais nous donner les versions de ce qui est installé et de ce
que tu veux installer s'il te plaît ? Tu es en amd64 ou ~amd64 ??



Je suis en amd64 sauf pour wine, et quelques autres sans impact.
glibc est en version 2.6.1 et mon problème viens que j'ai voulu faire un
deep update newuse impliquant un changement de version de sandbox :-(

Sur les forums, j'ai trouve le problème de compatibilité cité plus haut.

Anthony
--
mailing list
Anthony
Le #7800991
Suite de mon problème :
Il semble que l'emerge sandbox cherche le compilateur :
i686-pc-linux-gnu-gcc
Quand je le lance au lieu du : "no input file" il me dit :
gcc-config error: i686-pc-linux-gnu-gcc wrapper: Could not determine
which compiler to use. Invalid CTARGET or CTARGET has no selected profile.

Quelqu'un à une idée de où modifier CTARGET ?

A+
Anthony
--
mailing list
Anthony
Le #7800981
Didier Link a écrit :
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Le Thu, 24 Jan 2008 00:12:20 +0100,
Anthony

Suite de mon problème :
Il semble que l'emerge sandbox cherche le compilateur :
i686-pc-linux-gnu-gcc
Quand je le lance au lieu du : "no input file" il me dit :
gcc-config error: i686-pc-linux-gnu-gcc wrapper: Could not determine
which compiler to use. Invalid CTARGET or CTARGET has no selected
profile.

Quelqu'un à une idée de où modifier CTARGET ?




Que te dis "gcc-config -l" éxécuté dans un shell en root ?



gcc-config -l
[1] x86_64-pc-linux-gnu-4.1.2


--
mailing list
Yoann Pannier
Le #7800971
Anthony wrote, On 2008-01-24 00:12 +0100:
Suite de mon problème :
Il semble que l'emerge sandbox cherche le compilateur :
i686-pc-linux-gnu-gcc
Quand je le lance au lieu du : "no input file" il me dit :
gcc-config error: i686-pc-linux-gnu-gcc wrapper: Could not determine
which compiler to use. Invalid CTARGET or CTARGET has no selected
profile.

Quelqu'un à une idée de où modifier CTARGET ?



Ca ne serait pas plutôt un problème de wrapper ?

https://bugs.gentoo.org/buglist.cgi?quicksearch=ALL+compiler+cannot+create+executables

--
Yoann Pannier
--
mailing list
Anthony Jaguenaud
Le #7800961
Yoann Pannier a écrit :
Anthony wrote, On 2008-01-24 00:12 +0100:

Suite de mon problème :
Il semble que l'emerge sandbox cherche le compilateur :
i686-pc-linux-gnu-gcc
Quand je le lance au lieu du : "no input file" il me dit :
gcc-config error: i686-pc-linux-gnu-gcc wrapper: Could not determine
which compiler to use. Invalid CTARGET or CTARGET has no selected
profile.

Quelqu'un à une idée de où modifier CTARGET ?




Ca ne serait pas plutôt un problème de wrapper ?

https://bugs.gentoo.org/buglist.cgi?quicksearch=ALL+compiler+cannot+create+executables



Résolu.
Les bugs indiqué sont parfois vieux, et pas de très bon conseil,
néanmoins, l'un d'entre eux m'a donné l'idée suivant.
Vérifier de quel paquet provenait le programme incriminé:
# equery b /usr/bin/i686-pc-linux-gnu-gcc
!!! Problem with sandbox binary. Disabling...

[ Searching for file(s) /usr/bin/i686-pc-linux-gnu-gcc in *... ]
# equery b /usr/bin/gcc
!!! Problem with sandbox binary. Disabling...

[ Searching for file(s) /usr/bin/gcc in *... ]
# equery b /usr/bin/gcc-4.1.2
!!! Problem with sandbox binary. Disabling...

[ Searching for file(s) /usr/bin/gcc-4.1.2 in *... ]
sys-devel/gcc-4.1.2 (/usr/bin/gcc-4.1.2 ->
/usr/x86_64-pc-linux-gnu/gcc-bin/4.1.2/x86_64-pc-linux-gnu-gcc)
# equery b /usr/x86_64-pc-linux-gnu/gcc-bin/4.1.2/x86_64-pc-linux-gnu-gcc
!!! Problem with sandbox binary. Disabling...

[ Searching for file(s)
/usr/x86_64-pc-linux-gnu/gcc-bin/4.1.2/x86_64-pc-linux-gnu-gcc in *... ]
sys-devel/gcc-4.1.2
(/usr/x86_64-pc-linux-gnu/gcc-bin/4.1.2/x86_64-pc-linux-gnu-gcc)
#

J'en ai déduit que le compilo i686* n'avait plus lieu d'être, j'ai
déplacé les fichier dans le homme root (histoire d'avoir une sauvegarde).
Puis, le emerge sandbox Ok.

Merci à tous
Anthony
--
mailing list
Publicité
Poster une réponse
Anonyme