[gentoo-user-fr] emerge xerces => portage_exception.InvalidAtom: >=app-crypt/gnupg-1.2*

Le
Pascal Ronecker
Bonjour la liste !

je suis en plein upgrade d'un systeme un peu vieillot, et c est au tour
de java.
Je suis le tuto : http://www.gentoo.org/proj/en/java/java-upgrade.xml

mais au ceck-environnement j'ai un message qui me dit que xerces-2
manque. J'essaie donc de l'installler mais un emerge-xerces me renoie
ceci (voir ci dessous).

Une idée pour me sortir du problème ?

merci !


Calculating dependencies Traceback (most recent call last):
File "/usr/bin/emerge", line 9205, in <module>
retval = emerge_main()
File "/usr/bin/emerge", line 9199, in emerge_main
myopts, myaction, myfiles, spinner)
File "/usr/bin/emerge", line 8460, in action_build
retval, favorites = mydepgraph.select_files(myfiles)
File "/usr/bin/emerge", line 2999, in select_files
self.altlist()
File "/usr/bin/emerge", line 3824, in altlist
self._resolve_conflicts()
File "/usr/bin/emerge", line 3836, in _resolve_conflicts
if not self._complete_graph():
File "/usr/bin/emerge", line 3479, in _complete_graph
if not self._create_graph(allow_unsatisfied=True):
File "/usr/bin/emerge", line 2264, in _create_graph
allow_unsatisfied=allow_unsatisfied):
File "/usr/bin/emerge", line 2542, in _add_pkg_deps
if not blocker and vardb.match(atom):
File "/usr/bin/emerge", line 1233, in _match_wrapper
matches = self._match(cpv, use_cache=use_cache)
File "/usr/bin/emerge", line 1917, in match
result = portage.dbapi.match(self, origdep, use_cache=use_cache)
File "/usr/lib/portage/pym/portage.py", line 6329, in match
mydep = dep_expand(origdep, mydb=self, settings=self.settings)
File "/usr/lib/portage/pym/portage.py", line 5753, in dep_expand
return portage_dep.Atom(prefix + expanded + postfix)
File "/usr/lib/portage/pym/portage_dep.py", line 289, in __init__
raise InvalidAtom(s)
portage_exception.InvalidAtom: >=app-crypt/gnupg-1.2*
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pascal Ronecker
Le #16517931
Didier Link a écrit :
des trucs super ;)



j'avais déjà retiré / remis une version a jour de gnupg mais sans que ca
ne change rien, il fallait doc bien chercher un package qui aie une
référence à gnupg-1.2. C'est dans /var/db/ que j'ai trouvé un résultat :
gpa

là je suis hyper surpris ! dans un premier temps, emerge app-crypt/gpa
commence bien, puis la compile se palnte en me disant que j'ai besoin de
gpgme>1.3. Je regarde, j'ai la version 1.2.
Et ca n'est pas apparu avec la gestion des dépendances ? c'est louche non ?

je prends donc gpgme entre quatres yeux, mais là c'est lui qui plante à
la fin de l'install :

/usr/bin/gpgsm --homedir . --import ./cert_g10code_test1.der
gpgsm: keybox `./pubring.kbx' created
gpgsm: importing common certificates `/usr/share/gnupg/com-certs.pem'
gpgsm: unknown hash algorithm `1.2.840.113549.1.1.11'
gpgsm: self-signed certificate has a BAD signature: General error
gpgsm: basic certificate checks failed - not imported
etc.
etc.

bon dans un premier temps je vais tenter en desinstallant gpgme et gpa,
on verra bien si ca avance mon probleme premier...


Tiens-nous au courant !! Et bon dimanche ;)



merci !


Didier



Pascal Ronecker
Le #16521091
Pascal Ronecker a écrit :
Didier Link a écrit :
des trucs super ;)



j'avais déjà retiré / remis une version a jour de gnupg mais sans que ca
ne change rien, il fallait doc bien chercher un package qui aie une
référence à gnupg-1.2. C'est dans /var/db/ que j'ai trouvé un résultat :
gpa

là je suis hyper surpris ! dans un premier temps, emerge app-crypt/gpa
commence bien, puis la compile se palnte en me disant que j'ai besoin de
gpgme>1.3. Je regarde, j'ai la version 1.2.
Et ca n'est pas apparu avec la gestion des dépendances ? c'est louche non ?

je prends donc gpgme entre quatres yeux, mais là c'est lui qui plante à
la fin de l'install :

/usr/bin/gpgsm --homedir . --import ./cert_g10code_test1.der
gpgsm: keybox `./pubring.kbx' created
gpgsm: importing common certificates `/usr/share/gnupg/com-certs.pem'
gpgsm: unknown hash algorithm `1.2.840.113549.1.1.11'
gpgsm: self-signed certificate has a BAD signature: General error
gpgsm: basic certificate checks failed - not imported
etc.
etc.

bon dans un premier temps je vais tenter en desinstallant gpgme et gpa,
on verra bien si ca avance mon probleme premier...



Apocalypse sur le systeme, passé apr le bug de mktemp absent,
revdep-rebuild de 117 packages,
et ... un seul soucis e vus pour le moment : libexpat.so.0 remplacé apr
libexpat.so.1, ce qui annonce encore un joli revdep.


et pas de nouvelles de gpgme pour le moment, m'enfin ca avance...




Tiens-nous au courant !! Et bon dimanche ;)



merci !

Didier







Publicité
Poster une réponse
Anonyme