[gentoo-user-fr] petit soucis sous CUPS

Le
thin
Bonsoir tout le monde,

je viens de mettre en place deux service CUPS sur deux gentoo..
j'y ai configuré une imprimante sur chacun d'entre eux et sur une
plate-forme l'imprimante se met automatiquement démarrée et sur
l'autre elle est automatique sur arrêté.

le problème est d'ordre pratique, il faut a chaque redémarrage de
service aller sur la conf web de cups et cliquer sur "démarrer
l'imprimante" pour pouvoir envoyer les job a l'imprimante.

j ai beau vérifier les paramétrages sur l'une ou l'autre machine et je =

ne vois pas de différences!!!!

si quelqu'un a déjà eu ce problème on ne sais jamais.


merci d'avance.

ps: se sont des machines reliées en USB.

-
This message was sent using IMP, the Internet Messaging Program.


--
gentoo-user-fr@gentoo.org mailing list
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
joris
Le #7803391
On 6/14/07, thin

Bonsoir tout le monde,

je viens de mettre en place deux service CUPS sur deux gentoo..
j'y ai configuré une imprimante sur chacun d'entre eux et sur une
plate-forme l'imprimante se met automatiquement démarrée et sur
l'autre elle est automatique sur arrêté.

le problème est d'ordre pratique, il faut a chaque redémarrage de
service aller sur la conf web de cups et cliquer sur "démarrer
l'imprimante" pour pouvoir envoyer les job a l'imprimante.

j ai beau vérifier les paramétrages sur l'une ou l'autre machine et j e
ne vois pas de différences!!!!

si quelqu'un a déjà eu ce problème... on ne sais jamais.


merci d'avance.

ps: se sont des machines reliées en USB.




Salut,

Je n'ai jamais eu ce genre de config en USB, mais par réseau j'ai déj à
eu des des imprimantes qui se mettaient en veille toutes seules.

Ma solution, un petit script dans un job cron

#!/bin/sh

logfile="/var/log/bernie.log"

printers=$( /usr/bin/lpstat -a | cut -d -f1 | xargs )

for p in $printers
do
/usr/bin/lpstat -p $p >/tmp/lpstat.tmp
/bin/grep --silent disabled /tmp/lpstat.tmp >/dev/null 2>&1
if [ $? -eq 0 ]
then
/usr/sbin/cupsenable $p
echo $( date +%D-%R ) $p redemarre >>$logfile
# un petit echo pour nous prevenir par mail
echo "Imprimante $p redemarree"
fi
done
--
mailing list
Eric Cloes
Le #7803271
thin a écrit :

Bonsoir tout le monde,

je viens de mettre en place deux service CUPS sur deux gentoo..
j'y ai configuré une imprimante sur chacun d'entre eux et sur une
plate-forme l'imprimante se met automatiquement démarrée et sur l'autre
elle est automatique sur arrêté.

le problème est d'ordre pratique, il faut a chaque redémarrage de
service aller sur la conf web de cups et cliquer sur "démarrer
l'imprimante" pour pouvoir envoyer les job a l'imprimante.

j ai beau vérifier les paramétrages sur l'une ou l'autre machine et je
ne vois pas de différences!!!!

si quelqu'un a déjà eu ce problème... on ne sais jamais.


merci d'avance.

ps: se sont des machines reliées en USB.

----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.




Je viens juste de rencontrer le problème. J'ai reemergé les packages
net-print déjà installés (cups, hplip, foomatic*) et l'imprimante est à
nouveau automatiquement démarrée.
--
mailing list
Publicité
Poster une réponse
Anonyme