[gentoo-user-fr] problème avec emacs-22 et le fichier .emacs

Le
Laurent Artaud
Bonjour.

Ça fait un moment que j'avais le problème, mais je n'avais pas le temps
de me pencher dessus et j'avais donc continué d'utiliser emacs-21.

Le .emacs que j'utilise avec la version 21 ne marche pas avec la 22. Au
début, je pensais qu'il n'était simplement pas lu (symptôme flagrant :
plus de coloration syntaxique, alors qu'elle est expressément activée
dans le .emacs) mais en supprimant le fichier, la coloration revient.
De même avec le scroll à la molette de la souris, qui ne fonctionne pas
avec le fichier .emacs présent, mais fonctionne sans

La syntaxe du fichier a changé ?

J'ai un peu cherché, mais je n'ai pas trouvé de référence à ce sujet

Merci de votre aide.

--
Laurent ARTAUD (laurent.artaud@free.fr)
--
gentoo-user-fr@lists.gentoo.org mailing list
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Mickael
Le #7800931
------=_Part_11700_29001595.1201616735919
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Le 18/01/08, Laurent Artaud

Bonjour.

Ça fait un moment que j'avais le problème, mais je n'avais pas le tem ps
de me pencher dessus et j'avais donc continué d'utiliser emacs-21.

Le .emacs que j'utilise avec la version 21 ne marche pas avec la 22. Au
début, je pensais qu'il n'était simplement pas lu (symptôme flagran t :
plus de coloration syntaxique, alors qu'elle est expressément activée
dans le .emacs) mais en supprimant le fichier, la coloration revient.
De même avec le scroll à la molette de la souris, qui ne fonctionne p as
avec le fichier .emacs présent, mais fonctionne sans...

La syntaxe du fichier a changé ?

J'ai un peu cherché, mais je n'ai pas trouvé de référence à ce sujet...

Merci de votre aide.

--
Laurent ARTAUD ()
--
mailing list




Salut,

est-ce que ton emacs gueule qqchose dans le buffer *MESSAGE* ?

As-tu essayé de le réécrire dans un nouveau fichier (from scratch)?

Mickael.

------=_Part_11700_29001595.1201616735919
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Bonjour. début, je pensais qu'il n'était simplement pas lu (symptôme f lagrant : De même avec le scroll à la molette de la souris, qui ne fonctionne pas
------=_Part_11700_29001595.1201616735919--
--
mailing list
Laurent Artaud
Le #7800921
Mickael a écrit :

Salut,

est-ce que ton emacs gueule qqchose dans le buffer *MESSAGE* ?

As-tu essayé de le réécrire dans un nouveau fichier (from scratch)?

Mickael.





J'avais essayé de le réécrire de zéro, en rajoutant une ligne à la fois, et ça
plantait dès la première... et par manque de temps, j'ai appelé à l'aide et
j'étais repassé en 21.

Par contre, effectivement, il râle dans *messages* (même pas pensé à regarder
s'il y avait un buffer d'erreur... quel sot!)

J'avais :
(mouse-wheel-mode)
(global-font-lock-mode)
qui marchaient pas et qui étaient rapides à repérer, et évidemment, un message :
Toggling mouse-wheel-mode off; better pass an explicit argument.
Toggling global-font-lock-mode off; better pass an explicit argument.
dans le buffer en question...
Si j'ai bien compris, mon .emacs marche! C'est simplement que ces valeurs sont
maintenant à ON par défaut et que je les passe à OFF au démarrage d'emacs, donc
je les ai plus...
En rajoutant un petit "t" à chaque ligne, ça marche de nouveau (ou tout du
moins, je précise vraiment ce que je veux, et ça va mieux ;-p)

Merci pour ton aide!

--
Laurent ARTAUD ()
--
mailing list
Mickael
Le #7800911
------=_Part_15074_16003153.1201676242469
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Le 29/01/08, Laurent Artaud

Mickael a écrit :
>
> Salut,
>
> est-ce que ton emacs gueule qqchose dans le buffer *MESSAGE* ?
>
> As-tu essayé de le réécrire dans un nouveau fichier (from scratch )?
>
> Mickael.
>
>

J'avais essayé de le réécrire de zéro, en rajoutant une ligne à la fois,
et ça
plantait dès la première... et par manque de temps, j'ai appelé à l'aide
et
j'étais repassé en 21.

Par contre, effectivement, il râle dans *messages* (même pas pensé à
regarder
s'il y avait un buffer d'erreur... quel sot!)

J'avais :
(mouse-wheel-mode)
(global-font-lock-mode)
qui marchaient pas et qui étaient rapides à repérer, et évidemmen t, un
message :
Toggling mouse-wheel-mode off; better pass an explicit argument.
Toggling global-font-lock-mode off; better pass an explicit argument.
dans le buffer en question...
Si j'ai bien compris, mon .emacs marche! C'est simplement que ces valeurs
sont
maintenant à ON par défaut et que je les passe à OFF au démarrage d'emacs,
donc
je les ai plus...
En rajoutant un petit "t" à chaque ligne, ça marche de nouveau (ou to ut du
moins, je précise vraiment ce que je veux, et ça va mieux ;-p)

Merci pour ton aide!




Mais de rien ;) juste au cas ou, avec la version 22 on peut maintenant se
faire des switch entre buffer avec un CTRL-x fleche doite ou fleche gauche,
en plus du traditionnel CRTL-x b META-x bs-show etcetc

menfin y'a plein de nouveauté.
ENJOY!

--
Laurent ARTAUD ()
--
mailing list





------=_Part_15074_16003153.1201676242469
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Mickael a écrit : &gt; Toggling mouse-wheel-mode off; better pass an explicit argument. maintenant à ON par défaut et que je les passe à OFF au démarrage d &#39;emacs, donc <br>Merci pour ton aide!</blockquote><div><br>Mais de rien ;)&nbsp; juste a u cas ou, avec la version 22&nbsp; on peut maintenant se faire des switch e ntre buffer avec un CTRL-x fleche doite ou fleche gauche, en plus du tradit ionnel CRTL-x b META-x bs-show etcetc<br>
--
------=_Part_15074_16003153.1201676242469--
--
mailing list
Publicité
Poster une réponse
Anonyme