[gentoo-user-fr] Soucis avec GTK

Le
Antoine Van-Elstraete
--nextPart2256177.4epsOnbOjU
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Bonjour à tous

Voilà j'ai un petit problème avec les application en GTK, certaines ne=
se
lance pas en se terminant pas un seg fault (erreur de segmentation [1] ) av=
ec
juste avant :

-%<-=
--
Gtk-CRITICAL **: gtk_widget_ensure_style: assertion `GTK_IS_WIDGET (widget)=
'
failed
-%<-=
--

Ça le fait pour audacity, xsane, mais pas gimp ni firefox.

Aucun indice du coté de revdep-rebuild.

x11-libs/wxGTK
Available versions: (2.6) 2.6.3.3
Installed versions: 2.6.3.3
(X -debug -doc -gnome -joystick -odbc opengl sdl unicode)

x11-libs/gtk+
Installed versions: (1) 1.2.10-r12 (2) 2.11.6
(debug linguas_fr nls)

media-sound/audacity-1.3.3
USE="flac mp3 unicode vorbis -ladspa -libsamplerate"

media-gfx/xsane-0.994
USE="nls jpeg png tiff gimp -lcms"

Merci de votre aide.

[1] D'ailleur, ça veut dire quoi "segmentation" ?
--
Antoine Van-Elstraete
Étudiant infirmier (C.H. Dunkerque)

http://bluecat.homelinux.net

--nextPart2256177.4epsOnbOjU
Content-Type: application/pgp-signature

--BEGIN PGP SIGNATURE--
Version: GnuPG v1.4.7 (GNU/Linux)

iD8DBQBGwXhZ/OFScBP7tMERAg8nAJsE7xS98I7zTbfGhOQvfJlFyT1jnACdG7Rk
RhvzxEQJPmlJ3YkE4ZSMEj4=
=8x/N
--END PGP SIGNATURE--

--nextPart2256177.4epsOnbOjU--
--
gentoo-user-fr@gentoo.org mailing list
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Yoann Pannier
Le #7802741
Antoine Van-Elstraete wrote, On 2007-08-14 11:39:
Voilà j'ai un petit problème avec les application en GTK, certaines ne se
lance pas en se terminant pas un seg fault (erreur de segmentation [1] ) avec
juste avant :



x11-libs/gtk+
Installed versions: (1) 1.2.10-r12 (2) 2.11.6



gtk+-2.11.6 c'est quand même une "unstable development release"¹ qui
n'existe pas dans portage (2.10.14 en ~arch)... A mon avis ceci explique
cela.

A part tenter de recompiler les applications incriminées et leurs
dépendances, et aller faire un tour sur le bugzilla² de gnome, je ne
vois pas.

1. http://mail.gnome.org/archives/gtk-devel-list/2007-July/msg00071.html
2. http://bugzilla.gnome.org/

--
Yoann Pannier
--
mailing list
Antoine Van-Elstraete
Le #7802711
--nextPart1460583.Yr0mXNcL1C
Content-Type: text/plain;
charset="utf-8"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Le mardi 14 août 2007 12:25, Yoann Pannier a écrit :
Antoine Van-Elstraete wrote, On 2007-08-14 11:39:
> Voilà j'ai un petit problème avec les application en GTK, ce rtaines ne
> se lance pas en se terminant pas un seg fault (erreur de segmentation [ 1]
> ) avec juste avant :
>
> x11-libs/gtk+
> Installed versions: (1) 1.2.10-r12 (2) 2.11.6

gtk+-2.11.6 c'est quand même une "unstable development release" ¹ qui
n'existe pas dans portage (2.10.14 en ~arch)... A mon avis ceci explique
cela.




J'ai en effet redescendu en 2.10.14, et c'est bon, ça marche :) J'avai s oublié
que j'avais cette overlay ^^

Merci :)

--
Antoine Van-Elstraete
Étudiant infirmier (C.H. Dunkerque)

http://bluecat.homelinux.net

--nextPart1460583.Yr0mXNcL1C
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)

iD8DBQBGwgtJ/OFScBP7tMERAr0oAJ0RRB30MWo4BkoLVDrCuR5DXQuMeACeLWsa
THr3IDXPk5lvnQCLxsnL7ho =O+bN
-----END PGP SIGNATURE-----

--nextPart1460583.Yr0mXNcL1C--
--
mailing list
Publicité
Poster une réponse
Anonyme