Gestion de Mises à Jour et paquets cassés sous Linux Mint

Le
jean b.
Bonjour,

Depuis quelques jours, je ne peux plus effectuer de mises à jour,
je me retrouve systématiquement avec le message : « Impossible
d'appliquer les changements. Réparez d'abord les paquets cassés ».

  J'ai beau tenter de retrouver ces paquets cassés via le
gestionnaire de paquets Synaptic, qui propose cette option de
réparer les paquets cassés, il ne trouve rien.

Y aurait-il une solution accessible à un youzeur de base ?

Merci !

--
jean b.
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
yamo'
Le #23321501
Salut,

jean b. a tapoté, le 30/04/2011 10:53:
« Impossible
d'appliquer les changements. Réparez d'abord les paquets cassés ».




Si c'est basé sur Ubuntu, ça arrive tous les 6 mois, faut attendre que
les serveurs soient un peut moins surchargés ou insister ;)


--
Stéphane


Au fond, je me donne des règles pour être totalement libre.
-+- Georges Perec (1936-1982), Olipien -+-
Sergio
Le #23321941
Le 30/04/2011 10:53, jean b. a écrit :
Bonjour,

Depuis quelques jours, je ne peux plus effectuer de mises à jour,
je me retrouve systématiquement avec le message : « Impossible
d'appliquer les changements. Réparez d'abord les paquets cassés ».

J'ai beau tenter de retrouver ces paquets cassés via le
gestionnaire de paquets Synaptic, qui propose cette option de
réparer les paquets cassés, il ne trouve rien.

Y aurait-il une solution accessible à un youzeur de base ?



J'ai ce script, que je lance de temps en temps, qui "nettoie" la base de paquets :

#!/bin/bash
sudo apt-get clean
sudo apt-get autoclean
sudo apt-get autoremove
sudo apt-get update
sudo apt-get upgrade

J'ignore si ça arrange ton cas... Sinon, la suggestion de yamo'...

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
jp willm
Le #23322351
Le 30/04/2011 15:14, Sergio a écrit :

J'ai ce script, que je lance de temps en temps, qui "nettoie" la base de
paquets :

#!/bin/bash
sudo apt-get clean
sudo apt-get autoclean
sudo apt-get autoremove
sudo apt-get update
sudo apt-get upgrade

J'ignore si ça arrange ton cas... Sinon, la suggestion de yamo'...




Je confirme, ça marche avec mint LMDE qui m'a affiché le même message.

J'ai par ailleurs lors de la mise à jour et à propos de grub-pc choisi
l'option "Installer la version du responsable des paquets".

Car grub plantait après un update-grub ou après installation d'un
nouveau noyau : le menu de démarrage de grub n'était pas mis à jour...

--
http://perso.orange.fr/willms/index.html
jean b.
Le #23322591
bonsoir,

le samedi 30 avril 2011 à 15:14, vous, *Sergio*, déclariez :

J'ai ce script, que je lance de temps en temps, qui "nettoie" la
base de paquets :
[...]



  N'ayant jamais été fichu de me servir convenablement d'un terminal
(je ne parviens pas à y publier mon mot de passe, c'est ballot), je
crois que je vais mettre à profit la méthode de yamo'.

  Merci à vous deux !

--
jean b.
moi-meme
Le #23322881
Le Sat, 30 Apr 2011 11:30:01 +0200, yamo' a écrit :

« Impossible
d'appliquer les changements. Réparez d'abord les paquets cassés ».





OK alors comment détecter les paquets cassés ?
La réinstallation n'a rien donné.



Si c'est basé sur Ubuntu, ça arrive tous les 6 mois, faut attendre que
les serveurs soient un peut moins surchargés ou insister



non c'est basé sur Debian mais avec des paquets non-libres et minimale.
jp willm
Le #23322901
Le 30/04/2011 18:43, jean b. a écrit :

N'ayant jamais été fichu de me servir convenablement d'un terminal
(je ne parviens pas à y publier mon mot de passe, c'est ballot), je
crois que je vais mettre à profit la méthode de yamo'.




Si tu veux avoir les droits admin et les garder tout au long de la session :

sudo -i > mot de passe que tu ne vois pas pendant la saisie > ensuite tu
as un # (exemple :~#) qui te montre que tu possède maintenant
les droits admin


Pour la mise à jour en utilisant apt :

apt-get update > Enter
apt-get upgrade > Enter

ou encore apt-get dist-upgrade > Enter


Pour la mise à jour vec aptitude, c'est les mêmes commandes sauf que tu
remplaces apt-get par aptitude

Merci à vous deux !


De rien :o)

--
http://perso.orange.fr/willms/index.html
jean b.
Le #23323091
re-bonsoir,

le samedi 30 avril 2011 à 20:05, vous, *jp willm*, déclariez :

Si tu veux avoir les droits admin et les garder tout au long de la
session :


[...]

  Aaah, merci infiniment ! Je garde ça sous le coude et mettrai ça
en pratique dès que possible !

--
jean b.
yamo'
Le #23323221
moi-meme a tapoté, le 30/04/2011 19:54:
OK alors comment détecter les paquets cassés ?
La réinstallation n'a rien donné.




Souvent apt-get update dit ce qui ne va pas et ce qu'il faut faire.



--
Stéphane


Pour sauver son crédit, il faut cacher sa perte.
-+- Jean de La Fontaine (1621-1695),
La Chauve-Souris, le Buisson, et le Canard (Fables XII.7) -+-
Publicité
Poster une réponse
Anonyme